aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-10 16:28:13 +0000
committerSam James <sam@gentoo.org>2022-05-10 16:28:13 +0000
commit3abdac2d4e66d1647fd3a49753a6334a4a40fe45 (patch)
tree8fc01c7f4fedd9223f4edb3a225f2492f5c5bdc4 /Makefile.gpyutils
parentBump pkgcheck2html (diff)
downloadqa-scripts-3abdac2d4e66d1647fd3a49753a6334a4a40fe45.tar.gz
qa-scripts-3abdac2d4e66d1647fd3a49753a6334a4a40fe45.tar.bz2
qa-scripts-3abdac2d4e66d1647fd3a49753a6334a4a40fe45.zip
Makefile.gpyutils: add Python 3.10 -> Python 3.11
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'Makefile.gpyutils')
-rw-r--r--Makefile.gpyutils5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.gpyutils b/Makefile.gpyutils
index 0379b03..59fdfc3 100644
--- a/Makefile.gpyutils
+++ b/Makefile.gpyutils
@@ -39,6 +39,11 @@ $(outdir)/depcheck.txt: $(timestamp)
gpy-depcheck > $@.new
mv $@.new $@
+$(outdir)/310-to-311.txt: $(timestamp)
+ mkdir -p $(outdir)
+ gpy-upgrade-impl -m python3_10 python3_11 > $@.new
+ mv $@.new $@
+
$(outdir)/39-to-310.txt: $(timestamp)
mkdir -p $(outdir)
gpy-upgrade-impl -m python3_9 python3_10 > $@.new