aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-10 21:56:48 +0000
committerSam James <sam@gentoo.org>2022-05-10 21:56:48 +0000
commit0e178cee8e359a69abdab408d3a36a1cac75ffb0 (patch)
treead3f54498e002c972bcdad6f7581a3b9434f9506 /Makefile.gpyutils
parenthtdocs: add link to Python 3.10 -> Python 3.11 lists (diff)
downloadqa-scripts-0e178cee8e359a69abdab408d3a36a1cac75ffb0.tar.gz
qa-scripts-0e178cee8e359a69abdab408d3a36a1cac75ffb0.tar.bz2
qa-scripts-0e178cee8e359a69abdab408d3a36a1cac75ffb0.zip
Makefile.gpyutils: try harder to add Python 3.11
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'Makefile.gpyutils')
-rw-r--r--Makefile.gpyutils7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.gpyutils b/Makefile.gpyutils
index 59fdfc3..34d93af 100644
--- a/Makefile.gpyutils
+++ b/Makefile.gpyutils
@@ -6,7 +6,7 @@ timestamp = $(PORTDIR)/metadata/timestamp.commit
outdir = /dev/null
# upgrades for stable impls
-upgr_base = $(outdir)/39-to-310.txt $(outdir)/38-to-39.txt
+upgr_base = $(outdir)/310-to-311.txt $(outdir)/39-to-310.txt $(outdir)/38-to-39.txt
# related stabilizations
upgr_streq = $(patsubst %.txt,%-stablereq.txt,$(upgr_base))
# all upgrade stuff
@@ -44,6 +44,11 @@ $(outdir)/310-to-311.txt: $(timestamp)
gpy-upgrade-impl -m python3_10 python3_11 > $@.new
mv $@.new $@
+$(outdir)/39-to-310-stablereq.txt: $(timestamp)
+ mkdir -p $(outdir)
+ gpy-upgrade-impl -m -s python3_10 python3_11 > $@.new
+ mv $@.new $@
+
$(outdir)/39-to-310.txt: $(timestamp)
mkdir -p $(outdir)
gpy-upgrade-impl -m python3_9 python3_10 > $@.new