summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-06-21 09:18:23 +0000
committerAli Polatel <hawking@gentoo.org>2008-06-21 09:18:23 +0000
commitedccbf510ffa3a99f132942c57e210fec112d12d (patch)
tree372d9ed34e7b51334fa57af12653e1a721895827
parentFixed veinfo. (diff)
downloadpython-updater-edccbf510ffa3a99f132942c57e210fec112d12d.tar.gz
python-updater-edccbf510ffa3a99f132942c57e210fec112d12d.tar.bz2
python-updater-edccbf510ffa3a99f132942c57e210fec112d12d.zip
List checks in help output, make indenting nicer. Cosmetics.
-rw-r--r--ChangeLog5
-rw-r--r--Makefile3
-rw-r--r--man.include10
-rwxr-xr-xpython-updater34
4 files changed, 37 insertions, 15 deletions
diff --git a/ChangeLog b/ChangeLog
index d28e571..8f4ceda 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -3,6 +3,11 @@ ChangeLog for python-updater
This file lists all changes except typo and formatting fixes.
+2008-06-21 Ali Polatel
+
+ * python-updater, man.include, Makefile: List checks in help output
+ and make indenting a bit nicer. Man page cosmetics.
+
2008-06-20 Ali Polatel
* python-updater: Fixed veinfo
diff --git a/Makefile b/Makefile
index 885ae36..6f61b15 100644
--- a/Makefile
+++ b/Makefile
@@ -9,7 +9,8 @@ all: python-updater.1 tarball
python-updater.1: python-updater $(MAN_INCLUDE)
help2man -L en_GB.UTF-8 -Ni $(MAN_INCLUDE) ./python-updater -o $@
- sed -i -e 's/ in the manpage//' $@
+ sed -i -e 's/ in the manpage//' \
+ -e 's/\*[[:space:]]\([[:alpha:]]*\).*/\1 /' $@
.PHONY: all clean tarball upload
clean:
diff --git a/man.include b/man.include
index 33d52c7..7349419 100644
--- a/man.include
+++ b/man.include
@@ -28,8 +28,8 @@ See EXAMPLES for a list examples.
See ENVIRONMENT on how to set default options to override
[COPYRIGHT]
-Copyright (c) 2007-2008 Gentoo Foundation
-Distributed under the terms of the GNU General Public License v2
+Copyright \(co 2007-2008 Gentoo Foundation,
+distributed under the terms of the GNU General Public License v2
[REPORTING BUGS]
Submit bug reports to https://bugs.gentoo.org/
[AUTHORS]
@@ -40,16 +40,16 @@ Ali Polatel "hawking" <hawking@gentoo.org>
Current maintainer
[EXAMPLES]
-* Rebuild packages after a python upgrade. Default options are just fine ;)
+\(bu Rebuild packages after a python upgrade. Default options are just fine ;)
$> python-updater
-* Rebuild packages omitting manually added ones:
+\(bu Rebuild packages omitting manually added ones:
$> python-updater -dmanual
$> python-updater -disable-manual
-* You can use unique substrings instead of names for checks:
+\(bu You can use unique substrings instead of names for checks:
$> python-updater -dm -ep
$> python-updater --disable-m --enable-pylib
diff --git a/python-updater b/python-updater
index f6d89c9..e41e784 100755
--- a/python-updater
+++ b/python-updater
@@ -73,17 +73,29 @@ Options:
Ignore versions when remerging packages
(still respects SLOTs)
-P PM, --package-manager PM
- Select between ${SUPPORTED_PMS} [default: portage]
+ Use package manager PM, where PM can be one of:
+$(for p in ${SUPPORTED_PMS} ; do
+echo -ne $'\t\t '\* ${p}
+if [[ ${p} == portage ]]; then
+ echo ' (Default)'
+else
+ echo
+fi
+done)
-c CMD, --command CMD
Pipe found packages to command CMD instead of invoking package
manager. Only for debug and script use.
-eCHECK --enable-CHECK
- Enable CHECK
+ Enable CHECK where CHECK can be one of:
+ * eclass (Disabled by default)
+ * pylibdir (Enabled by default)
+ * soname (Enabled by default)
+ * manual (Enabled by default)
-dCHECK --disable-CHECK
- Disable CHECK
+ Disable CHECK. See --enable option for a list of checks
-See CHECKS section in the manpage for a list of checks and EXAMPLES section to
-learn how to use them.
+See CHECKS section in the manpage for explanations about checks and
+EXAMPLES section to learn how to use them.
EOF_USAGE
}
@@ -330,8 +342,9 @@ for content in `find ${PKG_DBDIR} -name CONTENTS`; do
PKGS_TO_REMERGE="${PKGS_TO_REMERGE} ${CATPKGVER}"
eindent
einfo "Adding to list: ${CATPKGVER}"
+ eindent
veinfo 1 "check: manual [Added to list manually]"
- eoutdent
+ eoutdent && eoutdent
continue
fi
@@ -345,8 +358,9 @@ for content in `find ${PKG_DBDIR} -name CONTENTS`; do
PKGS_TO_REMERGE="${PKGS_TO_REMERGE} ${CATPKGVER}"
eindent
einfo "Adding to list: ${CATPKGVER}"
+ eindent
veinfo 1 "check: pylibdir [ Installed file under old python library directory ]"
- eoutdent
+ eoutdent && eoutdent
continue
fi
fi
@@ -358,10 +372,11 @@ for content in `find ${PKG_DBDIR} -name CONTENTS`; do
PKGS_TO_REMERGE="${PKGS_TO_REMERGE} ${CATPKGVER}"
eindent
einfo "Adding to list: ${CATPKGVER}"
+ eindent
veinfo 1 "check: soname [ Libraries linked to old libpython found:"
veinfo 1 "${broken_libs}"
veinfo 1 "]"
- eoutdent
+ eoutdent && eoutdent
fi
fi
@@ -371,8 +386,9 @@ for content in `find ${PKG_DBDIR} -name CONTENTS`; do
PKGS_TO_REMERGE="${PKGS_TO_REMERGE} ${CATPKGVER}"
eindent
einfo "Adding to list: ${CATPKGVER}"
+ eindent
veinfo 1 "check: environ [ Ebuild set PYVER=${OLD_PY_VER} ]"
- eoutdent
+ eoutdent && eoutdent
continue
fi
fi