summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-02-19 11:01:11 -0500
committerMike Gilbert <floppym@gentoo.org>2017-02-19 11:48:46 -0500
commit84ac0797eb7ae46ad617de2e9ec0cbe88a3b9aee (patch)
treec4a507df6c615b4e829d3101710cfb4a9ab49663
parentUpdates from Arfrever (diff)
downloadpython-gentoo-patches-3.5.3-0.tar.gz
python-gentoo-patches-3.5.3-0.tar.bz2
python-gentoo-patches-3.5.3-0.zip
Updates for 3.5.3 from Arfrever3.5.3-0
-rw-r--r--patches/01_all_static_library_location.patch6
-rw-r--r--patches/02_all_disable_modules_and_ssl.patch10
-rw-r--r--patches/03_all_libdir.patch16
-rw-r--r--patches/04_all_non-zero_exit_status_on_failure.patch12
-rw-r--r--patches/05_all_regenerate_platform-specific_modules.patch12
-rw-r--r--patches/21_all_distutils_c++.patch2
-rw-r--r--patches/22_all_tests_environment.patch12
-rw-r--r--patches/24_all_expat-2.2.patch19
8 files changed, 35 insertions, 54 deletions
diff --git a/patches/01_all_static_library_location.patch b/patches/01_all_static_library_location.patch
index 3180c73..56c6ff0 100644
--- a/patches/01_all_static_library_location.patch
+++ b/patches/01_all_static_library_location.patch
@@ -4,7 +4,7 @@ https://bugs.python.org/issue6103
--- Makefile.pre.in
+++ Makefile.pre.in
-@@ -1061,6 +1061,19 @@
+@@ -1047,6 +1047,19 @@
$(RUNSHARED) $(PYTHON_FOR_BUILD) -m ensurepip \
$$ensurepip --root=$(DESTDIR)/ ; \
fi
@@ -24,7 +24,7 @@ https://bugs.python.org/issue6103
commoninstall: @FRAMEWORKALTINSTALLFIRST@ \
altbininstall libinstall inclinstall libainstall \
-@@ -1398,18 +1411,6 @@
+@@ -1385,18 +1398,6 @@
else true; \
fi; \
done
@@ -82,7 +82,7 @@ https://bugs.python.org/issue6103
echo "$SO"
--- Modules/makesetup
+++ Modules/makesetup
-@@ -89,7 +89,7 @@
+@@ -90,7 +90,7 @@
then
ExtraLibDir=.
else
diff --git a/patches/02_all_disable_modules_and_ssl.patch b/patches/02_all_disable_modules_and_ssl.patch
index 6ad321a..f782624 100644
--- a/patches/02_all_disable_modules_and_ssl.patch
+++ b/patches/02_all_disable_modules_and_ssl.patch
@@ -1,6 +1,6 @@
--- setup.py
+++ setup.py
-@@ -44,7 +44,17 @@
+@@ -43,7 +43,17 @@
COMPILED_WITH_PYDEBUG = ('--with-pydebug' in sysconfig.get_config_var("CONFIG_ARGS"))
# This global variable is used to hold the list of modules to be disabled.
@@ -19,7 +19,7 @@
def add_dir_to_list(dirlist, dir):
"""Add the directory 'dir' to the list 'dirlist' (after any relative
-@@ -488,6 +498,7 @@
+@@ -487,6 +497,7 @@
return ['m']
def detect_modules(self):
@@ -27,7 +27,7 @@
# Ensure that /usr/local is always used, but the local build
# directories (i.e. '.' and 'Include') must be first. See issue
# 10520.
-@@ -815,7 +826,7 @@
+@@ -814,7 +825,7 @@
ssl_incs = find_file('openssl/ssl.h', inc_dirs,
search_for_ssl_incs_in
)
@@ -36,7 +36,7 @@
krb5_h = find_file('krb5.h', inc_dirs,
['/usr/kerberos/include'])
if krb5_h:
-@@ -826,7 +837,8 @@
+@@ -825,7 +836,8 @@
] )
if (ssl_incs is not None and
@@ -46,7 +46,7 @@
exts.append( Extension('_ssl', ['_ssl.c'],
include_dirs = ssl_incs,
library_dirs = ssl_libs,
-@@ -859,7 +871,7 @@
+@@ -858,7 +870,7 @@
#print('openssl_ver = 0x%08x' % openssl_ver)
min_openssl_ver = 0x00907000
diff --git a/patches/03_all_libdir.patch b/patches/03_all_libdir.patch
index 39a70c9..3fa0528 100644
--- a/patches/03_all_libdir.patch
+++ b/patches/03_all_libdir.patch
@@ -78,7 +78,7 @@
else:
--- Makefile.pre.in
+++ Makefile.pre.in
-@@ -125,7 +125,7 @@
+@@ -126,7 +126,7 @@
MANDIR= @mandir@
INCLUDEDIR= @includedir@
CONFINCLUDEDIR= $(exec_prefix)/include
@@ -129,7 +129,7 @@
--- configure.ac
+++ configure.ac
-@@ -4456,7 +4456,7 @@
+@@ -4524,7 +4524,7 @@
dnl define LIBPL after ABIFLAGS and LDVERSION is defined.
AC_SUBST(PY_ENABLE_SHARED)
@@ -140,7 +140,7 @@
# Check whether right shifting a negative integer extends the sign bit
--- setup.py
+++ setup.py
-@@ -503,7 +503,7 @@
+@@ -502,7 +502,7 @@
# directories (i.e. '.' and 'Include') must be first. See issue
# 10520.
if not cross_compiling:
@@ -149,7 +149,7 @@
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
# only change this for cross builds for 3.3, issues on Mageia
if cross_compiling:
-@@ -560,8 +560,7 @@
+@@ -559,8 +559,7 @@
# be assumed that no additional -I,-L directives are needed.
if not cross_compiling:
lib_dirs = self.compiler.library_dirs + [
@@ -159,7 +159,7 @@
]
inc_dirs = self.compiler.include_dirs + ['/usr/include']
else:
-@@ -791,11 +790,11 @@
+@@ -790,11 +789,11 @@
elif curses_library:
readline_libs.append(curses_library)
elif self.compiler.find_library_file(lib_dirs +
@@ -173,7 +173,7 @@
extra_link_args=readline_extra_link_args,
libraries=readline_libs) )
else:
-@@ -1052,8 +1051,7 @@
+@@ -1051,8 +1050,7 @@
# check lib directories parallel to the location of the header
db_dirs_to_check = [
@@ -183,7 +183,7 @@
]
if host_platform != 'darwin':
-@@ -1164,10 +1162,8 @@
+@@ -1163,10 +1161,8 @@
if sqlite_incdir:
sqlite_dirs_to_check = [
@@ -196,7 +196,7 @@
]
sqlite_libfile = self.compiler.find_library_file(
sqlite_dirs_to_check + lib_dirs, 'sqlite3')
-@@ -1815,15 +1811,14 @@
+@@ -1814,15 +1810,14 @@
added_lib_dirs.append('/usr/openwin/lib')
elif os.path.exists('/usr/X11R6/include'):
include_dirs.append('/usr/X11R6/include')
diff --git a/patches/04_all_non-zero_exit_status_on_failure.patch b/patches/04_all_non-zero_exit_status_on_failure.patch
index 11667b9..e92f9bf 100644
--- a/patches/04_all_non-zero_exit_status_on_failure.patch
+++ b/patches/04_all_non-zero_exit_status_on_failure.patch
@@ -3,7 +3,7 @@ https://bugs.python.org/issue6731
--- setup.py
+++ setup.py
-@@ -56,6 +56,8 @@
+@@ -55,6 +55,8 @@
else:
disable_ssl = 0
@@ -12,9 +12,9 @@ https://bugs.python.org/issue6731
def add_dir_to_list(dirlist, dir):
"""Add the directory 'dir' to the list 'dirlist' (after any relative
directories) if:
-@@ -313,7 +315,10 @@
- " detect_modules() for the module's name.")
- print()
+@@ -312,7 +314,10 @@
+ " Setup files:")
+ print_three_column([ext.name for ext in removed_modules])
+ global exit_status
+
@@ -23,7 +23,7 @@ https://bugs.python.org/issue6731
failed = self.failed[:]
print()
print("Failed to build these modules:")
-@@ -321,6 +326,7 @@
+@@ -320,6 +325,7 @@
print()
if self.failed_on_import:
@@ -31,7 +31,7 @@ https://bugs.python.org/issue6731
failed = self.failed_on_import[:]
print()
print("Following modules built successfully"
-@@ -2286,6 +2292,7 @@
+@@ -2287,6 +2293,7 @@
scripts = ["Tools/scripts/pydoc3", "Tools/scripts/idle3",
"Tools/scripts/2to3", "Tools/scripts/pyvenv"]
)
diff --git a/patches/05_all_regenerate_platform-specific_modules.patch b/patches/05_all_regenerate_platform-specific_modules.patch
index 39329ad..b8d412c 100644
--- a/patches/05_all_regenerate_platform-specific_modules.patch
+++ b/patches/05_all_regenerate_platform-specific_modules.patch
@@ -37,16 +37,16 @@ https://bugs.python.org/issue12619
+python$EXE ../../Tools/scripts/h2py.py /usr/include/sys/stropts.h
--- Makefile.pre.in
+++ Makefile.pre.in
-@@ -482,7 +482,7 @@
+@@ -483,7 +483,7 @@
# Default target
- all: build_all
+ all: @DEF_MAKE_ALL_RULE@
-build_all: $(BUILDPYTHON) oldsharedmods sharedmods gdbhooks Programs/_testembed python-config
+build_all: $(BUILDPYTHON) oldsharedmods sharedmods platformspecificmods gdbhooks Programs/_testembed python-config
# Compile a binary with profile guided optimization.
profile-opt:
-@@ -606,6 +606,32 @@
+@@ -607,6 +607,32 @@
_TCLTK_INCLUDES='$(TCLTK_INCLUDES)' _TCLTK_LIBS='$(TCLTK_LIBS)' \
$(PYTHON_FOR_BUILD) $(srcdir)/setup.py $$quiet build
@@ -79,7 +79,7 @@ https://bugs.python.org/issue12619
# Build static library
# avoid long command lines, same as LIBRARY_OBJS
$(LIBRARY): $(LIBRARY_OBJS)
-@@ -1254,7 +1280,7 @@
+@@ -1241,7 +1267,7 @@
unittest unittest/test unittest/test/testmock \
venv venv/scripts venv/scripts/posix \
curses pydoc_data $(MACHDEPS)
@@ -88,7 +88,7 @@ https://bugs.python.org/issue12619
@for i in $(SCRIPTDIR) $(LIBDEST); \
do \
if test ! -d $(DESTDIR)$$i; then \
-@@ -1346,23 +1372,6 @@
+@@ -1333,23 +1359,6 @@
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
$(PYTHON_FOR_BUILD) -m lib2to3.pgen2.driver $(DESTDIR)$(LIBDEST)/lib2to3/PatternGrammar.txt
@@ -112,7 +112,7 @@ https://bugs.python.org/issue12619
python-config: $(srcdir)/Misc/python-config.in Misc/python-config.sh
# Substitution happens here, as the completely-expanded BINDIR
# is not available in configure
-@@ -1691,7 +1700,7 @@
+@@ -1682,7 +1691,7 @@
Python/thread.o: @THREADHEADERS@
# Declare targets that aren't real files
diff --git a/patches/21_all_distutils_c++.patch b/patches/21_all_distutils_c++.patch
index 877af24..9b2ed60 100644
--- a/patches/21_all_distutils_c++.patch
+++ b/patches/21_all_distutils_c++.patch
@@ -229,7 +229,7 @@ https://bugs.python.org/issue1222585
linker = _osx_support.compiler_fixup(linker, ld_args)
--- Makefile.pre.in
+++ Makefile.pre.in
-@@ -602,7 +602,7 @@
+@@ -603,7 +603,7 @@
*\ -s*|s*) quiet="-q";; \
*) quiet="";; \
esac; \
diff --git a/patches/22_all_tests_environment.patch b/patches/22_all_tests_environment.patch
index 656f00b..4bd2589 100644
--- a/patches/22_all_tests_environment.patch
+++ b/patches/22_all_tests_environment.patch
@@ -27,7 +27,7 @@ https://bugs.python.org/issue1674555
try:
import threading
-@@ -434,7 +435,6 @@
+@@ -437,7 +438,6 @@
subprocess exits, its return code, stdout and stderr are returned as a
3-tuple.
"""
@@ -35,7 +35,7 @@ https://bugs.python.org/issue1674555
base_cmd = ([sys.executable] + support.args_from_interpreter_flags() +
['-X', 'faulthandler', '-m', 'test.regrtest'])
# required to spawn a new process with PGO flag on/off
-@@ -657,9 +657,62 @@
+@@ -660,9 +660,62 @@
support.use_resources = ns.use_resources
save_modules = sys.modules.keys()
@@ -99,7 +99,7 @@ https://bugs.python.org/issue1674555
test_times.append((test_time, test))
if ok == PASSED:
good.append(test)
-@@ -773,15 +826,15 @@
+@@ -776,15 +829,15 @@
if ns.trace:
# If we're tracing code coverage, then we don't exit with status
# if on a false return value from main.
@@ -121,7 +121,7 @@ https://bugs.python.org/issue1674555
accumulate_result(test, result)
except KeyboardInterrupt:
interrupted = True
-@@ -835,8 +888,8 @@
+@@ -838,8 +891,8 @@
sys.stdout.flush()
try:
ns.verbose = True
@@ -132,7 +132,7 @@ https://bugs.python.org/issue1674555
except KeyboardInterrupt:
# print a newline separate from the ^C
print()
-@@ -1261,8 +1314,9 @@
+@@ -1259,8 +1312,9 @@
for name, get, restore in self.resource_info():
current = get()
original = saved_values.pop(name)
@@ -179,7 +179,7 @@ https://bugs.python.org/issue1674555
stdout, stderr = popen.communicate()
--- Makefile.pre.in
+++ Makefile.pre.in
-@@ -1016,7 +1016,7 @@
+@@ -1002,7 +1002,7 @@
######################################################################
TESTOPTS= $(EXTRATESTOPTS)
diff --git a/patches/24_all_expat-2.2.patch b/patches/24_all_expat-2.2.patch
deleted file mode 100644
index bd69580..0000000
--- a/patches/24_all_expat-2.2.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-https://bugs.python.org/issue27369
-https://hg.python.org/cpython/rev/0fbf3b88eed8
-
---- Lib/test/test_pyexpat.py
-+++ Lib/test/test_pyexpat.py
-@@ -656,11 +656,9 @@
- # \xc2\x85 is UTF-8 encoded U+0085 (NEXT LINE)
- xml = b"<?xml version\xc2\x85='1.0'?>\r\n"
- parser = expat.ParserCreate()
-- try:
-+ err_pattern = r'XML declaration not well-formed: line 1, column \d+'
-+ with self.assertRaisesRegex(expat.ExpatError, err_pattern):
- parser.Parse(xml, True)
-- self.fail()
-- except expat.ExpatError as e:
-- self.assertEqual(str(e), 'XML declaration not well-formed: line 1, column 14')
-
- class ErrorMessageTest(unittest.TestCase):
- def test_codes(self):