summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/postgresql-libs/files/postgresql-8.0-libs.patch')
-rw-r--r--dev-db/postgresql-libs/files/postgresql-8.0-libs.patch106
1 files changed, 0 insertions, 106 deletions
diff --git a/dev-db/postgresql-libs/files/postgresql-8.0-libs.patch b/dev-db/postgresql-libs/files/postgresql-8.0-libs.patch
deleted file mode 100644
index ba9ed64..0000000
--- a/dev-db/postgresql-libs/files/postgresql-8.0-libs.patch
+++ /dev/null
@@ -1,106 +0,0 @@
-diff --git a/GNUmakefile.in b/GNUmakefile.in
-index c451bd6..10f8f42 100644
---- a/GNUmakefile.in
-+++ b/GNUmakefile.in
-@@ -9,19 +9,16 @@ top_builddir = .
- include $(top_builddir)/src/Makefile.global
-
- all:
-- $(MAKE) -C doc all
- $(MAKE) -C src all
- $(MAKE) -C config all
- @echo "All of PostgreSQL successfully made. Ready to install."
-
- install:
-- $(MAKE) -C doc $@
- $(MAKE) -C src $@
- $(MAKE) -C config $@
- @echo "PostgreSQL installation complete."
-
- installdirs uninstall distprep:
-- $(MAKE) -C doc $@
- $(MAKE) -C src $@
- $(MAKE) -C config $@
-
-diff --git a/src/Makefile b/src/Makefile
-index 0963f88..dc7cdb9 100644
---- a/src/Makefile
-+++ b/src/Makefile
-@@ -15,13 +15,10 @@ include Makefile.global
-
- all install installdirs uninstall dep depend distprep:
- $(MAKE) -C port $@
-- $(MAKE) -C timezone $@
- $(MAKE) -C backend $@
-- $(MAKE) -C backend/utils/mb/conversion_procs $@
- $(MAKE) -C include $@
- $(MAKE) -C interfaces $@
- $(MAKE) -C bin $@
-- $(MAKE) -C pl $@
- $(MAKE) -C makefiles $@
- $(MAKE) -C utils $@
-
-diff --git a/src/backend/Makefile b/src/backend/Makefile
-index 2bbdc8e..79aabf1 100644
---- a/src/backend/Makefile
-+++ b/src/backend/Makefile
-@@ -34,7 +34,7 @@ endif
-
- ##########################################################################
-
--all: submake-libpgport postgres $(POSTGRES_IMP)
-+all: someheaders
-
- ifneq ($(PORTNAME), cygwin)
- ifneq ($(PORTNAME), win32)
-@@ -104,8 +104,7 @@ $(SUBSYSOBJS): $(DIRS:%=%-recursive) ;
-
- .PHONY: $(DIRS:%=%-recursive)
- # Update the commonly used headers before building the subdirectories
--$(DIRS:%=%-recursive): $(top_builddir)/src/include/parser/parse.h $(top_builddir)/src/include/utils/fmgroids.h
-- $(MAKE) -C $(subst -recursive,,$@) all
-+someheaders $(DIRS:%=%-recursive): $(top_builddir)/src/include/parser/parse.h $(top_builddir)/src/include/utils/fmgroids.h
-
-
- $(DLLINIT): $(DLLINIT:%.o=%.c)
-@@ -151,22 +150,7 @@ distprep:
-
- ##########################################################################
-
--install: all installdirs install-bin
--ifeq ($(PORTNAME), cygwin)
--ifeq ($(MAKE_DLL), true)
-- $(INSTALL_DATA) libpostgres.a $(DESTDIR)$(libdir)/libpostgres.a
--endif
--endif
--ifeq ($(PORTNAME), win32)
--ifeq ($(MAKE_DLL), true)
-- $(INSTALL_DATA) libpostgres.a $(DESTDIR)$(libdir)/libpostgres.a
--endif
--endif
-- $(MAKE) -C catalog install-data
-- $(INSTALL_DATA) $(srcdir)/libpq/pg_hba.conf.sample $(DESTDIR)$(datadir)/pg_hba.conf.sample
-- $(INSTALL_DATA) $(srcdir)/libpq/pg_ident.conf.sample $(DESTDIR)$(datadir)/pg_ident.conf.sample
-- $(INSTALL_DATA) $(srcdir)/utils/misc/postgresql.conf.sample $(DESTDIR)$(datadir)/postgresql.conf.sample
-- $(INSTALL_DATA) $(srcdir)/access/transam/recovery.conf.sample $(DESTDIR)$(datadir)/recovery.conf.sample
-+install:
-
- install-bin: postgres $(POSTGRES_IMP) installdirs
- $(INSTALL_PROGRAM) postgres$(X) $(DESTDIR)$(bindir)/postgres$(X)
-diff --git a/src/bin/Makefile b/src/bin/Makefile
-index 8309db1..e645ff2 100644
---- a/src/bin/Makefile
-+++ b/src/bin/Makefile
-@@ -13,11 +13,7 @@ subdir = src/bin
- top_builddir = ../..
- include $(top_builddir)/src/Makefile.global
-
--DIRS := initdb ipcclean pg_ctl pg_dump \
-- psql scripts pg_config pg_controldata pg_resetxlog
--ifeq ($(PORTNAME), win32)
--DIRS+=pgevent
--endif
-+DIRS := pg_config
-
- all install installdirs uninstall depend distprep:
- @for dir in $(DIRS); do $(MAKE) -C $$dir $@ || exit; done