summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/postgresql-libs/files/postgresql-7.4-libs.patch')
-rw-r--r--dev-db/postgresql-libs/files/postgresql-7.4-libs.patch100
1 files changed, 0 insertions, 100 deletions
diff --git a/dev-db/postgresql-libs/files/postgresql-7.4-libs.patch b/dev-db/postgresql-libs/files/postgresql-7.4-libs.patch
deleted file mode 100644
index a619303..0000000
--- a/dev-db/postgresql-libs/files/postgresql-7.4-libs.patch
+++ /dev/null
@@ -1,100 +0,0 @@
-diff --git a/GNUmakefile.in b/GNUmakefile.in
-index 563532a..d2bd525 100644
---- a/GNUmakefile.in
-+++ b/GNUmakefile.in
-@@ -9,17 +9,14 @@ top_builddir = .
- include $(top_builddir)/src/Makefile.global
-
- all:
-- $(MAKE) -C doc all
- $(MAKE) -C src all
- @echo "All of PostgreSQL successfully made. Ready to install."
-
- install:
-- $(MAKE) -C doc install
- $(MAKE) -C src install
- @echo "PostgreSQL installation complete."
-
- installdirs uninstall distprep:
-- $(MAKE) -C doc $@
- $(MAKE) -C src $@
-
- install-all-headers:
-diff --git a/src/Makefile b/src/Makefile
-index cd6e5e6..bc535d5 100644
---- a/src/Makefile
-+++ b/src/Makefile
-@@ -16,11 +16,9 @@ include Makefile.global
- all install installdirs uninstall dep depend distprep:
- $(MAKE) -C port $@
- $(MAKE) -C backend $@
-- $(MAKE) -C backend/utils/mb/conversion_procs $@
- $(MAKE) -C include $@
- $(MAKE) -C interfaces $@
- $(MAKE) -C bin $@
-- $(MAKE) -C pl $@
-
- install-all-headers:
- $(MAKE) -C include $@
-diff --git a/src/backend/Makefile b/src/backend/Makefile
-index 82cdd0f..88d302a 100644
---- a/src/backend/Makefile
-+++ b/src/backend/Makefile
-@@ -29,7 +29,7 @@ endif
-
- ##########################################################################
-
--all: submake-libpgport postgres $(POSTGRES_IMP)
-+all: someheaders
-
- ifneq ($(PORTNAME), cygwin)
-
-@@ -78,8 +78,7 @@ $(OBJS): $(DIRS:%=%-recursive) ;
-
- .PHONY: $(DIRS:%=%-recursive)
- # Update the commonly used headers before building the subdirectories
--$(DIRS:%=%-recursive): $(top_builddir)/src/include/parser/parse.h $(top_builddir)/src/include/utils/fmgroids.h
-- $(MAKE) -C $(subst -recursive,,$@) all
-+someheaders $(DIRS:%=%-recursive): $(top_builddir)/src/include/parser/parse.h $(top_builddir)/src/include/utils/fmgroids.h
-
-
- $(DLLINIT): $(DLLINIT:%.o=%.c)
-@@ -125,16 +124,7 @@ distprep:
-
- ##########################################################################
-
--install: all installdirs install-bin
--ifeq ($(PORTNAME), cygwin)
--ifeq ($(MAKE_DLL), true)
-- $(INSTALL_DATA) libpostgres.a $(DESTDIR)$(libdir)/libpostgres.a
--endif
--endif
-- $(MAKE) -C catalog install-data
-- $(INSTALL_DATA) $(srcdir)/libpq/pg_hba.conf.sample $(DESTDIR)$(datadir)/pg_hba.conf.sample
-- $(INSTALL_DATA) $(srcdir)/libpq/pg_ident.conf.sample $(DESTDIR)$(datadir)/pg_ident.conf.sample
-- $(INSTALL_DATA) $(srcdir)/utils/misc/postgresql.conf.sample $(DESTDIR)$(datadir)/postgresql.conf.sample
-+install:
-
- install-bin: postgres $(POSTGRES_IMP) installdirs
- $(INSTALL_PROGRAM) postgres$(X) $(DESTDIR)$(bindir)/postgres$(X)
-diff --git a/src/bin/Makefile b/src/bin/Makefile
-index 3035f61..469c6e0 100644
---- a/src/bin/Makefile
-+++ b/src/bin/Makefile
-@@ -13,14 +13,10 @@ subdir = src/bin
- top_builddir = ../..
- include $(top_builddir)/src/Makefile.global
-
--DIRS := initdb initlocation ipcclean pg_ctl pg_dump pg_id \
-- psql scripts pg_config pg_controldata pg_resetxlog \
-+DIRS := \
-+ pg_config \
- pg_encoding
-
--ifeq ($(with_tcl), yes)
-- DIRS += pgtclsh
--endif
--
- all install installdirs uninstall depend distprep:
- @for dir in $(DIRS); do $(MAKE) -C $$dir $@ || exit; done
-