summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/postgresql-client/postgresql-client-8.2.6.ebuild')
-rw-r--r--dev-db/postgresql-client/postgresql-client-8.2.6.ebuild98
1 files changed, 0 insertions, 98 deletions
diff --git a/dev-db/postgresql-client/postgresql-client-8.2.6.ebuild b/dev-db/postgresql-client/postgresql-client-8.2.6.ebuild
deleted file mode 100644
index 465b175..0000000
--- a/dev-db/postgresql-client/postgresql-client-8.2.6.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-WANT_AUTOCONF="latest"
-WANT_AUTOMAKE="none"
-
-inherit eutils multilib toolchain-funcs versionator autotools
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-
-DESCRIPTION="PostgreSQL client applications"
-HOMEPAGE="http://www.postgresql.org/"
-SRC_URI="mirror://postgresql/source/v${PV}/postgresql-${PV}.tar.bz2"
-LICENSE="POSTGRESQL"
-SLOT="$(get_version_component_range 1-2)"
-# find . -name \*.po | xargs -n 1 basename | cut -d. -f1|sort|uniq|sed 's/^/linguas_/'
-IUSE_LINGUAS="
- linguas_af linguas_cs linguas_de linguas_es linguas_fa linguas_fr
- linguas_hr linguas_hu linguas_it linguas_ko linguas_nb linguas_pl
- linguas_pt_BR linguas_ro linguas_ru linguas_sk linguas_sl linguas_sv
- linguas_tr linguas_zh_CN linguas_zh_TW"
-IUSE="doc nls ${IUSE_LINGUAS}"
-
-wanted_languages() {
- for u in ${IUSE_LINGUAS} ; do
- use $u && echo ${u#linguas_}
- done
-}
-
-DEPEND="~dev-db/postgresql-libs-${PV}"
-RDEPEND="${DEPEND}"
-PDEPEND="doc? ( ~dev-db/postgresql-docs-${PV} )"
-
-S="${WORKDIR}/postgresql-${PV}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/postgresql-${SLOT}-common.patch"
- epatch "${FILESDIR}/postgresql-${SLOT}-client.patch"
-
- # to avoid collision - it only should be installed by server
- rm "${S}/src/backend/nls.mk"
-
- # because psql/help.c includes the file
- ln -s "${S}/src/include/libpq/pqsignal.h" "${S}/src/bin/psql/"
-
- eautoconf
-}
-
-src_compile() {
- # TODO: test if PPC really cannot work with other CFLAGS settings
- # use ppc && CFLAGS="-pipe -fsigned-char"
-
- # 1. threadsafety is disabled to avoid pulling in test tarball in absense of
- # which configure would fail. The configure output in the large part goes
- # unnoticed as the installed pgxs stuff is used instead.
- # 2. eval is needed to get along with pg_config quotation of space-rich
- # entities.
- eval econf "$(/usr/$(get_libdir)/postgresql-${SLOT}/bin/pg_config --configure)" \
- "$(built_with_use ~dev-db/postgresql-libs-${PV} nls && use_enable nls nls "$(wanted_languages)")" \
- --disable-thread-safety \
- || die "configure failed"
-
- for bd in . contrib ; do
- PATH="/usr/lib/postgresql-${SLOT}/bin:${PATH}" \
- emake -C $bd LD="$(tc-getLD) $(get_abi_LDFLAGS)" \
- PGXS=$(/usr/$(get_libdir)/postgresql-${SLOT}/bin/pg_config --pgxs) \
- NO_PGXS=0 USE_PGXS=1 docdir=/usr/share/doc/${PF} || die "emake in $bd failed"
- done
-}
-
-src_install() {
-
- for bd in . contrib ; do
- PATH="/usr/lib/postgresql-${SLOT}/bin:${PATH}" \
- emake -C $bd install DESTDIR="${D}" \
- PGXS=$(/usr/$(get_libdir)/postgresql-${SLOT}/bin/pg_config --pgxs) \
- NO_PGXS=0 USE_PGXS=1 docdir=/usr/share/doc/${PF} || die "emake install in $bd failed"
- done
-
- rm "${D}/usr/share/postgresql-${SLOT}/man/man1"/{initdb,ipcclean,pg_config,pg_controldata,pg_ctl,pg_resetxlog,pg_restore,postgres,postmaster,ecpg}.1
-
- dodoc README HISTORY doc/{README.*,TODO,bug.template}
-
- dodir /usr/lib/eselect-postgresql/slots/${SLOT}
- echo "postgres_ebuilds=\"\${postgres_ebuilds} ${PF}\"" >${D}/usr/lib/eselect-postgresql/slots/${SLOT}/client
-}
-
-pkg_postinst() {
- eselect postgresql update
-}
-
-pkg_postrm() {
- eselect postgresql update
-}