summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/postgresql-client/files/postgresql-8.3-common.patch')
-rw-r--r--dev-db/postgresql-client/files/postgresql-8.3-common.patch17
1 files changed, 16 insertions, 1 deletions
diff --git a/dev-db/postgresql-client/files/postgresql-8.3-common.patch b/dev-db/postgresql-client/files/postgresql-8.3-common.patch
index bab8258..c9f2ad2 100644
--- a/dev-db/postgresql-client/files/postgresql-8.3-common.patch
+++ b/dev-db/postgresql-client/files/postgresql-8.3-common.patch
@@ -17,8 +17,23 @@ index 9434113..d72b35c 100644
AC_SUBST(localedir)
])# PGAC_CHECK_GETTEXT
+diff --git a/configure.in b/configure.in
+index 58cc61c..07ffc38 100644
+--- a/configure.in
++++ b/configure.in
+@@ -19,10 +19,6 @@ m4_pattern_forbid(^PGAC_)dnl to catch undefined macros
+
+ AC_INIT([PostgreSQL], [8.3RC1], [pgsql-bugs@postgresql.org])
+
+-m4_if(m4_defn([m4_PACKAGE_VERSION]), [2.59], [], [m4_fatal([Autoconf version 2.59 is required.
+-Untested combinations of 'autoconf' and PostgreSQL versions are not
+-recommended. You can remove the check from 'configure.in' but it is then
+-your responsibility whether the result works or not.])])
+ AC_COPYRIGHT([Copyright (c) 1996-2008, PostgreSQL Global Development Group])
+ AC_CONFIG_SRCDIR([src/backend/access/common/heaptuple.c])
+ AC_CONFIG_AUX_DIR(config)
diff --git a/src/include/storage/s_lock.h b/src/include/storage/s_lock.h
-index a9cbeac..d5c2764 100644
+index 7d9448f..07799bc 100644
--- a/src/include/storage/s_lock.h
+++ b/src/include/storage/s_lock.h
@@ -298,6 +298,29 @@ tas(volatile slock_t *lock)