summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/postgresql-base/files/postgresql-7.3-base.patch')
-rw-r--r--dev-db/postgresql-base/files/postgresql-7.3-base.patch117
1 files changed, 117 insertions, 0 deletions
diff --git a/dev-db/postgresql-base/files/postgresql-7.3-base.patch b/dev-db/postgresql-base/files/postgresql-7.3-base.patch
new file mode 100644
index 0000000..0549ec0
--- /dev/null
+++ b/dev-db/postgresql-base/files/postgresql-7.3-base.patch
@@ -0,0 +1,117 @@
+=== contrib/Makefile
+==================================================================
+--- contrib/Makefile (revision 12)
++++ contrib/Makefile (local)
+@@ -5,40 +5,10 @@
+ include $(top_builddir)/src/Makefile.global
+
+ WANTED_DIRS = \
+- array \
+- btree_gist \
+- chkpass \
+- cube \
+- dbase \
+- dblink \
+- dbmirror \
+- dbsize \
+- earthdistance \
+ findoidjoins \
+- fulltextindex \
+- fuzzystrmatch \
+- intagg \
+- intarray \
+- isbn_issn \
+- lo \
+- ltree \
+- miscutil \
+- noupdate \
+ oid2name \
+ pg_dumplo \
+- pg_logger \
+ pgbench \
+- pgcrypto \
+- pgstattuple \
+- rserv \
+- rtree_gist \
+- seg \
+- spi \
+- string \
+- tablefunc \
+- tips \
+- tsearch \
+- userlock \
+ vacuumlo
+
+ # Missing:
+=== src/Makefile
+==================================================================
+--- src/Makefile (revision 12)
++++ src/Makefile (local)
+@@ -16,11 +16,9 @@
+ all install installdirs uninstall dep depend distprep:
+ $(MAKE) -C port $@
+ $(MAKE) -C backend $@
+- $(MAKE) -C backend/utils/mb/conversion_procs $@
+ $(MAKE) -C include $@
+ $(MAKE) -C interfaces $@
+ $(MAKE) -C bin $@
+- $(MAKE) -C pl $@
+
+ install-all-headers:
+ $(MAKE) -C include $@
+=== src/backend/Makefile
+==================================================================
+--- src/backend/Makefile (revision 12)
++++ src/backend/Makefile (local)
+@@ -29,7 +29,7 @@
+
+ ##########################################################################
+
+-all: submake-libpgport postgres $(POSTGRES_IMP)
++all: someheaders
+
+ ifneq ($(PORTNAME), win)
+
+@@ -78,7 +78,7 @@
+
+ .PHONY: $(DIRS:%=%-recursive)
+ # Update the commonly used headers before building the subdirectories
+-$(DIRS:%=%-recursive): $(top_builddir)/src/include/parser/parse.h $(top_builddir)/src/include/utils/fmgroids.h
++someheaders $(DIRS:%=%-recursive): $(top_builddir)/src/include/parser/parse.h $(top_builddir)/src/include/utils/fmgroids.h
+ $(MAKE) -C $(subst -recursive,,$@) all
+
+
+@@ -125,16 +125,7 @@
+
+ ##########################################################################
+
+-install: all installdirs install-bin
+-ifeq ($(PORTNAME), win)
+-ifeq ($(MAKE_DLL), true)
+- $(INSTALL_DATA) libpostgres.a $(DESTDIR)$(libdir)/libpostgres.a
+-endif
+-endif
+- $(MAKE) -C catalog install-bki
+- $(INSTALL_DATA) $(srcdir)/libpq/pg_hba.conf.sample $(DESTDIR)$(datadir)/pg_hba.conf.sample
+- $(INSTALL_DATA) $(srcdir)/libpq/pg_ident.conf.sample $(DESTDIR)$(datadir)/pg_ident.conf.sample
+- $(INSTALL_DATA) $(srcdir)/utils/misc/postgresql.conf.sample $(DESTDIR)$(datadir)/postgresql.conf.sample
++install:
+
+ install-bin: postgres $(POSTGRES_IMP) installdirs
+ $(INSTALL_PROGRAM) postgres$(X) $(DESTDIR)$(bindir)/postgres$(X)
+=== src/bin/Makefile
+==================================================================
+--- src/bin/Makefile (revision 12)
++++ src/bin/Makefile (local)
+@@ -13,9 +13,8 @@
+ top_builddir = ../..
+ include $(top_builddir)/src/Makefile.global
+
+-DIRS := initdb initlocation ipcclean pg_ctl pg_dump pg_id \
+- psql scripts pg_config pg_controldata pg_resetxlog \
+- pg_encoding
++DIRS := pg_ctl pg_dump pg_id \
++ psql scripts pg_config
+
+ ifeq ($(with_tcl), yes)
+ DIRS += pgtclsh