aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xtests/qfile/dotest13
-rw-r--r--tests/qfile/root/app-shells/bash-4.4_p23-r1/BUILD_TIME1
-rw-r--r--tests/qfile/root/app-shells/bash-4.4_p23-r1/CATEGORY1
-rw-r--r--tests/qfile/root/app-shells/bash-4.4_p23-r1/CBUILD1
-rw-r--r--tests/qfile/root/app-shells/bash-4.4_p23-r1/CFLAGS1
-rw-r--r--tests/qfile/root/app-shells/bash-4.4_p23-r1/CHOST1
-rw-r--r--tests/qfile/root/app-shells/bash-4.4_p23-r1/CONTENTS153
-rw-r--r--tests/qfile/root/app-shells/bash-4.4_p23-r1/COUNTER1
-rw-r--r--tests/qfile/root/app-shells/bash-4.4_p23-r1/CXXFLAGS1
-rw-r--r--tests/qfile/root/app-shells/bash-4.4_p23-r1/DEFINED_PHASES1
-rw-r--r--tests/qfile/root/app-shells/bash-4.4_p23-r1/DEPEND1
-rw-r--r--tests/qfile/root/app-shells/bash-4.4_p23-r1/DESCRIPTION1
-rw-r--r--tests/qfile/root/app-shells/bash-4.4_p23-r1/EAPI1
-rw-r--r--tests/qfile/root/app-shells/bash-4.4_p23-r1/FEATURES1
-rw-r--r--tests/qfile/root/app-shells/bash-4.4_p23-r1/HOMEPAGE1
-rw-r--r--tests/qfile/root/app-shells/bash-4.4_p23-r1/INHERITED1
-rw-r--r--tests/qfile/root/app-shells/bash-4.4_p23-r1/IUSE1
-rw-r--r--tests/qfile/root/app-shells/bash-4.4_p23-r1/IUSE_EFFECTIVE1
-rw-r--r--tests/qfile/root/app-shells/bash-4.4_p23-r1/KEYWORDS1
-rw-r--r--tests/qfile/root/app-shells/bash-4.4_p23-r1/LDFLAGS1
-rw-r--r--tests/qfile/root/app-shells/bash-4.4_p23-r1/LICENSE1
-rw-r--r--tests/qfile/root/app-shells/bash-4.4_p23-r1/NEEDED1
-rw-r--r--tests/qfile/root/app-shells/bash-4.4_p23-r1/NEEDED.ELF.21
-rw-r--r--tests/qfile/root/app-shells/bash-4.4_p23-r1/PF1
-rw-r--r--tests/qfile/root/app-shells/bash-4.4_p23-r1/RDEPEND1
-rw-r--r--tests/qfile/root/app-shells/bash-4.4_p23-r1/REQUIRES1
-rw-r--r--tests/qfile/root/app-shells/bash-4.4_p23-r1/SIZE1
-rw-r--r--tests/qfile/root/app-shells/bash-4.4_p23-r1/SLOT1
-rw-r--r--tests/qfile/root/app-shells/bash-4.4_p23-r1/USE1
-rw-r--r--tests/qfile/root/app-shells/bash-4.4_p23-r1/bash-4.4_p23-r1.ebuild260
-rw-r--r--tests/qfile/root/app-shells/bash-4.4_p23-r1/repository1
-rw-r--r--tests/qfile/root/bin/bash0
32 files changed, 446 insertions, 8 deletions
diff --git a/tests/qfile/dotest b/tests/qfile/dotest
index a9d1c55..7769a51 100755
--- a/tests/qfile/dotest
+++ b/tests/qfile/dotest
@@ -1,13 +1,10 @@
#!/bin/bash
-# TODO: Make these work with local vdb instead of requiring /.
-if [[ -n ${TRAVIS_OS_NAME} ]] ; then
- echo "TODO: Make it work on non-Gentoo system"
- exit 0
-fi
-
. ../init.sh || exit 1
+export ROOT=${as}/root
+export Q_VDB=/
+
tests=(
"q file -Cq /bin/bash /bin/XXXXX"
"app-shells/bash"
@@ -27,10 +24,10 @@ tests=(
"q file -Co -x app-shells/bash:0 /bin/bash"
"/bin/bash"
- "(cd /bin; q file -Cq bash)"
+ "(cd ${ROOT}/bin; q file -RCq bash)"
"app-shells/bash"
- "(cd /; q file -Co whatever)"
+ "(cd ${ROOT}/; q file -Co whatever)"
"whatever"
)
diff --git a/tests/qfile/root/app-shells/bash-4.4_p23-r1/BUILD_TIME b/tests/qfile/root/app-shells/bash-4.4_p23-r1/BUILD_TIME
new file mode 100644
index 0000000..9b6c3b8
--- /dev/null
+++ b/tests/qfile/root/app-shells/bash-4.4_p23-r1/BUILD_TIME
@@ -0,0 +1 @@
+1547713708
diff --git a/tests/qfile/root/app-shells/bash-4.4_p23-r1/CATEGORY b/tests/qfile/root/app-shells/bash-4.4_p23-r1/CATEGORY
new file mode 100644
index 0000000..23665dc
--- /dev/null
+++ b/tests/qfile/root/app-shells/bash-4.4_p23-r1/CATEGORY
@@ -0,0 +1 @@
+app-shells
diff --git a/tests/qfile/root/app-shells/bash-4.4_p23-r1/CBUILD b/tests/qfile/root/app-shells/bash-4.4_p23-r1/CBUILD
new file mode 100644
index 0000000..f733b5f
--- /dev/null
+++ b/tests/qfile/root/app-shells/bash-4.4_p23-r1/CBUILD
@@ -0,0 +1 @@
+x86_64-pc-linux-gnu
diff --git a/tests/qfile/root/app-shells/bash-4.4_p23-r1/CFLAGS b/tests/qfile/root/app-shells/bash-4.4_p23-r1/CFLAGS
new file mode 100644
index 0000000..38b744e
--- /dev/null
+++ b/tests/qfile/root/app-shells/bash-4.4_p23-r1/CFLAGS
@@ -0,0 +1 @@
+-O3 -march=native -pipe
diff --git a/tests/qfile/root/app-shells/bash-4.4_p23-r1/CHOST b/tests/qfile/root/app-shells/bash-4.4_p23-r1/CHOST
new file mode 100644
index 0000000..f733b5f
--- /dev/null
+++ b/tests/qfile/root/app-shells/bash-4.4_p23-r1/CHOST
@@ -0,0 +1 @@
+x86_64-pc-linux-gnu
diff --git a/tests/qfile/root/app-shells/bash-4.4_p23-r1/CONTENTS b/tests/qfile/root/app-shells/bash-4.4_p23-r1/CONTENTS
new file mode 100644
index 0000000..76fe036
--- /dev/null
+++ b/tests/qfile/root/app-shells/bash-4.4_p23-r1/CONTENTS
@@ -0,0 +1,153 @@
+dir /usr
+dir /usr/bin
+obj /usr/bin/bashbug 9b20c085e9d7f3646f3b4b45e74f70ca 1547713704
+dir /usr/share
+dir /usr/share/info
+obj /usr/share/info/bash.info.bz2 e96f21c53fd71a8b9f392eae611c8393 1547713705
+sym /usr/share/info/bashref.info.bz2 -> bash.info.bz2 1547713709
+dir /usr/share/man
+dir /usr/share/man/man1
+obj /usr/share/man/man1/rbash.1.bz2 c8370af7d2cba6984a624f80a9f75bb1 1547713707
+obj /usr/share/man/man1/builtins.1.bz2 5a135e368c236f17d1d98f8b3f170898 1547713707
+obj /usr/share/man/man1/bashbug.1.bz2 214100b4439c2b3fddc8afcdd176afc4 1547713707
+obj /usr/share/man/man1/bash.1.bz2 167fbcd505b4ab3517c1f902e4e7b0fd 1547713707
+dir /usr/share/locale
+dir /usr/share/locale/nl
+dir /usr/share/locale/nl/LC_MESSAGES
+obj /usr/share/locale/nl/LC_MESSAGES/bash.mo 9e46ff47323e90ae06a3d6bca048272e 1547713705
+dir /usr/share/locale/af
+dir /usr/share/locale/af/LC_MESSAGES
+obj /usr/share/locale/af/LC_MESSAGES/bash.mo 41c37d8a87fef0c492736c69719e6c6d 1547713705
+dir /usr/share/locale/sv
+dir /usr/share/locale/sv/LC_MESSAGES
+obj /usr/share/locale/sv/LC_MESSAGES/bash.mo b66c7adfda290a08b3e72ac6f9cd8945 1547713705
+dir /usr/share/locale/uk
+dir /usr/share/locale/uk/LC_MESSAGES
+obj /usr/share/locale/uk/LC_MESSAGES/bash.mo bedd282c9d1c91979a0ca61b556283ce 1547713706
+dir /usr/share/locale/ja
+dir /usr/share/locale/ja/LC_MESSAGES
+obj /usr/share/locale/ja/LC_MESSAGES/bash.mo dd347d2692940ec86da0997939c92456 1547713705
+dir /usr/share/locale/ca
+dir /usr/share/locale/ca/LC_MESSAGES
+obj /usr/share/locale/ca/LC_MESSAGES/bash.mo f8f6318563af78500bdcd343da9fb5bd 1547713705
+dir /usr/share/locale/da
+dir /usr/share/locale/da/LC_MESSAGES
+obj /usr/share/locale/da/LC_MESSAGES/bash.mo 17911605b0dfce2cbcec904385562bc5 1547713705
+dir /usr/share/locale/zh_TW
+dir /usr/share/locale/zh_TW/LC_MESSAGES
+obj /usr/share/locale/zh_TW/LC_MESSAGES/bash.mo 3be163bd6ff115f158152008b38ac969 1547713706
+dir /usr/share/locale/ru
+dir /usr/share/locale/ru/LC_MESSAGES
+obj /usr/share/locale/ru/LC_MESSAGES/bash.mo 41500366236f08a546b04089e15eb7ac 1547713705
+dir /usr/share/locale/et
+dir /usr/share/locale/et/LC_MESSAGES
+obj /usr/share/locale/et/LC_MESSAGES/bash.mo 9021bbbc713985bdf7a083e29e0bf895 1547713705
+dir /usr/share/locale/hr
+dir /usr/share/locale/hr/LC_MESSAGES
+obj /usr/share/locale/hr/LC_MESSAGES/bash.mo 37b44cc4f316c9caa93d528481d33101 1547713705
+dir /usr/share/locale/el
+dir /usr/share/locale/el/LC_MESSAGES
+obj /usr/share/locale/el/LC_MESSAGES/bash.mo bdf88cf8bf58ac0e68e06d875f8e9f9f 1547713705
+dir /usr/share/locale/sl
+dir /usr/share/locale/sl/LC_MESSAGES
+obj /usr/share/locale/sl/LC_MESSAGES/bash.mo 70863c54e2afd14279ef56533839a348 1547713705
+dir /usr/share/locale/es
+dir /usr/share/locale/es/LC_MESSAGES
+obj /usr/share/locale/es/LC_MESSAGES/bash.mo 904fe5b6516f8f826221189a2fe441c9 1547713705
+dir /usr/share/locale/en@boldquot
+dir /usr/share/locale/en@boldquot/LC_MESSAGES
+obj /usr/share/locale/en@boldquot/LC_MESSAGES/bash.mo 5d38e79cce3b7ba4b528cda0cbd45c5f 1547713705
+dir /usr/share/locale/ro
+dir /usr/share/locale/ro/LC_MESSAGES
+obj /usr/share/locale/ro/LC_MESSAGES/bash.mo 081cb1677de385da8f8f6a33530a1e27 1547713705
+dir /usr/share/locale/fi
+dir /usr/share/locale/fi/LC_MESSAGES
+obj /usr/share/locale/fi/LC_MESSAGES/bash.mo 93ecb14eb6818e7ec4d0e71ce8dfb46b 1547713705
+dir /usr/share/locale/hu
+dir /usr/share/locale/hu/LC_MESSAGES
+obj /usr/share/locale/hu/LC_MESSAGES/bash.mo d894f16d5c3d1df6ee890acd1fb68bdd 1547713705
+dir /usr/share/locale/gl
+dir /usr/share/locale/gl/LC_MESSAGES
+obj /usr/share/locale/gl/LC_MESSAGES/bash.mo 09bf9ea4c06650fec7297d652d452072 1547713705
+dir /usr/share/locale/zh_CN
+dir /usr/share/locale/zh_CN/LC_MESSAGES
+obj /usr/share/locale/zh_CN/LC_MESSAGES/bash.mo 982f68ff89ba75cb1a26ee4b1576a77e 1547713706
+dir /usr/share/locale/sk
+dir /usr/share/locale/sk/LC_MESSAGES
+obj /usr/share/locale/sk/LC_MESSAGES/bash.mo da1a183b7424ed2763e4b57cca9f81c5 1547713705
+dir /usr/share/locale/sr
+dir /usr/share/locale/sr/LC_MESSAGES
+obj /usr/share/locale/sr/LC_MESSAGES/bash.mo 123101974934c1739603380ff64c34fb 1547713705
+dir /usr/share/locale/nb
+dir /usr/share/locale/nb/LC_MESSAGES
+obj /usr/share/locale/nb/LC_MESSAGES/bash.mo 63bb59bf3116e89f6a0de715b13bee2d 1547713705
+dir /usr/share/locale/it
+dir /usr/share/locale/it/LC_MESSAGES
+obj /usr/share/locale/it/LC_MESSAGES/bash.mo e4cd256316092bc484fc7c1643b0642b 1547713705
+dir /usr/share/locale/lt
+dir /usr/share/locale/lt/LC_MESSAGES
+obj /usr/share/locale/lt/LC_MESSAGES/bash.mo d7f88bb2d27036603108ca63a1242877 1547713705
+dir /usr/share/locale/pl
+dir /usr/share/locale/pl/LC_MESSAGES
+obj /usr/share/locale/pl/LC_MESSAGES/bash.mo f29f6495aa95493baa76c3db6c44a46b 1547713705
+dir /usr/share/locale/id
+dir /usr/share/locale/id/LC_MESSAGES
+obj /usr/share/locale/id/LC_MESSAGES/bash.mo 2e3a6b6569e3d63dbee7ccb27369d919 1547713705
+dir /usr/share/locale/ga
+dir /usr/share/locale/ga/LC_MESSAGES
+obj /usr/share/locale/ga/LC_MESSAGES/bash.mo cba1736115ba3cfca171bd107a5e15c8 1547713705
+dir /usr/share/locale/bg
+dir /usr/share/locale/bg/LC_MESSAGES
+obj /usr/share/locale/bg/LC_MESSAGES/bash.mo 5fa98a9e7839eaffb678029b63d29ac2 1547713705
+dir /usr/share/locale/en@quot
+dir /usr/share/locale/en@quot/LC_MESSAGES
+obj /usr/share/locale/en@quot/LC_MESSAGES/bash.mo c52f08684d8c0028e8b85f5e7e68c17d 1547713705
+dir /usr/share/locale/fr
+dir /usr/share/locale/fr/LC_MESSAGES
+obj /usr/share/locale/fr/LC_MESSAGES/bash.mo c83ca2e7b7f1e26e0ed099f2954d81ca 1547713705
+dir /usr/share/locale/tr
+dir /usr/share/locale/tr/LC_MESSAGES
+obj /usr/share/locale/tr/LC_MESSAGES/bash.mo 9263814b39d2c82190f73dc8e53873b5 1547713706
+dir /usr/share/locale/eo
+dir /usr/share/locale/eo/LC_MESSAGES
+obj /usr/share/locale/eo/LC_MESSAGES/bash.mo f73eab965f06f39bebeebea9823dbd65 1547713705
+dir /usr/share/locale/cs
+dir /usr/share/locale/cs/LC_MESSAGES
+obj /usr/share/locale/cs/LC_MESSAGES/bash.mo 0d37f682297cf2058d299c9a609b1776 1547713705
+dir /usr/share/locale/de
+dir /usr/share/locale/de/LC_MESSAGES
+obj /usr/share/locale/de/LC_MESSAGES/bash.mo 99ac10426e2a7f53f466132a416c3c74 1547713705
+dir /usr/share/locale/vi
+dir /usr/share/locale/vi/LC_MESSAGES
+obj /usr/share/locale/vi/LC_MESSAGES/bash.mo f5358a7d46ab199cd60a1092e50ed51a 1547713706
+dir /usr/share/locale/pt_BR
+dir /usr/share/locale/pt_BR/LC_MESSAGES
+obj /usr/share/locale/pt_BR/LC_MESSAGES/bash.mo e4b8c7f219da7133b54651397ae9492e 1547713705
+dir /usr/share/doc
+dir /usr/share/doc/bash-4.4_p23-r1
+obj /usr/share/doc/bash-4.4_p23-r1/CHANGES.bz2 90497d0564cd628e219e573c7e1f91a2 1547713706
+obj /usr/share/doc/bash-4.4_p23-r1/RBASH.bz2 186ce9e929bbdae0610329d2ed8b0866 1547713704
+obj /usr/share/doc/bash-4.4_p23-r1/FAQ.bz2 9e5ccebbf4184a087962fdb7916e0070 1547713705
+obj /usr/share/doc/bash-4.4_p23-r1/POSIX.bz2 b0775619c07d1c1e1499b5e81adf89af 1547713704
+obj /usr/share/doc/bash-4.4_p23-r1/NEWS.bz2 91265b542f03a160da810ceaadea9ba0 1547713706
+dir /usr/share/doc/bash-4.4_p23-r1/html
+obj /usr/share/doc/bash-4.4_p23-r1/html/bashref.html f0b4a5de246defd76b7e70e7c0ed1b27 1547713705
+obj /usr/share/doc/bash-4.4_p23-r1/html/bash.html 0f0ac8b9fe84d2b4eea5b70cc22cb1e2 1547713705
+obj /usr/share/doc/bash-4.4_p23-r1/INTRO.bz2 0adb1e98d3ad2a3a012d696ea17e5547 1547713705
+obj /usr/share/doc/bash-4.4_p23-r1/ChangeLog.bz2 18be01005cfbe3a8ec3ade7f826510dc 1547713707
+obj /usr/share/doc/bash-4.4_p23-r1/COMPAT.bz2 98fe32b626a3d32e568f33d6c2cf02c9 1547713704
+obj /usr/share/doc/bash-4.4_p23-r1/AUTHORS.bz2 65f88febe33195919919139655121a7f 1547713706
+obj /usr/share/doc/bash-4.4_p23-r1/README.bz2 c0ca2da4709cedc22e6cd2de6b1e0202 1547713706
+dir /bin
+sym /bin/rbash -> bash 1547713706
+obj /bin/bash 2bb7a207ac3295d9c722132e7987969a 1547713709
+dir /etc
+dir /etc/skel
+obj /etc/skel/.bash_profile d3322040528c46743ea8e4b0b9a186bc 1547713707
+obj /etc/skel/.bashrc d210b9cd7fc07420736480f2062d7d7f 1547713707
+obj /etc/skel/.bash_logout 7d8a8ef90c1818a0cd66808ac2740638 1547713707
+dir /etc/bash
+obj /etc/bash/bash_logout 229ccc2980a94877f2e87f957e9da7bf 1547713707
+dir /etc/bash/bashrc.d
+obj /etc/bash/bashrc.d/.keep_app-shells_bash-0 d41d8cd98f00b204e9800998ecf8427e 1547713707
+obj /etc/bash/bashrc de46ed8f069d75d6982c5ea2fc8458f4 1547713707
diff --git a/tests/qfile/root/app-shells/bash-4.4_p23-r1/COUNTER b/tests/qfile/root/app-shells/bash-4.4_p23-r1/COUNTER
new file mode 100644
index 0000000..69eca71
--- /dev/null
+++ b/tests/qfile/root/app-shells/bash-4.4_p23-r1/COUNTER
@@ -0,0 +1 @@
+4119 \ No newline at end of file
diff --git a/tests/qfile/root/app-shells/bash-4.4_p23-r1/CXXFLAGS b/tests/qfile/root/app-shells/bash-4.4_p23-r1/CXXFLAGS
new file mode 100644
index 0000000..38b744e
--- /dev/null
+++ b/tests/qfile/root/app-shells/bash-4.4_p23-r1/CXXFLAGS
@@ -0,0 +1 @@
+-O3 -march=native -pipe
diff --git a/tests/qfile/root/app-shells/bash-4.4_p23-r1/DEFINED_PHASES b/tests/qfile/root/app-shells/bash-4.4_p23-r1/DEFINED_PHASES
new file mode 100644
index 0000000..9b18a45
--- /dev/null
+++ b/tests/qfile/root/app-shells/bash-4.4_p23-r1/DEFINED_PHASES
@@ -0,0 +1 @@
+compile configure install postinst preinst prepare setup unpack
diff --git a/tests/qfile/root/app-shells/bash-4.4_p23-r1/DEPEND b/tests/qfile/root/app-shells/bash-4.4_p23-r1/DEPEND
new file mode 100644
index 0000000..db51768
--- /dev/null
+++ b/tests/qfile/root/app-shells/bash-4.4_p23-r1/DEPEND
@@ -0,0 +1 @@
+>=sys-libs/ncurses-5.2-r2:0/6= >=sys-libs/readline-7.0:0/7= virtual/libintl
diff --git a/tests/qfile/root/app-shells/bash-4.4_p23-r1/DESCRIPTION b/tests/qfile/root/app-shells/bash-4.4_p23-r1/DESCRIPTION
new file mode 100644
index 0000000..570b430
--- /dev/null
+++ b/tests/qfile/root/app-shells/bash-4.4_p23-r1/DESCRIPTION
@@ -0,0 +1 @@
+The standard GNU Bourne again shell
diff --git a/tests/qfile/root/app-shells/bash-4.4_p23-r1/EAPI b/tests/qfile/root/app-shells/bash-4.4_p23-r1/EAPI
new file mode 100644
index 0000000..1e8b314
--- /dev/null
+++ b/tests/qfile/root/app-shells/bash-4.4_p23-r1/EAPI
@@ -0,0 +1 @@
+6
diff --git a/tests/qfile/root/app-shells/bash-4.4_p23-r1/FEATURES b/tests/qfile/root/app-shells/bash-4.4_p23-r1/FEATURES
new file mode 100644
index 0000000..9095fd6
--- /dev/null
+++ b/tests/qfile/root/app-shells/bash-4.4_p23-r1/FEATURES
@@ -0,0 +1 @@
+assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms sign strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr
diff --git a/tests/qfile/root/app-shells/bash-4.4_p23-r1/HOMEPAGE b/tests/qfile/root/app-shells/bash-4.4_p23-r1/HOMEPAGE
new file mode 100644
index 0000000..49e53c1
--- /dev/null
+++ b/tests/qfile/root/app-shells/bash-4.4_p23-r1/HOMEPAGE
@@ -0,0 +1 @@
+http://tiswww.case.edu/php/chet/bash/bashtop.html
diff --git a/tests/qfile/root/app-shells/bash-4.4_p23-r1/INHERITED b/tests/qfile/root/app-shells/bash-4.4_p23-r1/INHERITED
new file mode 100644
index 0000000..1d2a251
--- /dev/null
+++ b/tests/qfile/root/app-shells/bash-4.4_p23-r1/INHERITED
@@ -0,0 +1 @@
+desktop epatch estack toolchain-funcs multilib ltprune preserve-libs vcs-clean eutils flag-o-matic prefix
diff --git a/tests/qfile/root/app-shells/bash-4.4_p23-r1/IUSE b/tests/qfile/root/app-shells/bash-4.4_p23-r1/IUSE
new file mode 100644
index 0000000..d68e221
--- /dev/null
+++ b/tests/qfile/root/app-shells/bash-4.4_p23-r1/IUSE
@@ -0,0 +1 @@
+afs bashlogger examples mem-scramble +net nls plugins +readline
diff --git a/tests/qfile/root/app-shells/bash-4.4_p23-r1/IUSE_EFFECTIVE b/tests/qfile/root/app-shells/bash-4.4_p23-r1/IUSE_EFFECTIVE
new file mode 100644
index 0000000..5369217
--- /dev/null
+++ b/tests/qfile/root/app-shells/bash-4.4_p23-r1/IUSE_EFFECTIVE
@@ -0,0 +1 @@
+abi_x86_64 afs alpha amd64 amd64-fbsd amd64-linux arm arm64 bashlogger elibc_AIX elibc_Cygwin elibc_Darwin elibc_DragonFly elibc_FreeBSD elibc_HPUX elibc_Interix elibc_NetBSD elibc_OpenBSD elibc_SunOS elibc_Winnt elibc_bionic elibc_glibc elibc_mingw elibc_mintlib elibc_musl elibc_uclibc examples hppa ia64 kernel_AIX kernel_Darwin kernel_FreeBSD kernel_HPUX kernel_NetBSD kernel_OpenBSD kernel_SunOS kernel_Winnt kernel_freemint kernel_linux m68k m68k-mint mem-scramble mips net nls plugins ppc ppc-aix ppc-macos ppc64 ppc64-linux prefix prefix-chain prefix-guest readline s390 sh sparc sparc-solaris sparc64-solaris userland_BSD userland_GNU x64-cygwin x64-macos x64-solaris x86 x86-cygwin x86-fbsd x86-linux x86-macos x86-solaris x86-winnt
diff --git a/tests/qfile/root/app-shells/bash-4.4_p23-r1/KEYWORDS b/tests/qfile/root/app-shells/bash-4.4_p23-r1/KEYWORDS
new file mode 100644
index 0000000..20630e7
--- /dev/null
+++ b/tests/qfile/root/app-shells/bash-4.4_p23-r1/KEYWORDS
@@ -0,0 +1 @@
+~alpha amd64 ~arm arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris
diff --git a/tests/qfile/root/app-shells/bash-4.4_p23-r1/LDFLAGS b/tests/qfile/root/app-shells/bash-4.4_p23-r1/LDFLAGS
new file mode 100644
index 0000000..8c39288
--- /dev/null
+++ b/tests/qfile/root/app-shells/bash-4.4_p23-r1/LDFLAGS
@@ -0,0 +1 @@
+-Wl,-O1 -Wl,--as-needed
diff --git a/tests/qfile/root/app-shells/bash-4.4_p23-r1/LICENSE b/tests/qfile/root/app-shells/bash-4.4_p23-r1/LICENSE
new file mode 100644
index 0000000..c5a7b08
--- /dev/null
+++ b/tests/qfile/root/app-shells/bash-4.4_p23-r1/LICENSE
@@ -0,0 +1 @@
+GPL-3
diff --git a/tests/qfile/root/app-shells/bash-4.4_p23-r1/NEEDED b/tests/qfile/root/app-shells/bash-4.4_p23-r1/NEEDED
new file mode 100644
index 0000000..635595a
--- /dev/null
+++ b/tests/qfile/root/app-shells/bash-4.4_p23-r1/NEEDED
@@ -0,0 +1 @@
+/bin/bash libreadline.so.7,libc.so.6
diff --git a/tests/qfile/root/app-shells/bash-4.4_p23-r1/NEEDED.ELF.2 b/tests/qfile/root/app-shells/bash-4.4_p23-r1/NEEDED.ELF.2
new file mode 100644
index 0000000..de3b9b0
--- /dev/null
+++ b/tests/qfile/root/app-shells/bash-4.4_p23-r1/NEEDED.ELF.2
@@ -0,0 +1 @@
+X86_64;/bin/bash;;;libreadline.so.7,libc.so.6;x86_64
diff --git a/tests/qfile/root/app-shells/bash-4.4_p23-r1/PF b/tests/qfile/root/app-shells/bash-4.4_p23-r1/PF
new file mode 100644
index 0000000..3fa1e20
--- /dev/null
+++ b/tests/qfile/root/app-shells/bash-4.4_p23-r1/PF
@@ -0,0 +1 @@
+bash-4.4_p23-r1
diff --git a/tests/qfile/root/app-shells/bash-4.4_p23-r1/RDEPEND b/tests/qfile/root/app-shells/bash-4.4_p23-r1/RDEPEND
new file mode 100644
index 0000000..21dfdf5
--- /dev/null
+++ b/tests/qfile/root/app-shells/bash-4.4_p23-r1/RDEPEND
@@ -0,0 +1 @@
+>=sys-libs/ncurses-5.2-r2:0/6= >=sys-libs/readline-7.0:0/7= virtual/libintl !<sys-apps/portage-2.1.6.7_p1
diff --git a/tests/qfile/root/app-shells/bash-4.4_p23-r1/REQUIRES b/tests/qfile/root/app-shells/bash-4.4_p23-r1/REQUIRES
new file mode 100644
index 0000000..bb95ab7
--- /dev/null
+++ b/tests/qfile/root/app-shells/bash-4.4_p23-r1/REQUIRES
@@ -0,0 +1 @@
+x86_64: libc.so.6 libreadline.so.7
diff --git a/tests/qfile/root/app-shells/bash-4.4_p23-r1/SIZE b/tests/qfile/root/app-shells/bash-4.4_p23-r1/SIZE
new file mode 100644
index 0000000..e47062f
--- /dev/null
+++ b/tests/qfile/root/app-shells/bash-4.4_p23-r1/SIZE
@@ -0,0 +1 @@
+8259979
diff --git a/tests/qfile/root/app-shells/bash-4.4_p23-r1/SLOT b/tests/qfile/root/app-shells/bash-4.4_p23-r1/SLOT
new file mode 100644
index 0000000..573541a
--- /dev/null
+++ b/tests/qfile/root/app-shells/bash-4.4_p23-r1/SLOT
@@ -0,0 +1 @@
+0
diff --git a/tests/qfile/root/app-shells/bash-4.4_p23-r1/USE b/tests/qfile/root/app-shells/bash-4.4_p23-r1/USE
new file mode 100644
index 0000000..7a17694
--- /dev/null
+++ b/tests/qfile/root/app-shells/bash-4.4_p23-r1/USE
@@ -0,0 +1 @@
+abi_x86_64 amd64 elibc_glibc kernel_linux net nls readline userland_GNU
diff --git a/tests/qfile/root/app-shells/bash-4.4_p23-r1/bash-4.4_p23-r1.ebuild b/tests/qfile/root/app-shells/bash-4.4_p23-r1/bash-4.4_p23-r1.ebuild
new file mode 100644
index 0000000..2eef8d0
--- /dev/null
+++ b/tests/qfile/root/app-shells/bash-4.4_p23-r1/bash-4.4_p23-r1.ebuild
@@ -0,0 +1,260 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs multilib prefix
+
+# Official patchlevel
+# See ftp://ftp.cwru.edu/pub/bash/bash-4.4-patches/
+PLEVEL=${PV##*_p}
+MY_PV=${PV/_p*}
+MY_PV=${MY_PV/_/-}
+MY_P=${PN}-${MY_PV}
+is_release() {
+ case ${PV} in
+ *_alpha*|*_beta*|*_rc*) return 1 ;;
+ *) return 0 ;;
+ esac
+}
+[[ ${PV} != *_p* ]] && PLEVEL=0
+patches() {
+ local opt=$1 plevel=${2:-${PLEVEL}} pn=${3:-${PN}} pv=${4:-${MY_PV}}
+ [[ ${plevel} -eq 0 ]] && return 1
+ eval set -- {1..${plevel}}
+ set -- $(printf "${pn}${pv/\.}-%03d " "$@")
+ if [[ ${opt} == -s ]] ; then
+ echo "${@/#/${DISTDIR}/}"
+ else
+ local u
+ for u in ftp://ftp.cwru.edu/pub/bash mirror://gnu/${pn} ; do
+ printf "${u}/${pn}-${pv}-patches/%s " "$@"
+ done
+ fi
+}
+
+# The version of readline this bash normally ships with.
+READLINE_VER="7.0"
+
+DESCRIPTION="The standard GNU Bourne again shell"
+HOMEPAGE="http://tiswww.case.edu/php/chet/bash/bashtop.html"
+if is_release ; then
+ SRC_URI="mirror://gnu/bash/${MY_P}.tar.gz $(patches)"
+else
+ SRC_URI="ftp://ftp.cwru.edu/pub/bash/${MY_P}.tar.gz"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="afs bashlogger examples mem-scramble +net nls plugins +readline"
+
+DEPEND="
+ >=sys-libs/ncurses-5.2-r2:0=
+ readline? ( >=sys-libs/readline-${READLINE_VER}:0= )
+ nls? ( virtual/libintl )
+"
+RDEPEND="
+ ${DEPEND}
+ !<sys-apps/portage-2.1.6.7_p1
+"
+# we only need yacc when the .y files get patched (bash42-005)
+#DEPEND+=" virtual/yacc"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if is-flag -malign-double ; then #7332
+ eerror "Detected bad CFLAGS '-malign-double'. Do not use this"
+ eerror "as it breaks LFS (struct stat64) on x86."
+ die "remove -malign-double from your CFLAGS mr ricer"
+ fi
+ if use bashlogger ; then
+ ewarn "The logging patch should ONLY be used in restricted (i.e. honeypot) envs."
+ ewarn "This will log ALL output you enter into the shell, you have been warned."
+ fi
+}
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+}
+
+src_prepare() {
+ # Include official patches
+ [[ ${PLEVEL} -gt 0 ]] && eapply -p0 $(patches -s)
+
+ eapply "${FILESDIR}/${PN}-4.4-jobs_overflow.patch" #644720
+ eapply "${FILESDIR}/${PN}-4.4-set-SHOBJ_STATUS.patch" #644720
+
+ # Clean out local libs so we know we use system ones w/releases.
+ if is_release ; then
+ rm -rf lib/{readline,termcap}/*
+ touch lib/{readline,termcap}/Makefile.in # for config.status
+ sed -ri -e 's:\$[(](RL|HIST)_LIBSRC[)]/[[:alpha:]]*.h::g' Makefile.in || die
+ fi
+
+ # Prefixify hardcoded path names. No-op for non-prefix.
+ hprefixify pathnames.h.in
+
+ # Avoid regenerating docs after patches #407985
+ sed -i -r '/^(HS|RL)USER/s:=.*:=:' doc/Makefile.in || die
+ touch -r . doc/*
+
+ eapply_user
+}
+
+src_configure() {
+ local myconf=(
+ --disable-profiling
+ --docdir='$(datarootdir)'/doc/${PF}
+ --htmldir='$(docdir)/html'
+ --with-curses
+ $(use_enable mem-scramble)
+ $(use_enable net net-redirections)
+ $(use_enable readline)
+ $(use_enable readline bang-history)
+ $(use_enable readline history)
+ $(use_with afs)
+ $(use_with mem-scramble bash-malloc)
+ )
+
+ # For descriptions of these, see config-top.h
+ # bashrc/#26952 bash_logout/#90488 ssh/#24762 mktemp/#574426
+ append-cppflags \
+ -DDEFAULT_PATH_VALUE=\'\"${EPREFIX}/usr/local/sbin:${EPREFIX}/usr/local/bin:${EPREFIX}/usr/sbin:${EPREFIX}/usr/bin:${EPREFIX}/sbin:${EPREFIX}/bin\"\' \
+ -DSTANDARD_UTILS_PATH=\'\"${EPREFIX}/bin:${EPREFIX}/usr/bin:${EPREFIX}/sbin:${EPREFIX}/usr/sbin\"\' \
+ -DSYS_BASHRC=\'\"${EPREFIX}/etc/bash/bashrc\"\' \
+ -DSYS_BASH_LOGOUT=\'\"${EPREFIX}/etc/bash/bash_logout\"\' \
+ -DNON_INTERACTIVE_LOGIN_SHELLS \
+ -DSSH_SOURCE_BASHRC \
+ $(use bashlogger && echo -DSYSLOG_HISTORY)
+
+ # Don't even think about building this statically without
+ # reading Bug 7714 first. If you still build it statically,
+ # don't come crying to us with bugs ;).
+ #use static && export LDFLAGS="${LDFLAGS} -static"
+ use nls || myconf+=( --disable-nls )
+
+ # Historically, we always used the builtin readline, but since
+ # our handling of SONAME upgrades has gotten much more stable
+ # in the PM (and the readline ebuild itself preserves the old
+ # libs during upgrades), linking against the system copy should
+ # be safe.
+ # Exact cached version here doesn't really matter as long as it
+ # is at least what's in the DEPEND up above.
+ export ac_cv_rl_version=${READLINE_VER%%_*}
+
+ # Force linking with system curses ... the bundled termcap lib
+ # sucks bad compared to ncurses. For the most part, ncurses
+ # is here because readline needs it. But bash itself calls
+ # ncurses in one or two small places :(.
+
+ if is_release ; then
+ # Use system readline only with released versions.
+ myconf+=( --with-installed-readline=. )
+ fi
+
+ if use plugins; then
+ append-ldflags -Wl,-rpath,/usr/$(get_libdir)/bash
+ else
+ # Disable the plugins logic by hand since bash doesn't
+ # provide a way of doing it.
+ export ac_cv_func_dl{close,open,sym}=no \
+ ac_cv_lib_dl_dlopen=no ac_cv_header_dlfcn_h=no
+ sed -i \
+ -e '/LOCAL_LDFLAGS=/s:-rdynamic::' \
+ configure || die
+ fi
+ tc-export AR #444070
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ emake
+
+ if use plugins ; then
+ emake -C examples/loadables all others
+ fi
+}
+
+src_install() {
+ local d f
+
+ default
+
+ dodir /bin
+ mv "${ED%/}"/usr/bin/bash "${ED%/}"/bin/ || die
+ dosym bash /bin/rbash
+
+ insinto /etc/bash
+ doins "${FILESDIR}"/bash_logout
+ doins "$(prefixify_ro "${FILESDIR}"/bashrc)"
+ keepdir /etc/bash/bashrc.d
+ insinto /etc/skel
+ for f in bash{_logout,_profile,rc} ; do
+ newins "${FILESDIR}"/dot-${f} .${f}
+ done
+
+ local sed_args=(
+ -e "s:#${USERLAND}#@::"
+ -e '/#@/d'
+ )
+ if ! use readline ; then
+ sed_args+=( #432338
+ -e '/^shopt -s histappend/s:^:#:'
+ -e 's:use_color=true:use_color=false:'
+ )
+ fi
+ sed -i \
+ "${sed_args[@]}" \
+ "${ED%/}"/etc/skel/.bashrc \
+ "${ED%/}"/etc/bash/bashrc || die
+
+ if use plugins ; then
+ exeinto /usr/$(get_libdir)/bash
+ doexe $(echo examples/loadables/*.o | sed 's:\.o::g')
+ insinto /usr/include/bash-plugins
+ doins *.h builtins/*.h include/*.h lib/{glob/glob.h,tilde/tilde.h}
+ fi
+
+ if use examples ; then
+ for d in examples/{functions,misc,scripts,startup-files} ; do
+ exeinto /usr/share/doc/${PF}/${d}
+ insinto /usr/share/doc/${PF}/${d}
+ for f in ${d}/* ; do
+ if [[ ${f##*/} != PERMISSION ]] && [[ ${f##*/} != *README ]] ; then
+ doexe ${f}
+ else
+ doins ${f}
+ fi
+ done
+ done
+ fi
+
+ doman doc/*.1
+ newdoc CWRU/changelog ChangeLog
+ dosym bash.info /usr/share/info/bashref.info
+}
+
+pkg_preinst() {
+ if [[ -e ${EROOT}/etc/bashrc ]] && [[ ! -d ${EROOT}/etc/bash ]] ; then
+ mkdir -p "${EROOT}"/etc/bash
+ mv -f "${EROOT}"/etc/bashrc "${EROOT}"/etc/bash/
+ fi
+
+ if [[ -L ${EROOT}/bin/sh ]] ; then
+ # rewrite the symlink to ensure that its mtime changes. having /bin/sh
+ # missing even temporarily causes a fatal error with paludis.
+ local target=$(readlink "${EROOT}"/bin/sh)
+ local tmp=$(emktemp "${EROOT}"/bin)
+ ln -sf "${target}" "${tmp}"
+ mv -f "${tmp}" "${EROOT}"/bin/sh
+ fi
+}
+
+pkg_postinst() {
+ # If /bin/sh does not exist, provide it
+ if [[ ! -e ${EROOT}/bin/sh ]] ; then
+ ln -sf bash "${EROOT}"/bin/sh
+ fi
+}
diff --git a/tests/qfile/root/app-shells/bash-4.4_p23-r1/repository b/tests/qfile/root/app-shells/bash-4.4_p23-r1/repository
new file mode 100644
index 0000000..23574f3
--- /dev/null
+++ b/tests/qfile/root/app-shells/bash-4.4_p23-r1/repository
@@ -0,0 +1 @@
+gentoo
diff --git a/tests/qfile/root/bin/bash b/tests/qfile/root/bin/bash
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/tests/qfile/root/bin/bash