aboutsummaryrefslogtreecommitdiff
path: root/libq
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-08-28 13:40:31 +0200
committerFabian Groffen <grobian@gentoo.org>2022-08-28 13:51:06 +0200
commit1ad6040d95a9c8733cec4388ac6cb3c73e8ddf0d (patch)
tree7c5d94823c7ead4fd322f5a33cab1e19f0ffa3fd /libq
parentUse pkg-config for dependencies (diff)
downloadportage-utils-1ad6040d95a9c8733cec4388ac6cb3c73e8ddf0d.tar.gz
portage-utils-1ad6040d95a9c8733cec4388ac6cb3c73e8ddf0d.tar.bz2
portage-utils-1ad6040d95a9c8733cec4388ac6cb3c73e8ddf0d.zip
Remove libtool
* Libtool was only used for convenience libraries, which can be done in vanilla Automake. This allows passing `static` in LDFLAGS. Bug: https://bugs.gentoo.org/841898 Signed-off-by: David Seifert <soap@gentoo.org> Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'libq')
-rw-r--r--libq/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/libq/Makefile.am b/libq/Makefile.am
index c0402a4a..879d4a71 100644
--- a/libq/Makefile.am
+++ b/libq/Makefile.am
@@ -34,9 +34,9 @@ QFILES += hash_md5_sha1.c hash_md5_sha1.h
endif
endif
-noinst_LTLIBRARIES = libq.la
-libq_la_SOURCES = $(QFILES)
-libq_la_CPPFLAGS = \
+noinst_LIBRARIES = libq.a
+libq_a_SOURCES = $(QFILES)
+libq_a_CPPFLAGS = \
$(OPENMP_CFLAGS) \
-I$(top_builddir)/autotools/gnulib \
-I$(top_srcdir)/autotools/gnulib