aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-03-27 13:07:57 -0400
committerMike Frysinger <vapier@gentoo.org>2016-03-27 13:07:57 -0400
commit26d038ae9c2f499cfb52486913cc326854a50571 (patch)
tree5143d651e6f51fcca7dc9a0eaf7d496f800d0cf1 /Makefile.am
parentusage: handle optional args, and auto-align display (diff)
downloadportage-utils-26d038ae9c2f499cfb52486913cc326854a50571.tar.gz
portage-utils-26d038ae9c2f499cfb52486913cc326854a50571.tar.bz2
portage-utils-26d038ae9c2f499cfb52486913cc326854a50571.zip
q: migrate to new repo posthook system
This also extends the reinit interface to optionally take a path to the overlay to process. That allows the postsync hook to fire on specific repos rather than all of them. URL: https://bugs.gentoo.org/522032
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 225c9791..362ee219 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,6 +2,11 @@ ACLOCAL_AMFLAGS = -I autotools/m4
SUBDIRS = autotools/gnulib
+portagedir = $(sysconfdir)/portage
+postsyncddir = $(portagedir)/repo.postsync.d
+
+dist_postsyncd_SCRIPTS = repo.postsync/q-reinit
+
bin_PROGRAMS = q
q_SOURCES = main.c
q_CPPFLAGS = \