summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-24 19:04:55 +0200
committerSam James <sam@gentoo.org>2023-01-14 18:45:09 +0000
commit75164c2f72aed07cbea40e95cfedbe775f8a377a (patch)
tree6584c02875dfd67d63eeaa837bc694552220b8ba
parentAdd a section on editing and publishing (diff)
downloadpolicy-guide-75164c2f72aed07cbea40e95cfedbe775f8a377a.tar.gz
policy-guide-75164c2f72aed07cbea40e95cfedbe775f8a377a.tar.bz2
policy-guide-75164c2f72aed07cbea40e95cfedbe775f8a377a.zip
Makefile: use a custom `clean` target
Replace the Sphinx's `clean` target with a custom one that does not remove the git repository from _build/html. Signed-off-by: Michał Górny <mgorny@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index b5027c9..e640808 100644
--- a/Makefile
+++ b/Makefile
@@ -13,7 +13,11 @@ all: html $(BUILDDIR)/html/combined.html
$(BUILDDIR)/html/combined.html: singlehtml
cp $(BUILDDIR)/singlehtml/index.html $@
-.PHONY: all Makefile
+# The standard `clean` command removes the git repository
+clean:
+ rm -rf _build/html/* _build/html/.buildinfo
+
+.PHONY: all clean Makefile
# Catch-all target: route all unknown targets to Sphinx using the new
# "make mode" option. $(O) is meant as a shortcut for $(SPHINXOPTS).