summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2013-08-09 21:18:54 +0200
committerUlrich Müller <ulm@gentoo.org>2013-08-10 17:49:26 +0200
commitff3db9dbc1d0778740b16b05ea11f37f492feb41 (patch)
tree7d1d7ce1f7d24fcd9a2494f98e9c7ba53ccc51f4 /Makefile
parentMakefile: update upload target. (diff)
downloadpms-ff3db9dbc1d0778740b16b05ea11f37f492feb41.tar.gz
pms-ff3db9dbc1d0778740b16b05ea11f37f492feb41.tar.bz2
pms-ff3db9dbc1d0778740b16b05ea11f37f492feb41.zip
Makefile: new "dist" target.
New "dist" target in Makefile for creating a distribution tarball. Don't remove vc.tex with "clean" because it cannot be recreated outside of a git working tree. The new "maintainer-clean" target will remove vc.tex.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index f3deb94..9fdfb46 100644
--- a/Makefile
+++ b/Makefile
@@ -3,7 +3,10 @@ html : pms.html
clean :
rm -f *~ *.pdf *.dvi *.log *.aux *.bbl *.blg *.toc *.lol *.loa *.lox \
- *.lot *.out *.html *.css *.png *.4ct *.4tc *.idv *.lg *.tmp *.xref vc.tex || true
+ *.lot *.out *.html *.css *.png *.4ct *.4tc *.idv *.lg *.tmp *.xref
+
+maintainer-clean: clean
+ rm -f vc.tex
LATEXFILES = $(shell find -name '*.tex') pms.cls
LISTINGFILES = $(shell ls *.listing)
@@ -53,10 +56,16 @@ pms.dvi: $(SOURCEFILES) pms.bbl
latex pms
latex pms
+dist: $(SOURCEFILES) pms.bib vc vc-git.awk vc.tex Makefile
+ @if test -z $(PV); then \
+ echo "Usage: $(MAKE) $@ PV=<version>"; false; \
+ fi
+ tar -cJf pms-$(PV).tar.xz --transform='s%^%pms-$(PV)/%' $^
+
upload:
scp pms.pdf eapi-cheatsheet.pdf pms*.html pms.css \
dev.gentoo.org:public_html/pms/head/
.default: all
-.phony: clean upload
+.phony: clean maintainer-clean dist upload