aboutsummaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-11-16 14:35:05 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-11-16 20:08:28 +0200
commit27dd5ec2b8ca977e0b9711eca0d6cba543743a4e (patch)
treec35b3f648ca6cdb1473f02a5b837a654e81b1f7f /tests
parentcommit: mention `-e` as nice option (diff)
downloadpkgdev-27dd5ec2b8ca977e0b9711eca0d6cba543743a4e.tar.gz
pkgdev-27dd5ec2b8ca977e0b9711eca0d6cba543743a4e.tar.bz2
pkgdev-27dd5ec2b8ca977e0b9711eca0d6cba543743a4e.zip
build backend: use custom wrapper around flit
For pkgcore we need to run multiple preparations of generating files before creating sdist or wheel. Flit is a very simple and nice build backend, much more than setuptools. Also migrate to use snakeoil.dist sphinx extension for generating man and html, to remove various logic from `doc/conf.py`. Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'tests')
-rw-r--r--tests/scripts/test_pkgdev.py10
1 files changed, 0 insertions, 10 deletions
diff --git a/tests/scripts/test_pkgdev.py b/tests/scripts/test_pkgdev.py
index 8155bdc..7a64c17 100644
--- a/tests/scripts/test_pkgdev.py
+++ b/tests/scripts/test_pkgdev.py
@@ -51,13 +51,3 @@ class TestPkgdev:
assert excinfo.value.code == 0
out, err = capsys.readouterr()
assert out.startswith(project)
-
- def test_installed(self):
- """Verify tests are running in environment where generated modules exist."""
- try:
- importlib.import_module(f'{project}._verinfo')
- except ImportError:
- pytest.fail(
- 'not running against installed or released package\n'
- '(use `setup.py test` when running from git)'
- )