aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'tests/ebuild/test_eapi.py')
-rw-r--r--tests/ebuild/test_eapi.py13
1 files changed, 7 insertions, 6 deletions
diff --git a/tests/ebuild/test_eapi.py b/tests/ebuild/test_eapi.py
index cf7ef090..2b39e68a 100644
--- a/tests/ebuild/test_eapi.py
+++ b/tests/ebuild/test_eapi.py
@@ -26,10 +26,10 @@ class TestEAPI:
EAPI.register(magic="0")
mock_ebd_temp = str(shutil.copytree(EBD_PATH, tmp_path / "ebd"))
- with mock.patch(
- "pkgcore.ebuild.eapi.bash_version"
- ) as bash_version, mock.patch.dict(eapi.EAPI.known_eapis), mock.patch(
- "pkgcore.ebuild.eapi.const.EBD_PATH", mock_ebd_temp
+ with (
+ mock.patch("pkgcore.ebuild.eapi.bash_version") as bash_version,
+ mock.patch.dict(eapi.EAPI.known_eapis),
+ mock.patch("pkgcore.ebuild.eapi.const.EBD_PATH", mock_ebd_temp),
):
# inadequate bash version
bash_version.return_value = "3.1"
@@ -52,8 +52,9 @@ class TestEAPI:
assert eapi6.is_supported
mock_ebd_temp = str(shutil.copytree(EBD_PATH, tmp_path / "ebd"))
- with mock.patch.dict(eapi.EAPI.known_eapis), mock.patch(
- "pkgcore.ebuild.eapi.const.EBD_PATH", mock_ebd_temp
+ with (
+ mock.patch.dict(eapi.EAPI.known_eapis),
+ mock.patch("pkgcore.ebuild.eapi.const.EBD_PATH", mock_ebd_temp),
):
# partially supported EAPI is flagged as such
test_eapi = EAPI.register("test", optionals={"is_supported": False})