aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-05-17 21:29:53 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-05-17 21:29:53 +0300
commitcffc43a5ad3185d5974b7f8c94a3348024ed272c (patch)
tree80b83ee1492a1f46e3319ff92f142185db5afcb0 /pyproject.toml
parentnew release 0.10.24 (diff)
downloadpkgcheck-cffc43a5ad3185d5974b7f8c94a3348024ed272c.tar.gz
pkgcheck-cffc43a5ad3185d5974b7f8c94a3348024ed272c.tar.bz2
pkgcheck-cffc43a5ad3185d5974b7f8c94a3348024ed272c.zip
cibuildwheel: upgrade to manylinux_2_28v0.10.24
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml18
1 files changed, 9 insertions, 9 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 92e13cd3..1299f3ff 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -92,11 +92,11 @@ test-requires = ["pytest", "requests"]
test-command = "pytest {project}/tests"
# glibc 2.24
-manylinux-x86_64-image = "manylinux_2_24"
-manylinux-i686-image = "manylinux_2_24"
-manylinux-aarch64-image = "manylinux_2_24"
-manylinux-ppc64le-image = "manylinux_2_24"
-manylinux-s390x-image = "manylinux_2_24"
+manylinux-x86_64-image = "manylinux_2_28"
+manylinux-i686-image = "manylinux_2_28"
+manylinux-aarch64-image = "manylinux_2_28"
+manylinux-ppc64le-image = "manylinux_2_28"
+manylinux-s390x-image = "manylinux_2_28"
test-skip = "*-*linux_{aarch64,ppc64le,s390x}"
[[tool.cibuildwheel.overrides]]
@@ -108,10 +108,10 @@ before-all = [
[[tool.cibuildwheel.overrides]]
select = "*-manylinux*"
before-all = [
- "apt-get update",
- "apt-get install -y git libxml2-dev libxslt-dev",
- # "yum update -y",
- # "yum install -y git libxslt-devel libxml2-devel",
+ # "apt-get update",
+ # "apt-get install -y git libxml2-dev libxslt-dev",
+ "yum update -y",
+ "yum install -y git libxslt-devel libxml2-devel",
"curl -L \"https://github.com/robxu9/bash-static/releases/download/5.1.016-1.2.3/bash-linux-$(uname -m)\" -o /usr/local/bin/bash",
"chmod +x /usr/local/bin/bash",