aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-11-13 23:14:55 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-11-19 18:35:07 +0200
commit3af5138d54c975ae9ea48d14cfc00726e0f77ac1 (patch)
tree6bee4b7e28fd8efb1ca58d572e0e5c701382dc3c /pyproject.toml
parentscan: add support for NOCOLOR to disable colors (diff)
downloadpkgcheck-3af5138d54c975ae9ea48d14cfc00726e0f77ac1.tar.gz
pkgcheck-3af5138d54c975ae9ea48d14cfc00726e0f77ac1.tar.bz2
pkgcheck-3af5138d54c975ae9ea48d14cfc00726e0f77ac1.zip
setup.py: move to pure setuptools
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml72
1 files changed, 69 insertions, 3 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 39d8f6a8..2f0ac255 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,12 +1,78 @@
[build-system]
requires = [
- "wheel", "setuptools",
+ "setuptools >= 61.0.0",
+ "wheel",
+ # repeat all normal runtime dependencies here
"chardet",
"lazy-object-proxy",
"lxml",
"pathspec",
"tree-sitter>=0.19.0",
- "snakeoil~=0.9.10",
- "pkgcore~=0.12.11",
+ "snakeoil~=0.10.2",
+ "pkgcore~=0.12.17",
]
build-backend = "setuptools.build_meta"
+
+[project]
+name = "pkgcheck"
+description = "pkgcore-based QA utility for ebuild repos"
+readme = "README.rst"
+license = {file = "LICENSE"}
+requires-python = "~=3.9"
+authors = [
+ {name = "Tim Harder", email = "radhermit@gmail.com"},
+ {name = "Arthur Zamarin", email = "arthurzam@gentoo.org"},
+]
+maintainers = [
+ {name = "Arthur Zamarin", email = "arthurzam@gentoo.org"},
+]
+classifiers = [
+ "License :: OSI Approved :: BSD License",
+ "Programming Language :: Python :: 3.9",
+ "Programming Language :: Python :: 3.10",
+ "Programming Language :: Python :: 3.11",
+]
+dynamic = ["version"]
+
+dependencies = [
+ "chardet",
+ "lazy-object-proxy",
+ "lxml",
+ "pathspec",
+ "tree-sitter>=0.19.0",
+ "snakeoil~=0.10.2",
+ "pkgcore~=0.12.17",
+]
+
+[project.optional-dependencies]
+test = [
+ "pytest>=6.0",
+ "pytest-cov",
+ "requests",
+]
+doc = [
+ "sphinx",
+ "tomli; python_version < '3.11'"
+]
+network = [
+ "requests",
+]
+
+[project.urls]
+Homepage = "https://github.com/pkgcore/pkgcheck"
+Documentation = "https://pkgcore.github.io/pkgcheck/"
+Source = "https://github.com/pkgcore/pkgcheck"
+
+[project.scripts]
+pkgcheck = "pkgcheck.scripts.__init__:main"
+
+[tool.setuptools]
+zip-safe = false
+
+[tool.setuptools.dynamic]
+version = {attr = "pkgcheck.__version__"}
+
+[tool.pytest.ini_options]
+minversion = "6.0"
+addopts = "-vv -ra -l"
+testpaths = ["tests"]