aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2004-08-15 06:10:04 +0000
committerNed Ludd <solar@gentoo.org>2004-08-15 06:10:04 +0000
commite0c76396b603f12000e1aaa005d907681866e03e (patch)
treef048aa3c04842b01ed899954f9fac39e02ed54f6
parentfix comparison between signed and unsigned int (diff)
downloadpax-utils-0.0.4.tar.gz
pax-utils-0.0.4.tar.bz2
pax-utils-0.0.4.zip
README and Makefile updatesv0.0.4
-rw-r--r--Makefile15
-rw-r--r--README16
2 files changed, 21 insertions, 10 deletions
diff --git a/Makefile b/Makefile
index b65bc60..e3aa56f 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,6 @@
# Copyright 2003 Ned Ludd <solar@linbsd.net>
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-projects/pax-utils/Makefile,v 1.10 2004/07/14 16:52:09 solar Exp $
+# $Header: /var/cvsroot/gentoo-projects/pax-utils/Makefile,v 1.11 2004/08/15 06:10:04 solar Exp $
####################################################################
# This program is free software; you can redistribute it and/or
# modify it under the terms of the GNU General Public License as
@@ -23,7 +23,7 @@ VERSION = 0.0.3
####################################################
CFLAGS := -Wall -O2
#CFLAGS += -DEBUG -g
-LDFLAGS :=-pie
+#LDFLAGS :=-pie
DESTDIR =
PREFIX := $(DESTDIR)/usr
STRIP := strip
@@ -42,21 +42,22 @@ all: $(OBJS) $(TARGETS)
$(CC) $(CFLAGS) -c $<
%: %.o
- $(CC) -o $@ $(CFLAGS) -o $@ paxelf.o $<
+ $(CC) -o $@ $(CFLAGS) -o $@ paxelf.o $< $(LDFLAGS)
%.so: %.c
- ${CC) -shared -fPIC -o $@ $<
+ $(CC) -shared -fPIC -o $@ $<
scan4sym:
- $(CC) -o $@ $(CFLAGS) paxelf.o $@.o -ldl
+ $(CC) -o $@ $(CFLAGS) paxelf.o $@.o -ldl $(LDFLAGS)
+
depend:
$(CC) $(CFLAGS) -MM $(SOURCES) > .depend
pttool:
- $(CC) -o $@ $(CFLAGS) $@.o
+ $(CC) -o $@ $(CFLAGS) $@.o $(LDFLAGS)
pspax:
- $(CC) -o $@ $(CFLAGS) $@.o
+ $(CC) -o $@ $(CFLAGS) $@.o $(LDFLAGS)
clean:
-rm -f $(OBJS) $(TARGETS)
diff --git a/README b/README
index b0a5baa..cf8644f 100644
--- a/README
+++ b/README
@@ -12,8 +12,6 @@ Usage: scanexec [options] dir1 dir2 dirN...
Tests if a file is of ELF ET_DYN, has a symbol for main, and contains a
program interpreter.
-isetdyn <filename>
-
== scanelf ==
Usage: scanelf [options] dir1 dir2 dirN...
-p, --path : Scan all directories in PATH environment.
@@ -21,10 +19,22 @@ Usage: scanelf [options] dir1 dir2 dirN...
-h, --help : Print this help and exit.
-v, --version : Print version and exit.
+== pspax ==
+Usage: pspax
+
+If pspax was compile with CFLAGS+= -DWANT_SYSCAP and LDFLAGS+=-lcap it
+will also list runtime capabilities If extended attribute support is
+enable it will list those calues as well.
+
+== scan4sym ==
+
+This is a debugging tool that will scan a directory to see of a symbol
+is visible via dlopen, dlsym. Note: This tool should be used with
+caution as opening an untrusted library with a constructor will
+automatically be executed.
== INSTALL ==
make install
-
PaX Homepage:
http://pageexec.virtualave.net/