summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--20018_all_mysql-8.0.19-without-clientlibs-tools.patch13
-rw-r--r--20018_all_percona-server-8.0.18-without-clientlibs-tools.patch13
2 files changed, 24 insertions, 2 deletions
diff --git a/20018_all_mysql-8.0.19-without-clientlibs-tools.patch b/20018_all_mysql-8.0.19-without-clientlibs-tools.patch
index ea6744e..722ddac 100644
--- a/20018_all_mysql-8.0.19-without-clientlibs-tools.patch
+++ b/20018_all_mysql-8.0.19-without-clientlibs-tools.patch
@@ -1,6 +1,17 @@
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -1285,7 +1285,9 @@ IF(WITH_UNIT_TESTS)
+@@ -1200,7 +1200,9 @@ ENDIF()
+ # Add lz4 library
+ MYSQL_CHECK_LZ4()
+ # Add icu library
+-MYSQL_CHECK_ICU()
++IF(NOT WITHOUT_SERVER)
++ MYSQL_CHECK_ICU()
++ENDIF()
+ # Add SASL library
+ MYSQL_CHECK_SASL()
+ # Add protoc and libprotobuf
+@@ -1285,7 +1287,9 @@ IF(WITH_UNIT_TESTS)
INCLUDE(googletest)
ENDIF()
diff --git a/20018_all_percona-server-8.0.18-without-clientlibs-tools.patch b/20018_all_percona-server-8.0.18-without-clientlibs-tools.patch
index bf07285..0b466ea 100644
--- a/20018_all_percona-server-8.0.18-without-clientlibs-tools.patch
+++ b/20018_all_percona-server-8.0.18-without-clientlibs-tools.patch
@@ -1,6 +1,17 @@
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -1284,7 +1284,9 @@ IF(WITH_UNIT_TESTS)
+@@ -1199,7 +1199,9 @@ ENDIF()
+ # Add lz4 library
+ MYSQL_CHECK_LZ4()
+ # Add icu library
+-MYSQL_CHECK_ICU()
++IF(NOT WITHOUT_SERVER)
++ MYSQL_CHECK_ICU()
++ENDIF()
+ # Add SASL library
+ MYSQL_CHECK_SASL()
+ # Add protoc and libprotobuf
+@@ -1284,7 +1286,9 @@ IF(WITH_UNIT_TESTS)
INCLUDE(googletest)
ENDIF()