summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@lavabit.com>2012-08-06 13:49:47 -0400
committerBrian Evans <grknight@lavabit.com>2012-08-06 13:49:47 -0400
commit4218898ead7a97f80d808d371d60b5d78c3d3448 (patch)
treefc5cad3fead56a46aaf2cf07eb3f89adccf136e4 /20001_all_fix-minimal-build-cmake-mysql.patch
parentPatch to fix unit tests that randomly fail on ma_test2 binary. Bugs #41001 #... (diff)
downloadmysql-extras-4218898ead7a97f80d808d371d60b5d78c3d3448.tar.gz
mysql-extras-4218898ead7a97f80d808d371d60b5d78c3d3448.tar.bz2
mysql-extras-4218898ead7a97f80d808d371d60b5d78c3d3448.zip
Fix USE="minimal" on cmake builds to mimic the autotools builds.
The mariadb patch comments out a file that is only referenced by the server and the aria storage engine.
Diffstat (limited to '20001_all_fix-minimal-build-cmake-mysql.patch')
-rw-r--r--20001_all_fix-minimal-build-cmake-mysql.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/20001_all_fix-minimal-build-cmake-mysql.patch b/20001_all_fix-minimal-build-cmake-mysql.patch
new file mode 100644
index 0000000..24c77f8
--- /dev/null
+++ b/20001_all_fix-minimal-build-cmake-mysql.patch
@@ -0,0 +1,17 @@
+--- mysql/CMakeLists.txt 2012-08-03 16:37:52.234629566 -0400
++++ mysql.new/CMakeLists.txt 2012-08-03 16:35:47.797340969 -0400
+@@ -320,6 +320,13 @@
+ IF(UNIX)
+ ADD_SUBDIRECTORY(man)
+ ENDIF()
++ELSE()
++ ADD_SUBDIRECTORY(client)
++ ADD_SUBDIRECTORY(sql/share)
++ ADD_SUBDIRECTORY(scripts)
++ IF(UNIX)
++ ADD_SUBDIRECTORY(man)
++ ENDIF()
+ ENDIF()
+
+ INCLUDE(cmake/abi_check.cmake)
+