aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2021-09-23 17:19:22 -0500
committerJory Pratt <anarchy@gentoo.org>2021-09-23 17:19:22 -0500
commit98ef5d1abd9ad842d686e976738f0957354b815a (patch)
tree7193d7d9bce2ee4ea16dabe6d7088fdfc2ec9336 /sys-devel
parentmedia-tv/kodi: Set 2MB stacksize for musl users (diff)
downloadmusl-98ef5d1abd9ad842d686e976738f0957354b815a.tar.gz
musl-98ef5d1abd9ad842d686e976738f0957354b815a.tar.bz2
musl-98ef5d1abd9ad842d686e976738f0957354b815a.zip
sys-devel/gcc: revbump for x86/ppc for stage regeneration
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Jory Pratt <anarchy@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/gcc-10.3.0-r3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-10.3.0-r3.ebuild b/sys-devel/gcc/gcc-10.3.0-r3.ebuild
new file mode 100644
index 00000000..60b7cbc2
--- /dev/null
+++ b/sys-devel/gcc/gcc-10.3.0-r3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PATCH_VER="3"
+
+inherit toolchain
+
+KEYWORDS="ppc x86"
+
+RDEPEND=""
+BDEPEND="${CATEGORY}/binutils"
+
+src_prepare() {
+ toolchain_src_prepare
+
+ if use elibc_musl || [[ ${CATEGORY} = cross-*-musl* ]]; then
+ eapply "${FILESDIR}"/10.1.0/cpu_indicator.patch
+ eapply "${FILESDIR}"/7.1.0/posix_memalign.patch
+ case $(tc-arch) in
+ amd64|arm64|ppc64) eapply "${FILESDIR}"/9.3.0/gcc-pure64.patch ;;
+ esac
+ fi
+
+ if [[ ${CATEGORY} != cross-* ]] ; then
+ eapply "${FILESDIR}"/gcc-6.1-musl-libssp.patch
+ fi
+
+ eapply_user
+}