aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAric Belsito <lluixhi@gmail.com>2018-01-15 20:54:39 -0800
committerAric Belsito <lluixhi@gmail.com>2018-01-15 20:54:39 -0800
commit6bb1d30e7124e6c46102dc81e00b6df58be53c13 (patch)
tree2cef39e9350abb12f37951bcd96fe6abf421d8d6 /sys-devel
parentsys-devel/gcc: sync 7.2.0-r1 with upstream (diff)
downloadmusl-6bb1d30e7124e6c46102dc81e00b6df58be53c13.tar.gz
musl-6bb1d30e7124e6c46102dc81e00b6df58be53c13.tar.bz2
musl-6bb1d30e7124e6c46102dc81e00b6df58be53c13.zip
sys-devel/gcc: bump to 7.2.0-r2
spectre patches should be masked for testing for now.
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/gcc-7.2.0-r1.ebuild11
-rw-r--r--sys-devel/gcc/gcc-7.2.0-r2.ebuild42
2 files changed, 42 insertions, 11 deletions
diff --git a/sys-devel/gcc/gcc-7.2.0-r1.ebuild b/sys-devel/gcc/gcc-7.2.0-r1.ebuild
index c6f78dff..c27bb96d 100644
--- a/sys-devel/gcc/gcc-7.2.0-r1.ebuild
+++ b/sys-devel/gcc/gcc-7.2.0-r1.ebuild
@@ -24,17 +24,6 @@ src_prepare() {
epatch "${FILESDIR}"/gcc-7.2.0-pr69728.patch
- # Meltdown/Spectre
- epatch "${FILESDIR}"/0001-gcc-7.2.0-move-struct-ix86_frame-to-machine-function.patch
- epatch "${FILESDIR}"/0002-gcc-7.2.0-move-struct-ix86_frame-to-machine-function.patch
- epatch "${FILESDIR}"/0003-gcc-7.2.0-move-struct-ix86_frame-to-machine-function.patch
-
- epatch "${FILESDIR}"/spectre-0001-mindirect-branch.patch
- epatch "${FILESDIR}"/spectre-0002-mfunction-return.patch
- epatch "${FILESDIR}"/spectre-0003-mindirect-branch-register.patch
- epatch "${FILESDIR}"/spectre-0004-v-register-modifier.patch
- epatch "${FILESDIR}"/spectre-0005-mcmodel-large.patch
-
if use elibc_musl || [[ ${CATEGORY} = cross-*-musl* ]]; then
epatch "${FILESDIR}"/6.3.0/cpu_indicator.patch
epatch "${FILESDIR}"/7.1.0/posix_memalign.patch
diff --git a/sys-devel/gcc/gcc-7.2.0-r2.ebuild b/sys-devel/gcc/gcc-7.2.0-r2.ebuild
new file mode 100644
index 00000000..2862d123
--- /dev/null
+++ b/sys-devel/gcc/gcc-7.2.0-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PATCH_VER="1.1"
+#UCLIBC_VER="1.0"
+
+inherit epatch toolchain
+
+# KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ elibc_glibc? ( >=sys-libs/glibc-2.13 )
+ >=${CATEGORY}/binutils-2.20"
+
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.13 )"
+fi
+
+src_prepare() {
+ toolchain_src_prepare
+
+ epatch "${FILESDIR}"/gcc-7.2.0-pr69728.patch
+
+ # Meltdown/Spectre
+ epatch "${FILESDIR}"/0001-gcc-7.2.0-move-struct-ix86_frame-to-machine-function.patch
+ epatch "${FILESDIR}"/0002-gcc-7.2.0-move-struct-ix86_frame-to-machine-function.patch
+ epatch "${FILESDIR}"/0003-gcc-7.2.0-move-struct-ix86_frame-to-machine-function.patch
+
+ epatch "${FILESDIR}"/spectre-0001-mindirect-branch.patch
+ epatch "${FILESDIR}"/spectre-0002-mfunction-return.patch
+ epatch "${FILESDIR}"/spectre-0003-mindirect-branch-register.patch
+ epatch "${FILESDIR}"/spectre-0004-v-register-modifier.patch
+ epatch "${FILESDIR}"/spectre-0005-mcmodel-large.patch
+
+ if use elibc_musl || [[ ${CATEGORY} = cross-*-musl* ]]; then
+ epatch "${FILESDIR}"/6.3.0/cpu_indicator.patch
+ epatch "${FILESDIR}"/7.1.0/posix_memalign.patch
+ fi
+}