aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2022-01-17 18:44:42 -0600
committerJory Pratt <anarchy@gentoo.org>2022-01-17 18:44:42 -0600
commitacc0d853a3f569092c6c2958223a4afb23c4fa3a (patch)
tree409086b460bdc4f4571d1e0d7507c73fd11c59fa /sys-block
parentmedia-sound/cdparanoia: already fixed in tree (diff)
downloadmusl-acc0d853a3f569092c6c2958223a4afb23c4fa3a.tar.gz
musl-acc0d853a3f569092c6c2958223a4afb23c4fa3a.tar.bz2
musl-acc0d853a3f569092c6c2958223a4afb23c4fa3a.zip
sys-block/parted: :: works as expected
Signed-off-by: Jory Pratt <anarchy@gentoo.org>
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/parted/Manifest1
-rw-r--r--sys-block/parted/files/parted-3.2-devmapper.patch60
-rw-r--r--sys-block/parted/files/parted-3.2-fix-includes.patch10
-rw-r--r--sys-block/parted/files/parted-3.2-fix-resizing-FAT16.patch64
-rw-r--r--sys-block/parted/files/parted-3.2-po4a-mandir.patch11
-rw-r--r--sys-block/parted/files/parted-3.2-sysmacros.patch28
-rw-r--r--sys-block/parted/metadata.xml20
-rw-r--r--sys-block/parted/parted-3.2-r2.ebuild64
-rw-r--r--sys-block/parted/parted-3.2.ebuild58
9 files changed, 0 insertions, 316 deletions
diff --git a/sys-block/parted/Manifest b/sys-block/parted/Manifest
deleted file mode 100644
index 1f69f788..00000000
--- a/sys-block/parted/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST parted-3.2.tar.xz 1655244 SHA256 858b589c22297cacdf437f3baff6f04b333087521ab274f7ab677cb8c6bb78e4 SHA512 4e37dbdd6f5032c9ebfec43704f6882379597d038167b9c4d04053efa083c68a705196713864451fa9e11d32777e16c68982877945c5efd9ea5f8252cb20e1c4 WHIRLPOOL af928177b893150ac6d5e0efcef542b6fa0df6b135f975078f7d8d5f7a4b109ef4c1f8eeaf6afc5c34448ff662ce4cbe5289e084f4ec05257666503a0cd3c93f
diff --git a/sys-block/parted/files/parted-3.2-devmapper.patch b/sys-block/parted/files/parted-3.2-devmapper.patch
deleted file mode 100644
index 0cd3e0e3..00000000
--- a/sys-block/parted/files/parted-3.2-devmapper.patch
+++ /dev/null
@@ -1,60 +0,0 @@
---- a/libparted/arch/linux.c
-+++ b/libparted/arch/linux.c
-@@ -2304,6 +2304,7 @@
- return r < 0 ? NULL : resultp;
- }
-
-+#ifdef ENABLE_DEVICE_MAPPER
- static char *
- dm_canonical_path (PedDevice const *dev)
- {
-@@ -2326,12 +2327,22 @@
- err:
- return NULL;
- }
-+#endif /* ENABLE_DEVICE_MAPPER */
-
- static char*
- _device_get_part_path (PedDevice const *dev, int num)
- {
-- char *devpath = (dev->type == PED_DEVICE_DM
-- ? dm_canonical_path (dev) : dev->path);
-+ char *devpath =
-+#ifdef ENABLE_DEVICE_MAPPER
-+ (
-+ dev->type == PED_DEVICE_DM
-+ ? dm_canonical_path (dev) :
-+#endif /* ENABLE_DEVICE_MAPPER */
-+ dev->path
-+#ifdef ENABLE_DEVICE_MAPPER
-+ )
-+#endif /* ENABLE_DEVICE_MAPPER */
-+ ;
- size_t path_len = strlen (devpath);
- char *result;
- /* Check for devfs-style /disc => /partN transformation
-@@ -2945,12 +2956,14 @@
- unsigned long long *length);
-
-
-+#ifdef ENABLE_DEVICE_MAPPER
- if (disk->dev->type == PED_DEVICE_DM) {
- add_partition = _dm_add_partition;
- remove_partition = _dm_remove_partition;
- resize_partition = _dm_resize_partition;
- get_partition_start_and_length = _dm_get_partition_start_and_length;
- } else {
-+#endif /* ENABLE_DEVICE_MAPPER */
- add_partition = _blkpg_add_partition;
- remove_partition = _blkpg_remove_partition;
- #ifdef BLKPG_RESIZE_PARTITION
-@@ -2959,7 +2972,9 @@
- resize_partition = NULL;
- #endif
- get_partition_start_and_length = _kernel_get_partition_start_and_length;
-+#ifdef ENABLE_DEVICE_MAPPER
- }
-+#endif /* ENABLE_DEVICE_MAPPER */
-
- /* lpn = largest partition number.
- * for remove pass, use greater of device or label limit */
diff --git a/sys-block/parted/files/parted-3.2-fix-includes.patch b/sys-block/parted/files/parted-3.2-fix-includes.patch
deleted file mode 100644
index c6eff0eb..00000000
--- a/sys-block/parted/files/parted-3.2-fix-includes.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- parted-3.1.orig/libparted/fs/xfs/platform_defs.h
-+++ parted-3.1/libparted/fs/xfs/platform_defs.h
-@@ -35,6 +35,7 @@
- #define __XFS_PLATFORM_DEFS_H__
-
- #include <stdio.h>
-+#include <fcntl.h>
- #include <stdarg.h>
- #include <assert.h>
- #include <endian.h>
diff --git a/sys-block/parted/files/parted-3.2-fix-resizing-FAT16.patch b/sys-block/parted/files/parted-3.2-fix-resizing-FAT16.patch
deleted file mode 100644
index 2a5a2311..00000000
--- a/sys-block/parted/files/parted-3.2-fix-resizing-FAT16.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-From 1e9e770f4bc7f3d80e09ecd1df58575fad064163 Mon Sep 17 00:00:00 2001
-From: Mike Fleetwood <mike.fleetwood@googlemail.com>
-Date: Sun, 28 Sep 2014 15:15:48 +0000
-Subject: lib-fs-resize: Prevent crash resizing FAT16 file systems
-
-Resizing FAT16 file system crashes in libparted/fs/r/fat/resize.c
-create_resize_context() because it was dereferencing NULL pointer
-fs_info->info_sector to copy the info_sector.
-
-Only FAT32 file systems have info_sector populated by fat_open() ->
-fat_info_sector_read(). FAT12 and FAT16 file systems don't have an
-info_sector so pointer fs_info->info_sector remains assigned NULL from
-fat_alloc(). When resizing a FAT file system create_resize_context()
-was always dereferencing fs_info->info_sector to memory copy the
-info_sector, hence it crashed for FAT12 and FAT16.
-
-Make create_resize_context() only copy the info_sector for FAT32 file
-systems.
-
-Reported by Christian Hesse in
-https://bugzilla.gnome.org/show_bug.cgi?id=735669
----
-diff --git a/NEWS b/NEWS
-index 297b0a5..da7db50 100644
---- a/NEWS
-+++ b/NEWS
-@@ -2,6 +2,10 @@ GNU parted NEWS -*- outline -*-
-
- * Noteworthy changes in release ?.? (????-??-??) [?]
-
-+** Bug Fixes
-+
-+ libparted-fs-resize: Prevent crash resizing FAT16 file systems.
-+
-
- * Noteworthy changes in release 3.2 (2014-07-28) [stable]
-
-diff --git a/libparted/fs/r/fat/resize.c b/libparted/fs/r/fat/resize.c
-index 919acf0..bfe60a0 100644
---- a/libparted/fs/r/fat/resize.c
-+++ b/libparted/fs/r/fat/resize.c
-@@ -668,11 +668,17 @@ create_resize_context (PedFileSystem* fs, const PedGeometry* new_geom)
-
- /* preserve boot code, etc. */
- new_fs_info->boot_sector = ped_malloc (new_geom->dev->sector_size);
-- new_fs_info->info_sector = ped_malloc (new_geom->dev->sector_size);
- memcpy (new_fs_info->boot_sector, fs_info->boot_sector,
- new_geom->dev->sector_size);
-- memcpy (new_fs_info->info_sector, fs_info->info_sector,
-- new_geom->dev->sector_size);
-+ new_fs_info->info_sector = NULL;
-+ if (fs_info->fat_type == FAT_TYPE_FAT32)
-+ {
-+ PED_ASSERT (fs_info->info_sector != NULL);
-+ new_fs_info->info_sector =
-+ ped_malloc (new_geom->dev->sector_size);
-+ memcpy (new_fs_info->info_sector, fs_info->info_sector,
-+ new_geom->dev->sector_size);
-+ }
-
- new_fs_info->logical_sector_size = fs_info->logical_sector_size;
- new_fs_info->sector_count = new_geom->length;
---
-cgit v0.9.0.2
diff --git a/sys-block/parted/files/parted-3.2-po4a-mandir.patch b/sys-block/parted/files/parted-3.2-po4a-mandir.patch
deleted file mode 100644
index be0a9c69..00000000
--- a/sys-block/parted/files/parted-3.2-po4a-mandir.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/doc/po4a.mk
-+++ b/doc/po4a.mk
-@@ -23,7 +23,7 @@
- # threshold is 80%), it won't be distributed, and the build won't fail.
- #
-
--mandir = $(mandir)/$(lang)
-+mandir := $(mandir)/$(lang)
-
- # Inform automake that we want to install some man pages in section 1, 5
- # and 8.
diff --git a/sys-block/parted/files/parted-3.2-sysmacros.patch b/sys-block/parted/files/parted-3.2-sysmacros.patch
deleted file mode 100644
index a29e7619..00000000
--- a/sys-block/parted/files/parted-3.2-sysmacros.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-https://bugs.gentoo.org/580022
-
-From dec8995fe80508374beba6356f6ecbba8ef6b18b Mon Sep 17 00:00:00 2001
-From: Mike Frysinger <vapier@gentoo.org>
-Date: Tue, 21 Jun 2016 15:01:08 -0400
-Subject: [PATCH] include sysmacros.h for major/minor/makedev
-
-Linux C libs are moving away from including this header implicitly via
-sys/types.h, so include it explicitly.
----
- libparted/arch/linux.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/libparted/arch/linux.c b/libparted/arch/linux.c
-index 326b95619d31..e5c168be3c68 100644
---- a/libparted/arch/linux.c
-+++ b/libparted/arch/linux.c
-@@ -37,6 +37,7 @@
- #include <dirent.h>
- #include <sys/ioctl.h>
- #include <sys/stat.h>
-+#include <sys/sysmacros.h>
- #include <sys/types.h>
- #include <sys/utsname.h> /* for uname() */
- #include <scsi/scsi.h>
---
-2.8.2
-
diff --git a/sys-block/parted/metadata.xml b/sys-block/parted/metadata.xml
deleted file mode 100644
index 2011c011..00000000
--- a/sys-block/parted/metadata.xml
+++ /dev/null
@@ -1,20 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>livecd@gentoo.org</email>
- <name>Gentoo LiveCD Project</name>
- </maintainer>
- <use>
- <flag name="device-mapper">
- Enable device-mapper support from <pkg>sys-fs/lvm2</pkg> in parted
- </flag>
- <flag name="debug">
- Enable debugging as encouraged by upstream: [The default configuration]
- includes --enable-debug (by default), which contains many assertions.
- Obviously, these "waste" space, but in the past, they have caught
- potentially dangerous bugs before they would have done damage, so we think
- it's worth it. Also, it means we get more bug reports ;)
- </flag>
- </use>
-</pkgmetadata>
diff --git a/sys-block/parted/parted-3.2-r2.ebuild b/sys-block/parted/parted-3.2-r2.ebuild
deleted file mode 100644
index 1a934862..00000000
--- a/sys-block/parted/parted-3.2-r2.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit autotools eutils flag-o-matic
-
-DESCRIPTION="Create, destroy, resize, check, copy partitions and file systems"
-HOMEPAGE="https://www.gnu.org/software/parted"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~mips ppc x86"
-IUSE="+debug device-mapper nls readline selinux static-libs"
-RESTRICT="test"
-
-# specific version for gettext needed
-# to fix bug 85999
-RDEPEND="
- >=sys-fs/e2fsprogs-1.27
- device-mapper? ( >=sys-fs/lvm2-2.02.45 )
- readline? ( >=sys-libs/readline-5.2:0= >=sys-libs/ncurses-5.7-r7:0= )
- selinux? ( sys-libs/libselinux )
- elibc_uclibc? ( dev-libs/libiconv )
-"
-DEPEND="
- ${RDEPEND}
- nls? ( >=sys-devel/gettext-0.12.1-r2 )
- virtual/pkgconfig
-"
-PATCHES=(
- "${FILESDIR}"/${PN}-3.2-devmapper.patch
- "${FILESDIR}"/${PN}-3.2-po4a-mandir.patch
- "${FILESDIR}"/${PN}-3.2-fix-resizing-FAT16.patch
- "${FILESDIR}"/${PN}-3.2-sysmacros.patch
- "${FILESDIR}"/${PN}-3.2-fix-includes.patch
-)
-
-src_prepare() {
- default
-
- eautoreconf
-}
-
-src_configure() {
- use elibc_uclibc && append-libs -liconv
- econf \
- $(use_enable debug) \
- $(use_enable device-mapper) \
- $(use_enable nls) \
- $(use_enable selinux) \
- $(use_enable static-libs static) \
- $(use_with readline) \
- --disable-rpath \
- --disable-silent-rules
-}
-
-DOCS=( AUTHORS BUGS ChangeLog NEWS README THANKS TODO doc/{API,FAT,USER.jp} )
-
-src_install() {
- default
-
- prune_libtool_files
-}
diff --git a/sys-block/parted/parted-3.2.ebuild b/sys-block/parted/parted-3.2.ebuild
deleted file mode 100644
index 55198ce3..00000000
--- a/sys-block/parted/parted-3.2.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools eutils
-
-DESCRIPTION="Create, destroy, resize, check, copy partitions and file systems"
-HOMEPAGE="https://www.gnu.org/software/parted"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~mips ppc x86"
-IUSE="+debug device-mapper nls readline selinux static-libs"
-RESTRICT="test"
-
-# specific version for gettext needed
-# to fix bug 85999
-RDEPEND="
- >=sys-fs/e2fsprogs-1.27
- >=sys-libs/ncurses-5.7-r7:0=
- device-mapper? ( >=sys-fs/lvm2-2.02.45 )
- readline? ( >=sys-libs/readline-5.2:0= )
- selinux? ( sys-libs/libselinux )
-"
-DEPEND="
- ${RDEPEND}
- nls? ( >=sys-devel/gettext-0.12.1-r2 )
- virtual/pkgconfig
-"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PN}-3.2-devmapper.patch \
- "${FILESDIR}"/${PN}-3.2-po4a-mandir.patch \
- "${FILESDIR}"/${PN}-3.2-fix-includes.patch
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_enable debug) \
- $(use_enable device-mapper) \
- $(use_enable nls) \
- $(use_enable selinux) \
- $(use_enable static-libs static) \
- $(use_with readline) \
- --disable-rpath \
- --disable-silent-rules
-}
-
-DOCS=( AUTHORS BUGS ChangeLog NEWS README THANKS TODO doc/{API,FAT,USER.jp} )
-
-src_install() {
- default
- prune_libtool_files
-}