aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2019-08-28 17:30:59 -0500
committerJory Pratt <anarchy@gentoo.org>2019-08-28 17:30:59 -0500
commit1ac3e7ac4506890f9841c03c9108361bbd8f2837 (patch)
treeb2709ec58c5e97a08c68fdb947175110854c4688 /net-misc
parentnet-firewall/ebtables: Sync with latest changes from portage (diff)
downloadmusl-1ac3e7ac4506890f9841c03c9108361bbd8f2837.tar.gz
musl-1ac3e7ac4506890f9841c03c9108361bbd8f2837.tar.bz2
musl-1ac3e7ac4506890f9841c03c9108361bbd8f2837.zip
net-misc/radvd: add ver. 2.18 from portage tree
Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Jory Pratt <anarchy@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/radvd/Manifest1
-rw-r--r--net-misc/radvd/radvd-2.18.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/net-misc/radvd/Manifest b/net-misc/radvd/Manifest
index bdb319cb..8658b7a1 100644
--- a/net-misc/radvd/Manifest
+++ b/net-misc/radvd/Manifest
@@ -1 +1,2 @@
DIST radvd-2.17.tar.gz 214937 BLAKE2B 1eec22e09607c0396f9539aef203b76d5beca18d1fdf5aa0ff202dcb2ff0e36ed8af74fc7900eb7b16012bfb0672f9660f17c88c222ac0269947d3cf4a270db3 SHA512 117a42c2c007d730b956cf999ac281f50a1a9b57c9428fe0f860cb211ac234ec62f59fead244a80191aaa15ef4ce96fb7dba9bd1a3cb6c3b29f1b6897d7a6132
+DIST radvd-2.18.tar.gz 224183 BLAKE2B 4bacf9e17b78286a032ca5e6b6424aa8742d2e42b3a00a67e5d8beeda139a70a574e69c0d8fde2c2754b6e9c9e92a97dfb6a2a67b4b3ce91740aa8edee994c5e SHA512 b66068ec40d4f228f679946039d7c696bf611eb55b88cb37bbea5e748cf7cdda796dc0b12e0f1e54b26a6af21750c8714ea18a152ef932741c0f0a6a7a9de59a
diff --git a/net-misc/radvd/radvd-2.18.ebuild b/net-misc/radvd/radvd-2.18.ebuild
new file mode 100644
index 00000000..ed92b4e4
--- /dev/null
+++ b/net-misc/radvd/radvd-2.18.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd user eutils readme.gentoo-r1
+
+DESCRIPTION="Linux IPv6 Router Advertisement Daemon"
+HOMEPAGE="http://v6web.litech.org/radvd/"
+SRC_URI="http://v6web.litech.org/radvd/dist/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="kernel_FreeBSD selinux test"
+
+CDEPEND="dev-libs/libdaemon"
+DEPEND="${CDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig
+ test? ( dev-libs/check )"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-radvd )
+"
+DOCS=( CHANGES README TODO radvd.conf.example )
+
+PATCHES=( "${FILESDIR}"/"${PN}"-2.17-r1-musl.patch
+)
+
+pkg_setup() {
+ enewgroup radvd
+ enewuser radvd -1 -1 /dev/null radvd
+}
+
+src_configure() {
+ econf --with-pidfile=/run/radvd/radvd.pid \
+ --disable-silent-rules \
+ --with-systemdsystemunitdir=no \
+ $(use_with test check)
+}
+
+src_install() {
+ default
+
+ insinto /usr/share/doc/${PF}/html
+ doins INTRO.html
+
+ newinitd "${FILESDIR}"/${PN}-2.15.init ${PN}
+ newconfd "${FILESDIR}"/${PN}.conf ${PN}
+
+ systemd_dounit "${FILESDIR}"/${PN}.service
+
+ if use kernel_FreeBSD ; then
+ sed -i -e \
+ 's/^SYSCTL_FORWARD=.*$/SYSCTL_FORWARD=net.inet6.ip6.forwarding/g' \
+ "${D}"/etc/init.d/${PN} || die
+ fi
+
+ readme.gentoo_create_doc
+}
+
+DISABLE_AUTOFORMATTING=1
+DOC_CONTENTS="Please create a configuration file ${ROOT}etc/radvd.conf.
+See ${ROOT}usr/share/doc/${PF} for an example.
+
+grsecurity users should allow a specific group to read /proc
+and add the radvd user to that group, otherwise radvd may
+segfault on startup."