summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/weblocks/weblocks-0.8.2.ebuild')
-rw-r--r--dev-lisp/weblocks/weblocks-0.8.2.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/dev-lisp/weblocks/weblocks-0.8.2.ebuild b/dev-lisp/weblocks/weblocks-0.8.2.ebuild
deleted file mode 100644
index 589de97a..00000000
--- a/dev-lisp/weblocks/weblocks-0.8.2.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit common-lisp-3
-
-DESCRIPTION="Weblocks is a continuations-based web framework written in Common Lisp."
-HOMEPAGE="http://weblocks-framework.info/"
-SRC_URI="http://common-lisp.net/~sionescu/files/${P}.tar.bz2"
-
-LICENSE="LLGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="dev-lisp/closer-mop
- dev-lisp/metatilities
- dev-lisp/hunchentoot
- dev-lisp/cl-who
- dev-lisp/cl-ppcre
- dev-lisp/cl-json
- dev-lisp/puri
- dev-lisp/md5
- dev-lisp/fare-matcher
- dev-lisp/cl-cont
- dev-lisp/parenscript
- dev-lisp/anaphora
- dev-lisp/f-underscore
- dev-lisp/bordeaux-threads
- dev-lisp/cl-fad
- dev-lisp/clsql
- dev-lisp/elephant
- dev-lisp/cl-prevalence
- dev-lisp/rt
- dev-lisp/lift"
-
-CLSYSTEMS="${PN} ${PN}-test ${PN}-scripts ${PN}-store-test
- src/store/clsql/${PN}-clsql
- src/store/elephant/${PN}-elephant
- src/store/memory/${PN}-memory
- src/store/prevalence/${PN}-prevalence
- examples/${PN}-clsql-demo/${PN}-clsql-demo
- examples/${PN}-demo/${PN}-demo
- examples/${PN}-elephant-demo/${PN}-elephant-demo"
-
-src_install() {
- dodir "${CLSOURCEROOT}"/${PN}/scripts
- cp -a scripts/weblocks-core "${D}/${CLSOURCEROOT}"/${PN}/scripts || die
- rm -rf scripts/weblocks-core
- common-lisp-install-sources examples pub scripts src test
- common-lisp-install-asdf
- dodoc docs/*
-}