summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2022-04-02 17:26:32 +0200
committerUlrich Müller <ulm@gentoo.org>2022-04-02 17:26:32 +0200
commit06f7db4298c4d759aee0ae7df9d3ef5433db18af (patch)
tree748174678234cd97af89e8c4ef2be7bd7b4b3183
parentdev-lisp/hunchentoot: Drop ~sparc because of unkeyworded dependencies (diff)
downloadlisp-06f7db4298c4d759aee0ae7df9d3ef5433db18af.tar.gz
lisp-06f7db4298c4d759aee0ae7df9d3ef5433db18af.tar.bz2
lisp-06f7db4298c4d759aee0ae7df9d3ef5433db18af.zip
dev-lisp/restas: Drop ~sparc because of unkeyworded dependencies
Rename "slime" use flag to "emacs". Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--dev-lisp/restas/restas-0.1.4.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/dev-lisp/restas/restas-0.1.4.ebuild b/dev-lisp/restas/restas-0.1.4.ebuild
index efd4be59..9641e93f 100644
--- a/dev-lisp/restas/restas-0.1.4.ebuild
+++ b/dev-lisp/restas/restas-0.1.4.ebuild
@@ -1,31 +1,31 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit common-lisp-3 elisp-common eutils
+inherit common-lisp-3 elisp-common
MY_PV="version-${PV}"
DESCRIPTION="Common Lisp application server"
HOMEPAGE="https://github.com/archimag/restas"
SRC_URI="https://github.com/archimag/restas/archive/${MY_PV}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
LICENSE="LLGPL-2.1"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="doc slime"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc emacs"
RDEPEND=" >=dev-lisp/cl-routes-0.2.2
dev-lisp/alexandria
>=dev-lisp/hunchentoot-1.2.0
- slime? ( dev-lisp/closer-mop )"
+ emacs? ( dev-lisp/closer-mop )"
-S="${WORKDIR}/${PN}-${MY_PV}"
SITEFILE=70${PN}-gentoo.el
src_compile () {
- if use slime ; then
+ if use emacs ; then
elisp-compile slime/${PN}.el || die "Cannot compile elisp files"
fi
}
@@ -36,16 +36,16 @@ src_install() {
doinitd "${FILESDIR}"/restas.lo || die "doinitd failed"
- if use slime; then
+ if use emacs; then
elisp-install ${PN} slime/${PN}.el || die "Cannot install elisp sources"
elisp-site-file-install "${FILESDIR}"/${SITEFILE} || die "Cannot install elisp site file"
fi
}
pkg_postinst() {
- use slime && elisp-site-regen
+ use emacs && elisp-site-regen
}
pkg_postrm() {
- use slime && elisp-site-regen
+ use emacs && elisp-site-regen
}