summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--0000_README4
-rw-r--r--1098_linux-6.1.99.patch37
2 files changed, 41 insertions, 0 deletions
diff --git a/0000_README b/0000_README
index 67ef8e56..6e536b9a 100644
--- a/0000_README
+++ b/0000_README
@@ -435,6 +435,10 @@ Patch: 1097_linux-6.1.98.patch
From: https://www.kernel.org
Desc: Linux 6.1.98
+Patch: 1098_linux-6.1.99.patch
+From: https://www.kernel.org
+Desc: Linux 6.1.99
+
Patch: 1500_XATTR_USER_PREFIX.patch
From: https://bugs.gentoo.org/show_bug.cgi?id=470644
Desc: Support for namespace user.pax.* on tmpfs.
diff --git a/1098_linux-6.1.99.patch b/1098_linux-6.1.99.patch
new file mode 100644
index 00000000..b548a275
--- /dev/null
+++ b/1098_linux-6.1.99.patch
@@ -0,0 +1,37 @@
+diff --git a/Makefile b/Makefile
+index c9a630cdb2ec2..c12da8fcb089b 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,7 @@
+ # SPDX-License-Identifier: GPL-2.0
+ VERSION = 6
+ PATCHLEVEL = 1
+-SUBLEVEL = 98
++SUBLEVEL = 99
+ EXTRAVERSION =
+ NAME = Curry Ramen
+
+diff --git a/drivers/usb/host/xhci-ring.c b/drivers/usb/host/xhci-ring.c
+index be5b0ff2966fe..7549c430c4f01 100644
+--- a/drivers/usb/host/xhci-ring.c
++++ b/drivers/usb/host/xhci-ring.c
+@@ -2631,17 +2631,16 @@ static int handle_tx_event(struct xhci_hcd *xhci,
+ else
+ xhci_handle_halted_endpoint(xhci, ep, 0, NULL,
+ EP_SOFT_RESET);
+- break;
++ goto cleanup;
+ case COMP_RING_UNDERRUN:
+ case COMP_RING_OVERRUN:
+ case COMP_STOPPED_LENGTH_INVALID:
+- break;
++ goto cleanup;
+ default:
+ xhci_err(xhci, "ERROR Transfer event for unknown stream ring slot %u ep %u\n",
+ slot_id, ep_index);
+ goto err_out;
+ }
+- return 0;
+ }
+
+ /* Count current td numbers if ep->skip is set */