aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMu Qiao <qiaomuf@gentoo.org>2011-06-26 20:27:46 +0800
committerMu Qiao <qiaomuf@gentoo.org>2011-06-26 20:27:46 +0800
commitb7ff827783049072f8afefad626522e39c092511 (patch)
treea780e7b362036388040f990f372a64496a8e67a2 /scripts
parentMerge remote-tracking branch 'mu/fix_arithmetic' (diff)
parentParser: use lexer rule to parse singled quoted string (diff)
downloadlibbash-b7ff827783049072f8afefad626522e39c092511.tar.gz
libbash-b7ff827783049072f8afefad626522e39c092511.tar.bz2
libbash-b7ff827783049072f8afefad626522e39c092511.zip
Merge branch 'mu/native_code'
Conflicts: Makefile.am bashast/features_script/features.sh.ast bashast/gunit/simp_command.gunit scripts/command_execution.bash test/verify_error_output_test.sh
Diffstat (limited to 'scripts')
-rw-r--r--scripts/command_execution.bash1
-rw-r--r--scripts/command_execution.bash.result1
-rw-r--r--scripts/here_document.ast3
-rw-r--r--scripts/here_document.sh5
4 files changed, 10 insertions, 0 deletions
diff --git a/scripts/command_execution.bash b/scripts/command_execution.bash
index d485d57..76e9c4c 100644
--- a/scripts/command_execution.bash
+++ b/scripts/command_execution.bash
@@ -56,3 +56,4 @@ shopt -p
printf "%s %s\n" abc def
printf "%s %s\n" $FOO001, def
((FOO010=1))
+echo "abc #av### ##" # for comment
diff --git a/scripts/command_execution.bash.result b/scripts/command_execution.bash.result
index 280798b..5f9bede 100644
--- a/scripts/command_execution.bash.result
+++ b/scripts/command_execution.bash.result
@@ -55,6 +55,7 @@ shopt -u sourcepath
shopt -u xpg_echo
abc def
hello, def
+abc #av### ##
DEFAULTED=yes
FOO001=hello
FOO002=Hello World
diff --git a/scripts/here_document.ast b/scripts/here_document.ast
new file mode 100644
index 0000000..ca0781c
--- /dev/null
+++ b/scripts/here_document.ast
@@ -0,0 +1,3 @@
+(LIST (COMMAND (STRING cat) (<< (STRING blah
+ blah
+) (REDIR > (STRING / dev / null)))) (COMMAND (STRING echo) (STRING hi)))
diff --git a/scripts/here_document.sh b/scripts/here_document.sh
new file mode 100644
index 0000000..2cc15d4
--- /dev/null
+++ b/scripts/here_document.sh
@@ -0,0 +1,5 @@
+cat<< _EOF_.abc >/dev/null
+blah
+blah
+_EOF_.abc
+echo hi