aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMu Qiao <qiaomuf@gentoo.org>2011-08-04 16:22:47 +0800
committerMu Qiao <qiaomuf@gentoo.org>2011-08-04 22:15:15 +0800
commit2757afdb7d447d1e40904ad22dc2712c15ea8714 (patch)
treec902aa256e46c01866508ee8c68cc76ac236032c
parentDoc: generate docs for public headers (diff)
downloadlibbash-2757afdb7d447d1e40904ad22dc2712c15ea8714.tar.gz
libbash-2757afdb7d447d1e40904ad22dc2712c15ea8714.tar.bz2
libbash-2757afdb7d447d1e40904ad22dc2712c15ea8714.zip
Doc: create a doc folder for libbash documentation
-rw-r--r--.gitignore2
-rw-r--r--Doxyfile2
-rw-r--r--Makefile.am2
-rw-r--r--README5
-rw-r--r--doc/coding_standard/coding_standard.tex (renamed from coding_standard/coding_standard.tex)0
-rw-r--r--doc/doxygen.am (renamed from doxygen.am)0
6 files changed, 6 insertions, 5 deletions
diff --git a/.gitignore b/.gitignore
index 311384d..f550a92 100644
--- a/.gitignore
+++ b/.gitignore
@@ -66,4 +66,4 @@ libtool
ltmain.sh
INSTALL
test_coverage/
-docs/
+doxygen-doc/
diff --git a/Doxyfile b/Doxyfile
index 88f83c4..9d070e4 100644
--- a/Doxyfile
+++ b/Doxyfile
@@ -38,7 +38,7 @@ PROJECT_NUMBER = 0.1
# If a relative path is entered, it will be relative to the location
# where doxygen was started. If left blank the current directory will be used.
-OUTPUT_DIRECTORY = docs
+OUTPUT_DIRECTORY = doxygen-doc
# If the CREATE_SUBDIRS tag is set to YES, then doxygen will create
# 4096 sub-directories (in 2 levels) under the output directory of each output
diff --git a/Makefile.am b/Makefile.am
index 9a11e03..3ca0e08 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,7 +19,7 @@
# Makefile.am for libbash
# Author: Nathan Eloe
###############################################
-include doxygen.am
+include doc/doxygen.am
ACLOCAL_AMFLAGS = -I m4
diff --git a/README b/README
index b3ca119..437c2b1 100644
--- a/README
+++ b/README
@@ -31,8 +31,9 @@ include/: public headers
utils/: some utilities that built on libbash
test/: some general tests for libbash
scripts/: some bash scripts or ebuilds for testing
-coding_standard/: LaTeX coding standard for the project
-docs/: output folder for Doxygen generated documentation
+doc/: documentation for libbash
+doc/coding_standard/: LaTeX coding standard for the project
+doxygen-doc/: output folder for Doxygen generated documentation
Build Instructions:
diff --git a/coding_standard/coding_standard.tex b/doc/coding_standard/coding_standard.tex
index 469c523..469c523 100644
--- a/coding_standard/coding_standard.tex
+++ b/doc/coding_standard/coding_standard.tex
diff --git a/doxygen.am b/doc/doxygen.am
index 420049e..420049e 100644
--- a/doxygen.am
+++ b/doc/doxygen.am