summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDetlev Casanova <detlev.casanova@gmail.com>2010-07-18 21:39:29 +0200
committerDetlev Casanova <detlev.casanova@gmail.com>2010-07-18 21:39:29 +0200
commit9eb908dc1bc6a8e46dbfdbd82aa003a62495e6ce (patch)
treef63601b9f8b3f2f165b680ceaf3bd2ccd8e8cc39
parentAdd the c-layman ebuild (diff)
parentRe-version everything to -8888 so it does not conflict with any other ebuilds... (diff)
downloadkuroo-9eb908dc1bc6a8e46dbfdbd82aa003a62495e6ce.tar.gz
kuroo-9eb908dc1bc6a8e46dbfdbd82aa003a62495e6ce.tar.bz2
kuroo-9eb908dc1bc6a8e46dbfdbd82aa003a62495e6ce.zip
Merge branch 'master' of git+ssh://git.overlays.gentoo.org/proj/kuroo
-rw-r--r--app-portage/layman/ChangeLog18
-rw-r--r--app-portage/layman/Manifest3
-rw-r--r--app-portage/layman/layman-8888.ebuild107
-rw-r--r--app-portage/layman/metadata.xml16
4 files changed, 144 insertions, 0 deletions
diff --git a/app-portage/layman/ChangeLog b/app-portage/layman/ChangeLog
new file mode 100644
index 0000000..483fa92
--- /dev/null
+++ b/app-portage/layman/ChangeLog
@@ -0,0 +1,18 @@
+# ChangeLog for app-portage/layman
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: Exp $
+
+ 17 Jul 2010; Brian Dolbec <brian.dolbec@gmail.com> re-version
+ this live ebuild to layman-8888 so it does not conflict with other versions.
+ It also makes it easier to spec on only this version for other development
+ packages.
+
+
+ 17 Jul 2010; Brian Dolbec <brian.dolbec@gmail.com> fix the ebuild
+ to use the proper git branch.
+
+
+*layman-9999 (17 Jul 2010)
+
+ 17 Jul 2010; Brian Dolbec <brian.dolbec@gmail.com> +layman-9999.ebuild:
+ initial copy/edit of the layman-9999.ebuild for the api development branch
diff --git a/app-portage/layman/Manifest b/app-portage/layman/Manifest
new file mode 100644
index 0000000..cf5f2f5
--- /dev/null
+++ b/app-portage/layman/Manifest
@@ -0,0 +1,3 @@
+EBUILD layman-8888.ebuild 2813 RMD160 f9bfc014839d4ba0afa4c4f3973d79b1e41c0e25 SHA1 98e73b0e1ff4b1c4f5b35f03296693b2767b0de5 SHA256 9329e9e383fd95004750c625b54ffe302de828f37a839fe93d7b9efd74eb155d
+MISC ChangeLog 763 RMD160 e2ace04f2d23ba8c8b1d61188991ba5791763b3f SHA1 77e900b5cda885f182db3e2e81b28f25cc01c9e0 SHA256 0d86535c921d968789dd80dc8278ead325fa5fb09d916712a4ed4bff1a5e08d9
+MISC metadata.xml 694 RMD160 2d94d6fe07b5d1c0dbff3721e8cdadf01d4f1c7e SHA1 af01ebe23677e8eb5535ad6c21984754e7497de0 SHA256 d4e6382743033a5e00938d1d494aa6258486cd53cba68b80ba0df6dc296d4843
diff --git a/app-portage/layman/layman-8888.ebuild b/app-portage/layman/layman-8888.ebuild
new file mode 100644
index 0000000..a091651
--- /dev/null
+++ b/app-portage/layman/layman-8888.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+EGIT_BRANCH="api"
+
+inherit eutils distutils git
+
+DESCRIPTION="An experimental development version of layman, a python script for retrieving gentoo overlays."
+HOMEPAGE="http://dev.gentooexperimental.org/~dol-sen/ http://layman.sourceforge.net"
+SRC_URI=""
+EGIT_REPO_URI="http://dev.gentooexperimental.org/~dol-sen/git/layman.git/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="bazaar cvs darcs git mercurial subversion test"
+
+COMMON_DEPS="dev-lang/python[xml]"
+DEPEND="${COMMON_DEPS}
+ test? ( dev-vcs/subversion )
+ app-text/xmlto"
+RDEPEND="${COMMON_DEPS}
+ bazaar? ( dev-vcs/bzr )
+ cvs? ( dev-vcs/cvs )
+ darcs? ( dev-vcs/darcs )
+ git? ( dev-vcs/git )
+ mercurial? ( dev-vcs/mercurial )
+ subversion? (
+ || (
+ >=dev-vcs/subversion-1.5.4[webdav-neon]
+ >=dev-vcs/subversion-1.5.4[webdav-serf]
+ )
+ )"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+pkg_setup() {
+ if ! has_version dev-vcs/subversion; then
+ ewarn "You do not have dev-vcs/subversion installed!"
+ ewarn "While layman does not exactly depend on this"
+ ewarn "version control system you should note that"
+ ewarn "most available overlays are offered via"
+ ewarn "dev-vcs/subversion. If you do not install it"
+ ewarn "you will be unable to use these overlays."
+ ewarn
+ fi
+}
+
+src_test() {
+ testing() {
+ for suite in layman/tests/{dtest,external}.py ; do
+ PYTHONPATH="." "$(PYTHON)" ${suite} \
+ || die "test suite '${suite}' failed"
+ done
+ }
+ python_execute_function testing
+}
+
+src_compile() {
+ distutils_src_compile
+ emake -C doc || die "emake -C doc failed"
+}
+
+src_install() {
+ distutils_src_install
+
+ dodir /etc/layman
+
+ cp etc/layman.cfg "${D}"/etc/layman/
+
+ doman doc/layman.8
+ dohtml doc/layman.8.html
+
+ keepdir /var/lib/layman
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ einfo "You are now ready to add overlays into your system."
+ einfo
+ einfo " layman -L"
+ einfo
+ einfo "will display a list of available overlays."
+ einfo
+ elog "Select an overlay and add it using"
+ elog
+ elog " layman -a overlay-name"
+ elog
+ elog "If this is the very first overlay you add with layman,"
+ elog "you need to append the following statement to your"
+ elog "/etc/make.conf file:"
+ elog
+ elog " source /var/lib/layman/make.conf"
+ elog
+ elog "If you modify the 'storage' parameter in the layman"
+ elog "configuration file (/etc/layman/layman.cfg) you will"
+ elog "need to adapt the path given above to the new storage"
+ elog "directory."
+ elog
+ ewarn "Please add the 'source' statement to make.conf only AFTER "
+ ewarn "you added your first overlay. Otherwise portage will fail."
+ epause 5
+}
diff --git a/app-portage/layman/metadata.xml b/app-portage/layman/metadata.xml
new file mode 100644
index 0000000..e56b051
--- /dev/null
+++ b/app-portage/layman/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>brian.dolbec@gmail.com</email>
+ <name>Brian Dolbec (dol-sen)</name>
+ <description>This is an experimental version used to develop a public API for consumer apps.</description>
+</maintainer>
+<use>
+ <flag name='bazaar'>Support <pkg>dev-vcs/bzr</pkg> based overlays</flag>
+ <flag name='darcs'>Support <pkg>dev-vcs/darcs</pkg> based overlays</flag>
+ <flag name='git'>Support <pkg>dev-vcs/git</pkg> based overlays</flag>
+ <flag name='mercurial'>Support <pkg>dev-vcs/mercurial</pkg> based overlays</flag>
+</use>
+</pkgmetadata>