summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/ec2-api-tools/ec2-api-tools-1.3.24159.ebuild')
-rw-r--r--sys-cluster/ec2-api-tools/ec2-api-tools-1.3.24159.ebuild42
1 files changed, 20 insertions, 22 deletions
diff --git a/sys-cluster/ec2-api-tools/ec2-api-tools-1.3.24159.ebuild b/sys-cluster/ec2-api-tools/ec2-api-tools-1.3.24159.ebuild
index 5cc453e..b9aa958 100644
--- a/sys-cluster/ec2-api-tools/ec2-api-tools-1.3.24159.ebuild
+++ b/sys-cluster/ec2-api-tools/ec2-api-tools-1.3.24159.ebuild
@@ -2,35 +2,33 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: Exp $
-inherit eutils
+inherit eutils versionator
-PKG=${PN}-1.3-24159
+MY_PV=$(replace_version_separator 2 '-')
-DESCRIPTION="Amazon EC2 API Tools"
-SRC_URI="http://s3.amazonaws.com/ec2-downloads/${PKG}.zip"
-HOMEPAGE="http://developer.amazonwebservices.com"
-KEYWORDS="x86 amd64"
+DESCRIPTION="Amazon EC2 Command Line Tools"
+HOMEPAGE="http://developer.amazonwebservices.com/connect/entry.jspa?externalID=351&categoryID=88"
+SRC_URI="http://s3.amazonaws.com/ec2-downloads/${PN}-${MY_PV}.zip"
+KEYWORDS="~x86 ~amd64"
SLOT="0"
-LICENSE="commercial"
+LICENSE="as-is"
IUSE=""
-S=${WORKDIR}/${PKG}
+S=${WORKDIR}/${PN}-${MY_PV}
DEPEND="app-arch/unzip"
RDEPEND=">=virtual/jre-1.5"
src_install () {
- rm -rf ${S}/bin/*.cmd
- dodir /opt/${P}
- insinto /opt/${P}/lib
- doins -r ${S}/lib/*
- exeinto /opt/${P}/bin
- doexe ${S}/bin/*
- insinto /usr/bin
- for exe in ${S}/bin/*; do
- target="$(basename ${exe})"
- base="$(basename ${exe})"
- ln -s /opt/${P}/bin/${target} ${D}/usr/bin/${base}
- done
- dodir /etc/env.d
- echo "EC2_HOME=/opt/${P}" > ${D}/etc/env.d/99ec2-api-tools
+ dodir /opt/${PN}
+
+ insinto /opt/${PN}/lib
+ doins -r lib/*
+
+ exeinto /opt/${PN}/bin
+ doexe bin/*
+ rm -rf ${D}/opt/${PN}/bin/*.cmd
+
+ dodir /etc/env.d
+ echo "PATH=/opt/${PN}/bin" > ${D}/etc/env.d/99${PN}
+ echo "EC2_HOME=/opt/${PN}" >> ${D}/etc/env.d/99${PN}
}