summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py21
1 files changed, 21 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..b28221e
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,21 @@
+#!/usr/bin/env python
+# kernel-check -- Kernel security information
+# Copyright 2009-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+from distutils.core import setup
+
+__version__ = open("VERSION").read().strip()
+
+setup(
+ name='Kernel-check',
+ version=__version__,
+ description='Gentoo kernel tracking tool',
+ author='Bjoern Trop',
+ author_email='asym@gentoo.org',
+ url='http://www.python.org/sigs/distutils-sig/', #TODO
+ package_dir={'': 'src'},
+ packages=['kernelcheck', 'kernelcheck.lib'],
+ scripts=['bin/kernel-check']
+)
+