aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kontact/kontact-9999.ebuild')
-rw-r--r--kde-base/kontact/kontact-9999.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/kde-base/kontact/kontact-9999.ebuild b/kde-base/kontact/kontact-9999.ebuild
new file mode 100644
index 0000000000..4d5a208852
--- /dev/null
+++ b/kde-base/kontact/kontact-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="1"
+
+KMNAME=kdepim
+inherit kde4svn-meta
+
+DESCRIPTION="KDE personal information manager"
+KEYWORDS=""
+IUSE="debug htmlhandbook"
+
+DEPEND="app-crypt/gnupg
+ app-crypt/gpgme
+ >=kde-base/kontactinterfaces-${PV}:${SLOT}
+ >=kde-base/libkdepim-${PV}:${SLOT}"
+RDEPEND="${DEPEND}"
+
+KMLOADLIBS="libkdepim"
+KMSAVELIBS="true"
+
+# We remove plugins that are related to external kdepim programs. This way
+# kontact doesn't have to depend on all programs it has plugins for.
+#
+# xml targets from kmail/ are being uncommented by kde4overlay-meta.eclass
+KMEXTRACTONLY="libkdepim/
+ kmail/
+ kontact/plugins/akregator/
+ kontact/plugins/kaddressbook/
+ kontact/plugins/kjots/
+ kontact/plugins/kmail/
+ kontact/plugins/kmobiletools
+ kontact/plugins/knode/
+ kontact/plugins/knotes/
+ kontact/plugins/korganizer/
+ kontact/plugins/ktimetracker/
+ kontact/plugins/planner/
+ kontact/plugins/specialdates/
+ kontactinterfaces/"