aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-01-20 10:18:51 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-01-20 10:27:01 +0100
commita0326a510e0449e0be5ad30c3092822fb10579dc (patch)
treea484c61656c8640abf52aaef87094ed4490ab8ef /kde-plasma/kwayland-integration
parentkde-plasma/kwallet-pam: 5.27.49.9999 version bump (diff)
downloadkde-a0326a510e0449e0be5ad30c3092822fb10579dc.tar.gz
kde-a0326a510e0449e0be5ad30c3092822fb10579dc.tar.bz2
kde-a0326a510e0449e0be5ad30c3092822fb10579dc.zip
kde-plasma/kwayland-integration: 5.27.49.9999 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwayland-integration')
-rw-r--r--kde-plasma/kwayland-integration/kwayland-integration-5.27.49.9999.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/kde-plasma/kwayland-integration/kwayland-integration-5.27.49.9999.ebuild b/kde-plasma/kwayland-integration/kwayland-integration-5.27.49.9999.ebuild
new file mode 100644
index 0000000000..1aee01006f
--- /dev/null
+++ b/kde-plasma/kwayland-integration/kwayland-integration-5.27.49.9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.102.0
+QTMIN=5.15.7
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Provides KWindowSystem integration plugin for Wayland"
+HOMEPAGE="https://invent.kde.org/plasma/kwayland-integration"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS=""
+IUSE=""
+
+# dev-qt/qtgui: QtXkbCommonSupport is provided by either IUSE libinput or X
+# slot ops:
+# dev-qt/qtgui: QtXkbCommonSupportPrivate
+# dev-qt/qtwayland: Qt::WaylandClientPrivate (private/qwayland*_p.h) stuff
+# kde-frameworks/kwindowsystem: Various private headers
+DEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtgui-${QTMIN}:5=
+ || (
+ >=dev-qt/qtgui-${QTMIN}:5[libinput]
+ >=dev-qt/qtgui-${QTMIN}:5[X]
+ )
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtwayland-${QTMIN}:5=
+ >=kde-frameworks/kwayland-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5=
+ x11-libs/libxkbcommon
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ ecm_src_prepare
+ ecm_punt_kf_module IdleTime
+ cmake_comment_add_subdirectory autotests # only contains idletime test
+ cmake_run_in src cmake_comment_add_subdirectory idletime
+}