aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-12-16 12:05:42 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-12-16 12:09:52 +0100
commit215b99d98b8c965a1c8ae678e68f08ac085477d5 (patch)
tree33d539320287f0cdd6dce25add562e3f7ac53cd9 /kde-plasma/kwayland-integration
parentkde-plasma/kwayland-integration: add kde-invent upstream metadata (diff)
downloadkde-215b99d98b8c965a1c8ae678e68f08ac085477d5.tar.gz
kde-215b99d98b8c965a1c8ae678e68f08ac085477d5.tar.bz2
kde-215b99d98b8c965a1c8ae678e68f08ac085477d5.zip
kde-plasma/kwayland-integration: re-add 9999, update dependencies
Still being released with Plasma 6 as compatibility package for Qt5-based applications. Upstream commits: 796b104a8adf2a47b820b4ba35c10f2a6e576088 d5662e953992469cc9e1d1cba3c3f99e97202fe8 9b9b3e472950e0e97dffdeb5349ff7db59d7c131 4a3ae83979507598fae29d1b6d0a449779fda5eb Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwayland-integration')
-rw-r--r--kde-plasma/kwayland-integration/kwayland-integration-9999.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/kde-plasma/kwayland-integration/kwayland-integration-9999.ebuild b/kde-plasma/kwayland-integration/kwayland-integration-9999.ebuild
new file mode 100644
index 0000000000..abacb93e08
--- /dev/null
+++ b/kde-plasma/kwayland-integration/kwayland-integration-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.106.0
+QTMIN=5.15.9
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Provides KWindowSystem integration plugin for Wayland"
+HOMEPAGE="https://invent.kde.org/plasma/kwayland-integration"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS=""
+IUSE=""
+
+# dev-qt/qtgui: QtXkbCommonSupport is provided by either IUSE libinput or X
+# slot ops:
+# dev-qt/qtgui: QtXkbCommonSupportPrivate
+# dev-qt/qtwayland: Qt::WaylandClientPrivate (private/qwayland*_p.h) stuff
+# kde-frameworks/kwindowsystem: Various private headers
+RDEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtgui-${QTMIN}:5=
+ || (
+ >=dev-qt/qtgui-${QTMIN}:5[libinput]
+ >=dev-qt/qtgui-${QTMIN}:5[X]
+ )
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtwayland-${QTMIN}:5=
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5=
+ >=kde-plasma/kwayland-${KFMIN}:5
+ x11-libs/libxkbcommon
+"
+DEPEND="${RDEPEND}
+ dev-libs/plasma-wayland-protocols
+"
+BDEPEND="
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"