aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-06-01 08:36:47 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-06-02 20:01:45 +0200
commit34082a1e0e3595e844f7a4bbf1a9a322c4b8d56a (patch)
tree282d17e49c473a0cc633c1dbb2fbb2674d9f2be5 /kde-frameworks
parentkde-frameworks/kxmlgui: 6.3.0 version bump (diff)
downloadkde-34082a1e0e3595e844f7a4bbf1a9a322c4b8d56a.tar.gz
kde-34082a1e0e3595e844f7a4bbf1a9a322c4b8d56a.tar.bz2
kde-34082a1e0e3595e844f7a4bbf1a9a322c4b8d56a.zip
kde-frameworks/purpose: 6.3.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/purpose/Manifest1
-rw-r--r--kde-frameworks/purpose/purpose-6.3.0.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/kde-frameworks/purpose/Manifest b/kde-frameworks/purpose/Manifest
new file mode 100644
index 0000000000..72a2b15f36
--- /dev/null
+++ b/kde-frameworks/purpose/Manifest
@@ -0,0 +1 @@
+DIST purpose-6.3.0.tar.xz 177216 BLAKE2B 7eb5190f4ab26ff458cfeb2635cd6c066483d03ab1eae253cb53c8c15775173280ca02273aefb629be7a2739740abfa3a7e071f081e61af59e410f3180a3b684 SHA512 012e9d6c30f64f76d800a3c90bda8426de45ce918a5f50c98daca06df0601e53083b8ae598a6bd37fe64e0c3cc84d9e606dba9e884ac9b41577f43fe6b9ae2df
diff --git a/kde-frameworks/purpose/purpose-6.3.0.ebuild b/kde-frameworks/purpose/purpose-6.3.0.ebuild
new file mode 100644
index 0000000000..644569f4d5
--- /dev/null
+++ b/kde-frameworks/purpose/purpose-6.3.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=6.6.2
+inherit ecm frameworks.kde.org optfeature xdg-utils
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64"
+IUSE="bluetooth kaccounts"
+
+# requires running environment
+RESTRICT="test"
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,network,widgets]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ =kde-frameworks/kconfig-${PVCUT}*:6
+ =kde-frameworks/kcoreaddons-${PVCUT}*:6
+ =kde-frameworks/ki18n-${PVCUT}*:6
+ =kde-frameworks/kio-${PVCUT}*:6
+ =kde-frameworks/kirigami-${PVCUT}*:6
+ =kde-frameworks/knotifications-${PVCUT}*:6
+ =kde-frameworks/kservice-${PVCUT}*:6
+ =kde-frameworks/prison-${PVCUT}*:6
+ kaccounts? (
+ kde-apps/kaccounts-integration:6
+ >=net-libs/accounts-qt-1.16_p20220803[qt6]
+ )
+"
+RDEPEND="${DEPEND}
+ !${CATEGORY}/${PN}:5[-kf6compat(-)]
+ >=kde-frameworks/kdeclarative-${PVCUT}:6
+ bluetooth? ( =kde-frameworks/bluez-qt-${PVCUT}*:6 )
+ kaccounts? ( >=net-libs/accounts-qml-0.7_p20231028[qt6] )
+"
+BDEPEND="kaccounts? ( dev-util/intltool )"
+
+src_prepare() {
+ ecm_src_prepare
+
+ use bluetooth ||
+ cmake_run_in src/plugins cmake_comment_add_subdirectory bluetooth
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package kaccounts KAccounts6)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Send through KDE Connect" kde-misc/kdeconnect
+ fi
+ ecm_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}