aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-10-04 23:38:43 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-10-05 00:00:03 +0200
commit17cb3758a8a13da88973e9c954f1052ea7587fe6 (patch)
treec7c8ee165e00111464ae0c345916950d7a14666d /kde-frameworks
parentkde-frameworks/ktextwidgets: 6.7.0 version bump (diff)
downloadkde-17cb3758a8a13da88973e9c954f1052ea7587fe6.tar.gz
kde-17cb3758a8a13da88973e9c954f1052ea7587fe6.tar.bz2
kde-17cb3758a8a13da88973e9c954f1052ea7587fe6.zip
kde-frameworks/kwallet: 6.7.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/kwallet/Manifest1
-rw-r--r--kde-frameworks/kwallet/kwallet-6.7.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/kde-frameworks/kwallet/Manifest b/kde-frameworks/kwallet/Manifest
new file mode 100644
index 0000000000..be258fea5e
--- /dev/null
+++ b/kde-frameworks/kwallet/Manifest
@@ -0,0 +1 @@
+DIST kwallet-6.7.0.tar.xz 353868 BLAKE2B 3799c6aa0978f4e5e0fb1afc694235e596d2c8df912ef1408455d21c1504e3cd67ae6be078791040edd63dfc8ac2abbf56c0aa7501fab7bd18fc1b8e35e5378e SHA512 acbc02873e8e73c0162f96b508df3ba4a58eb845d5e3970af1a243107701f52a317f350fefd907f27979a6b8ebe27d0d74f740ede395aef29774b25e03a259fe
diff --git a/kde-frameworks/kwallet/kwallet-6.7.0.ebuild b/kde-frameworks/kwallet/kwallet-6.7.0.ebuild
new file mode 100644
index 0000000000..9d62049854
--- /dev/null
+++ b/kde-frameworks/kwallet/kwallet-6.7.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=6.6.2
+inherit ecm frameworks.kde.org optfeature
+
+DESCRIPTION="Framework providing desktop-wide storage for passwords"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="gpg +man"
+
+DEPEND="
+ >=app-crypt/qca-2.3.1:2[qt6(-)]
+ dev-libs/libgcrypt:0=
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,widgets]
+ =kde-frameworks/kcolorscheme-${PVCUT}*:6
+ =kde-frameworks/kconfig-${PVCUT}*:6
+ =kde-frameworks/kcoreaddons-${PVCUT}*:6
+ =kde-frameworks/kcrash-${PVCUT}*:6
+ =kde-frameworks/kdbusaddons-${PVCUT}*:6
+ =kde-frameworks/ki18n-${PVCUT}*:6
+ =kde-frameworks/knotifications-${PVCUT}*:6
+ =kde-frameworks/kservice-${PVCUT}*:6
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:6
+ =kde-frameworks/kwindowsystem-${PVCUT}*:6[X]
+ gpg? ( app-crypt/gpgme:=[qt6(-)] )
+"
+RDEPEND="${DEPEND}
+ !${CATEGORY}/${PN}:5[-kf6compat(-)]
+"
+BDEPEND="man? ( >=kde-frameworks/kdoctools-${PVCUT}:6 )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package gpg Gpgmepp)
+ $(cmake_use_find_package man KF6DocTools)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Auto-unlocking after Plasma login" "kde-plasma/kwallet-pam"
+ optfeature "KWallet management" "kde-apps/kwalletmanager"
+ elog "For more information, read https://wiki.gentoo.org/wiki/KDE#KWallet"
+ fi
+ ecm_pkg_postinst
+}