aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-11-15 23:01:34 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-11-28 00:12:38 +0100
commitbdc498495ee603cbf7a82501e3fe10019e1e562d (patch)
treef938809ad8d0c45788f01cd249d72c97fb16562e /kde-frameworks/karchive
parentkde-frameworks/breeze-icons-rcc: add 9999 (diff)
downloadkde-bdc498495ee603cbf7a82501e3fe10019e1e562d.tar.gz
kde-bdc498495ee603cbf7a82501e3fe10019e1e562d.tar.bz2
kde-bdc498495ee603cbf7a82501e3fe10019e1e562d.zip
kde-frameworks/karchive: add 9999
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/karchive')
-rw-r--r--kde-frameworks/karchive/karchive-9999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/kde-frameworks/karchive/karchive-9999.ebuild b/kde-frameworks/karchive/karchive-9999.ebuild
new file mode 100644
index 0000000000..40695f3c8f
--- /dev/null
+++ b/kde-frameworks/karchive/karchive-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+QTMIN=6.6.0
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for reading, creation, and manipulation of various archive formats"
+
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS=""
+IUSE="+zstd"
+
+DEPEND="
+ app-arch/bzip2
+ app-arch/xz-utils
+ sys-libs/zlib
+ zstd? ( app-arch/zstd:= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ >=dev-qt/qttools-${QTMIN}:6[linguist]
+ zstd? ( virtual/pkgconfig )
+"
+
+src_prepare() {
+ ecm_src_prepare
+
+ # TODO: try to get a build switch upstreamed
+ if ! use zstd; then
+ sed -e "s/^pkg_check_modules.*LibZstd/#&/" -i CMakeLists.txt || die
+ fi
+}