aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-06-05 16:33:01 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-06-05 17:31:49 +0200
commit08a64275368310e13af88af97d74fd9151b08c15 (patch)
tree90975a91e391bcde2f163461d7f04840e4a166f8 /kde-frameworks/karchive
parentkde-frameworks/kapidox: 5.107.0 version bump (diff)
downloadkde-08a64275368310e13af88af97d74fd9151b08c15.tar.gz
kde-08a64275368310e13af88af97d74fd9151b08c15.tar.bz2
kde-08a64275368310e13af88af97d74fd9151b08c15.zip
kde-frameworks/karchive: 5.107.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/karchive')
-rw-r--r--kde-frameworks/karchive/Manifest1
-rw-r--r--kde-frameworks/karchive/karchive-5.107.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/kde-frameworks/karchive/Manifest b/kde-frameworks/karchive/Manifest
new file mode 100644
index 0000000000..32c864ca80
--- /dev/null
+++ b/kde-frameworks/karchive/Manifest
@@ -0,0 +1 @@
+DIST karchive-5.107.0.tar.xz 1017740 BLAKE2B 92efa513aaa55682a593ad031bfbcad96e9584ac3f5048b427aa1ff3cdc3efc9a8da3dc070eccd4b81522368a762b939960869da42ab5037171b9a9416a327b7 SHA512 b9bb1fd8f0bc00d603e2065a3655f25a0f4847e54853f4e699f1830069fb6ccfb7ec045bcd795cd5c8a30af3bc5748f399b69aad90f602889a0e87d5cf24f817
diff --git a/kde-frameworks/karchive/karchive-5.107.0.ebuild b/kde-frameworks/karchive/karchive-5.107.0.ebuild
new file mode 100644
index 0000000000..bb4a02521a
--- /dev/null
+++ b/kde-frameworks/karchive/karchive-5.107.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+QTMIN=5.15.9
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for reading, creation, and manipulation of various archive formats"
+
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="+zstd"
+
+DEPEND="
+ app-arch/bzip2
+ app-arch/xz-utils
+ sys-libs/zlib
+ zstd? ( app-arch/zstd:= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ >=dev-qt/linguist-tools-${QTMIN}:5
+ zstd? ( virtual/pkgconfig )
+"
+
+src_prepare() {
+ ecm_src_prepare
+
+ # TODO: try to get a build switch upstreamed
+ if ! use zstd; then
+ sed -e "s/^pkg_check_modules.*LibZstd/#&/" -i CMakeLists.txt || die
+ fi
+}