aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-08-13 22:17:34 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-08-13 22:17:34 +0200
commitd51d113fb6a578ea62f970ed1edaa4dc8bd12e17 (patch)
tree61d7adf147b69e770b9a70dafdf5fdce491df8d8 /kde-frameworks/extra-cmake-modules
parentcmake.eclass: If inherited from ecm.eclass, set ECM_DISABLE_APPSTREAMTEST (diff)
downloadkde-d51d113fb6a578ea62f970ed1edaa4dc8bd12e17.tar.gz
kde-d51d113fb6a578ea62f970ed1edaa4dc8bd12e17.tar.bz2
kde-d51d113fb6a578ea62f970ed1edaa4dc8bd12e17.zip
kde-frameworks/extra-cmake-modules: Add ECM_DISABLE_GIT
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/extra-cmake-modules')
-rw-r--r--kde-frameworks/extra-cmake-modules/extra-cmake-modules-9999.ebuild1
-rw-r--r--kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-6.5.0-disable-git-commit-hooks.patch31
2 files changed, 32 insertions, 0 deletions
diff --git a/kde-frameworks/extra-cmake-modules/extra-cmake-modules-9999.ebuild b/kde-frameworks/extra-cmake-modules/extra-cmake-modules-9999.ebuild
index c2397dad03..b86c3043d8 100644
--- a/kde-frameworks/extra-cmake-modules/extra-cmake-modules-9999.ebuild
+++ b/kde-frameworks/extra-cmake-modules/extra-cmake-modules-9999.ebuild
@@ -35,6 +35,7 @@ PATCHES=(
"${FILESDIR}/${PN}-5.112.0-disable-tests-requiring-PyQt5.patch" # bug 680256
"${FILESDIR}/${PN}-5.245.0-disable-qmlplugindump.patch"
"${FILESDIR}/${PN}-6.5.0-disable-appstreamtest.patch"
+ "${FILESDIR}/${PN}-6.5.0-disable-git-commit-hooks.patch"
)
python_check_deps() {
diff --git a/kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-6.5.0-disable-git-commit-hooks.patch b/kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-6.5.0-disable-git-commit-hooks.patch
new file mode 100644
index 0000000000..ad67e8233a
--- /dev/null
+++ b/kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-6.5.0-disable-git-commit-hooks.patch
@@ -0,0 +1,31 @@
+From ed944c8c85822c39dea66afdd1759dec093fd6b3 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Tue, 13 Aug 2024 22:15:40 +0200
+Subject: [PATCH] KDEGitCommitHooks.cmake: Add ECM_DISABLE_GIT to silence
+ useless Git search/hooks
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ kde-modules/KDEGitCommitHooks.cmake | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/kde-modules/KDEGitCommitHooks.cmake b/kde-modules/KDEGitCommitHooks.cmake
+index 6122cc7a..fef735a2 100644
+--- a/kde-modules/KDEGitCommitHooks.cmake
++++ b/kde-modules/KDEGitCommitHooks.cmake
+@@ -59,7 +59,12 @@ set(GIT_DIR "${CMAKE_SOURCE_DIR}/.git")
+ set(GIT_HOOKS_DIR "${GIT_DIR}/hooks")
+ set(JSON_SCHEMA_OUT "${GIT_HOOKS_DIR}/scripts/combined.schema.json")
+
++option (ECM_DISABLE_GIT "Disable Git commit hooks (for e.g. distro package build)" OFF)
++
+ function(KDE_CONFIGURE_GIT_PRE_COMMIT_HOOK)
++ if(ECM_DISABLE_GIT)
++ return()
++ endif()
+ set(_oneValueArgs "")
+ set(_multiValueArgs CHECKS CUSTOM_SCRIPTS)
+ cmake_parse_arguments(ARG "" "${_oneValueArgs}" "${_multiValueArgs}" ${ARGN})
+--
+2.45.2
+