aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-10-11 10:54:32 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-10-11 11:10:40 +0200
commit2d20687014bf4b5e872b266225afaf439e4afa6e (patch)
treeccbdbfa4f999d3f15a1e6e9987ba2baef0268ef8 /kde-apps/thumbnailers
parentkde-apps/svgpart: 23.08.2 version bump (diff)
downloadkde-2d20687014bf4b5e872b266225afaf439e4afa6e.tar.gz
kde-2d20687014bf4b5e872b266225afaf439e4afa6e.tar.bz2
kde-2d20687014bf4b5e872b266225afaf439e4afa6e.zip
kde-apps/thumbnailers: 23.08.2 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/thumbnailers')
-rw-r--r--kde-apps/thumbnailers/Manifest1
-rw-r--r--kde-apps/thumbnailers/thumbnailers-23.08.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/kde-apps/thumbnailers/Manifest b/kde-apps/thumbnailers/Manifest
new file mode 100644
index 0000000000..ef1159895c
--- /dev/null
+++ b/kde-apps/thumbnailers/Manifest
@@ -0,0 +1 @@
+DIST kdegraphics-thumbnailers-23.08.2.tar.xz 49424 BLAKE2B a2d0df9404cf2625c09372ae44ebbff0cc5d283974d3d376103630496b3159c036c1495acf31bdeb4203def175c44997d6c93a4b1ac6634a4b1fb5c126b637b3 SHA512 2f26121b9a34599c0fdfee8e4f406dd8be443766b5ce103895549e320b9d4aac715dacd0eb9bfdcd6c72032837d9bdcecad93cd063b39ebd40b2da52b0f21359
diff --git a/kde-apps/thumbnailers/thumbnailers-23.08.2.ebuild b/kde-apps/thumbnailers/thumbnailers-23.08.2.ebuild
new file mode 100644
index 0000000000..f2b2c66bce
--- /dev/null
+++ b/kde-apps/thumbnailers/thumbnailers-23.08.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_NAME="kdegraphics-thumbnailers"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.106.0
+QTMIN=5.15.9
+inherit ecm gear.kde.org
+
+DESCRIPTION="Thumbnail generators for Mobipocket, PDF/PS and RAW files"
+
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="mobi raw"
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=kde-frameworks/karchive-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ mobi? ( >=kde-apps/kdegraphics-mobipocket-${PVCUT}:5 )
+ raw? (
+ >=kde-apps/libkdcraw-${PVCUT}:5
+ >=kde-apps/libkexiv2-${PVCUT}:5
+ )
+"
+RDEPEND="${DEPEND}
+ mobi? ( !<kde-apps/kdegraphics-mobipocket-21.12.50:5[thumbnail] )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_MOBIPOCKET=$(usex !mobi)
+ $(cmake_use_find_package raw KF5KExiv2)
+ $(cmake_use_find_package raw KF5KDcraw)
+ )
+
+ ecm_src_configure
+}