aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-01-07 13:28:33 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-01-07 14:23:50 +0100
commit172cd2bb3a5620ae8d1ced3922406be67c0dd008 (patch)
tree9de9908370e54a6dcf4112f126a951139932de0a /kde-apps/mailcommon
parentkde-apps/libktnef: Add 24.02 stable branch (diff)
downloadkde-172cd2bb3a5620ae8d1ced3922406be67c0dd008.tar.gz
kde-172cd2bb3a5620ae8d1ced3922406be67c0dd008.tar.bz2
kde-172cd2bb3a5620ae8d1ced3922406be67c0dd008.zip
kde-apps/mailcommon: Add 24.02 stable branch
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/mailcommon')
-rw-r--r--kde-apps/mailcommon/mailcommon-24.02.49.9999.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/kde-apps/mailcommon/mailcommon-24.02.49.9999.ebuild b/kde-apps/mailcommon/mailcommon-24.02.49.9999.ebuild
new file mode 100644
index 0000000000..0716df4f0f
--- /dev/null
+++ b/kde-apps/mailcommon/mailcommon-24.02.49.9999.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_DESIGNERPLUGIN="true"
+ECM_QTHELP="true"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.246.0
+QTMIN=6.6.0
+inherit ecm gear.kde.org
+
+DESCRIPTION="Common mail library"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="6"
+KEYWORDS=""
+IUSE=""
+
+RESTRICT="test"
+
+DEPEND="
+ >=app-crypt/gpgme-1.23.1-r1:=[cxx,qt6]
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,widgets,xml]
+ >=dev-qt/qtmultimedia-${QTMIN}:6
+ >=kde-apps/akonadi-${PVCUT}:6
+ >=kde-apps/akonadi-contacts-${PVCUT}:6
+ >=kde-apps/akonadi-mime-${PVCUT}:6
+ >=kde-apps/kmailtransport-${PVCUT}:6
+ >=kde-apps/kmime-${PVCUT}:6
+ >=kde-apps/kpimtextedit-${PVCUT}:6
+ >=kde-apps/libkdepim-${PVCUT}:6
+ >=kde-apps/mailimporter-${PVCUT}:6
+ >=kde-apps/messagelib-${PVCUT}:6
+ >=kde-apps/pimcommon-${PVCUT}:6
+ >=kde-frameworks/karchive-${KFMIN}:6
+ >=kde-frameworks/kcodecs-${KFMIN}:6
+ >=kde-frameworks/kcompletion-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcontacts-${KFMIN}:6
+ >=kde-frameworks/kdbusaddons-${KFMIN}:6
+ >=kde-frameworks/kguiaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kiconthemes-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kitemmodels-${KFMIN}:6
+ >=kde-frameworks/kitemviews-${KFMIN}:6
+ >=kde-frameworks/ktextwidgets-${KFMIN}:6
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:6
+ >=kde-frameworks/kwindowsystem-${KFMIN}:6
+ >=kde-frameworks/kxmlgui-${KFMIN}:6
+ >=kde-frameworks/syntax-highlighting-${KFMIN}:6
+ >=media-libs/phonon-4.12.0[qt6]
+"
+RDEPEND="${DEPEND}"