aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-08-16 21:34:37 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-08-16 21:49:47 +0200
commitc238efe4133e0215726c6c1a531ba8a52a041329 (patch)
tree04bad0a5fd0cc88d0e9570f161b2d1b7fc6e2d62 /dev-libs
parentapp-office/merkuro: 24.08.0 version bump (diff)
downloadkde-c238efe4133e0215726c6c1a531ba8a52a041329.tar.gz
kde-c238efe4133e0215726c6c1a531ba8a52a041329.tar.bz2
kde-c238efe4133e0215726c6c1a531ba8a52a041329.zip
dev-libs/kopeninghours: 24.08.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/kopeninghours/Manifest1
-rw-r--r--dev-libs/kopeninghours/kopeninghours-24.08.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-libs/kopeninghours/Manifest b/dev-libs/kopeninghours/Manifest
index adac431231..2ba64d6e32 100644
--- a/dev-libs/kopeninghours/Manifest
+++ b/dev-libs/kopeninghours/Manifest
@@ -1 +1,2 @@
DIST kopeninghours-24.07.90.tar.xz 74624 BLAKE2B 9eb1b485ac3ab4b036c0e5e5f17d7c62c09ee16b1f5eb205c66e91aa0c2fed4e74017c6e82f79d022bfa5b07e79874e82d2089bdc129be1665ecbf9578e805c9 SHA512 63061d1ac1c1fbc436a41e0a1778a53fdf166527fff5e5f04eddf59e71ead1ec5c6139c30fe4fd58991f9eaf6e5810d4049eaa9af2e7e36a7ac65f776ba49332
+DIST kopeninghours-24.08.0.tar.xz 74612 BLAKE2B 66bf4bbc405e53746679ddb00aa3ab481e43ca041658bcf62875057881d079fc698563bcad49cd4c0a03f31fa9a3b8c027b3ff69d1fb6052cc73d2bffc539538 SHA512 a5f71f6c95d9a4ef9c78148ef960893240707a73faa917510a52fe821789cf88cc7bd46af43d9d46f83e36129e13ab4de42fa080198e36c49e6a84830ce39f9a
diff --git a/dev-libs/kopeninghours/kopeninghours-24.08.0.ebuild b/dev-libs/kopeninghours/kopeninghours-24.08.0.ebuild
new file mode 100644
index 0000000000..1084d8654d
--- /dev/null
+++ b/dev-libs/kopeninghours/kopeninghours-24.08.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="true"
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-3)
+KFMIN=6.5.0
+QTMIN=6.7.2
+PYTHON_COMPAT=( python3_{10..12} )
+inherit ecm gear.kde.org python-single-r1
+
+DESCRIPTION="Library for parsing and evaluating OSM opening hours expressions"
+HOMEPAGE="https://api.kde.org/kopeninghours/html/index.html
+https://invent.kde.org/libraries/kopeninghours"
+
+LICENSE="LGPL-2+"
+SLOT="6"
+KEYWORDS="~amd64 ~arm64"
+IUSE="python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ >=dev-libs/kpublictransport-${PVCUT}:6
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=kde-frameworks/kholidays-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ sys-libs/zlib
+ python? (
+ $(python_gen_cond_dep '
+ >=dev-libs/boost-1.70:=[python,${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+"
+BDEPEND="
+ app-alternatives/lex
+ app-alternatives/yacc
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-22.04.0-boostpython.patch )
+
+pkg_setup() {
+ ecm_pkg_setup
+ python_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBOOSTPYTHON_VERSION_MAJOR_MINOR=${EPYTHON}
+ $(cmake_use_find_package python Boost)
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ python_optimize
+}