summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/pinentry/pinentry-0.7.5.ebuild')
-rw-r--r--app-crypt/pinentry/pinentry-0.7.5.ebuild71
1 files changed, 0 insertions, 71 deletions
diff --git a/app-crypt/pinentry/pinentry-0.7.5.ebuild b/app-crypt/pinentry/pinentry-0.7.5.ebuild
deleted file mode 100644
index d3806061..00000000
--- a/app-crypt/pinentry/pinentry-0.7.5.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.7.5.ebuild,v 1.11 2009/05/02 20:34:01 swegener Exp $
-
-EAPI=1
-
-inherit qt3 multilib eutils
-
-DESCRIPTION="Collection of simple PIN or passphrase entry dialogs which utilize the Assuan protocol"
-HOMEPAGE="http://www.gnupg.org/aegypten/"
-SRC_URI="mirror://gnupg/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~hppa ~mips ppc ppc64 s390 sh ~sparc x86"
-IUSE="gtk ncurses qt3 caps"
-
-DEPEND="gtk? ( x11-libs/gtk+:2 )
- ncurses? ( sys-libs/ncurses )
- qt3? ( dev-qt/qt-meta:3 )
- !gtk? ( !qt3? ( !ncurses? ( sys-libs/ncurses ) ) )
- caps? ( sys-libs/libcap )"
-RDEPEND="${DEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${P}-grab.patch"
- epatch "${FILESDIR}/${PN}-gmem.patch"
-}
-
-src_compile() {
- local myconf=""
-
- if ! ( use qt3 || use gtk || use ncurses )
- then
- myconf="--enable-pinentry-curses --enable-fallback-curses"
- fi
-
- # Issues finding qt on multilib systems
- export QTLIB="${QTDIR}/$(get_libdir)"
-
- econf \
- --disable-dependency-tracking \
- --enable-maintainer-mode \
- --disable-pinentry-gtk \
- $(use_enable gtk pinentry-gtk2) \
- $(use_enable qt3 pinentry-qt) \
- $(use_enable ncurses pinentry-curses) \
- $(use_enable ncurses fallback-curses) \
- $(use_with caps libcap) \
- ${myconf} \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS ChangeLog NEWS README THANKS TODO || die "dodoc failed"
-}
-
-pkg_postinst() {
- elog "We no longer install pinentry-curses and pinentry-qt SUID root by default."
- elog "Linux kernels >=2.6.9 support memory locking for unprivileged processes."
- elog "The soft resource limit for memory locking specifies the limit an"
- elog "unprivileged process may lock into memory. You can also use POSIX"
- elog "capabilities to allow pinentry to lock memory. To do so activate the caps"
- elog "USE flag and add the CAP_IPC_LOCK capability to the permitted set of"
- elog "your users."
-}