summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-apps/krdc/krdc-4.14.3-r1.ebuild (renamed from kde-apps/krdc/krdc-4.14.3.ebuild)20
1 files changed, 7 insertions, 13 deletions
diff --git a/kde-apps/krdc/krdc-4.14.3.ebuild b/kde-apps/krdc/krdc-4.14.3-r1.ebuild
index a74d9674..291de393 100644
--- a/kde-apps/krdc/krdc-4.14.3.ebuild
+++ b/kde-apps/krdc/krdc-4.14.3-r1.ebuild
@@ -1,23 +1,20 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
KDE_HANDBOOK="optional"
inherit kde4-base
DESCRIPTION="KDE remote desktop connection (RDP and VNC) client"
-HOMEPAGE="https://www.kde.org/applications/internet/krdc/"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="debug jpeg +rdp telepathy vnc zeroconf"
+HOMEPAGE="https://apps.kde.org/en/krdc"
-#nx? ( >=net-misc/nxcl-0.9-r1 ) disabled upstream, last checked 4.13.1
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="debug +rdp telepathy vnc"
DEPEND="
- jpeg? ( virtual/jpeg:0 )
- telepathy? ( >=net-libs/telepathy-qt-0.9[qt4(-)] )
+ telepathy? ( net-libs/telepathy-qt:0-qt4 )
vnc? ( >=net-libs/libvncserver-0.9 )
- zeroconf? ( net-dns/avahi )
"
RDEPEND="${DEPEND}
rdp? ( >=net-misc/freerdp-1.1.0_beta1[X] )
@@ -27,11 +24,8 @@ PATCHES=( "${FILESDIR}/${PN}-4.13.1-freerdp.patch" )
src_configure() {
local mycmakeargs=(
- $(cmake-utils_use_with jpeg)
- $(cmake-utils_use_with telepathy TelepathyQt4)
- $(cmake-utils_use_with vnc LibVNCServer)
- $(cmake-utils_use_with zeroconf DNSSD)
+ -DWITH_TelepathyQt4=$(usex telepathy)
+ -DWITH_LibVNCServer=$(usex vnc)
)
-
kde4-base_src_configure
}