summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-12-06 02:51:47 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-12-06 11:09:09 +0100
commit7a85459610d705a86f83b9e55a12a34bbf02d9a9 (patch)
tree246ecaca946db1ef2de195b39fc5cd7431d4a3a1 /media-libs
parentmedia-libs/phonon: Import 4.10.2 (SLOT="0-qt4") from before last-rites (diff)
downloadkde-sunset-7a85459610d705a86f83b9e55a12a34bbf02d9a9.tar.gz
kde-sunset-7a85459610d705a86f83b9e55a12a34bbf02d9a9.tar.bz2
kde-sunset-7a85459610d705a86f83b9e55a12a34bbf02d9a9.zip
media-libs/phonon-gstreamer: Import 4.9.0-r3 (SLOT="0-qt4") from before last-rites
Add IUSE=minimal for compatibility w/ SLOT=5 Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/phonon-gstreamer/files/phonon-gstreamer-4.9.0-no-paused-on-zero-vol.patch30
-rw-r--r--media-libs/phonon-gstreamer/phonon-gstreamer-4.9.0-r3.ebuild56
2 files changed, 86 insertions, 0 deletions
diff --git a/media-libs/phonon-gstreamer/files/phonon-gstreamer-4.9.0-no-paused-on-zero-vol.patch b/media-libs/phonon-gstreamer/files/phonon-gstreamer-4.9.0-no-paused-on-zero-vol.patch
new file mode 100644
index 00000000..51887e99
--- /dev/null
+++ b/media-libs/phonon-gstreamer/files/phonon-gstreamer-4.9.0-no-paused-on-zero-vol.patch
@@ -0,0 +1,30 @@
+From fca0714fd37b2276eb663f649b6b9871a3973fa4 Mon Sep 17 00:00:00 2001
+From: Anthony Fieroni <bvbfan@abv.bg>
+Date: Mon, 10 Dec 2018 16:19:51 +0200
+Subject: Do not trigger paused state on 0 percentage
+
+Differential Revision: https://phabricator.kde.org/D14241
+
+Signed-off-by: Anthony Fieroni <bvbfan@abv.bg>
+---
+ gstreamer/pipeline.cpp | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/gstreamer/pipeline.cpp b/gstreamer/pipeline.cpp
+index 7025418..0d0b253 100644
+--- a/gstreamer/pipeline.cpp
++++ b/gstreamer/pipeline.cpp
+@@ -325,6 +325,11 @@ gboolean Pipeline::cb_buffering(GstBus *bus, GstMessage *gstMessage, gpointer da
+ gint percent = 0;
+ gst_message_parse_buffering(gstMessage, &percent);
+
++ // we should not trigger paused state or gstreamer will starts buffering again
++ if (percent == 0) {
++ return true;
++ }
++
+ debug() << Q_FUNC_INFO << "Buffering :" << percent;
+
+ // Instead of playing when the pipeline is still streaming, we pause
+--
+cgit v1.1
diff --git a/media-libs/phonon-gstreamer/phonon-gstreamer-4.9.0-r3.ebuild b/media-libs/phonon-gstreamer/phonon-gstreamer-4.9.0-r3.ebuild
new file mode 100644
index 00000000..ee6b966a
--- /dev/null
+++ b/media-libs/phonon-gstreamer/phonon-gstreamer-4.9.0-r3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="phonon-backend-gstreamer"
+MY_P=${MY_PN}-${PV}
+inherit cmake xdg-utils
+
+DESCRIPTION="Phonon GStreamer backend"
+HOMEPAGE="https://community.kde.org/Phonon"
+SRC_URI="mirror://kde/stable/phonon/${MY_PN}/${PV}/${MY_P}.tar.xz"
+
+LICENSE="LGPL-2.1+ || ( LGPL-2.1 LGPL-3 )"
+SLOT="0-qt4"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
+IUSE="alsa debug minimal +network"
+
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/libxml2:2
+ >=dev-qt/qtcore-4.8.7-r2:4[glib]
+ >=dev-qt/qtgui-4.8.7:4[glib]
+ >=dev-qt/qtopengl-4.8.7:4
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ media-libs/phonon:0-qt4
+ media-plugins/gst-plugins-meta:1.0[alsa?,ogg,vorbis]
+ virtual/opengl
+ network? ( media-plugins/gst-plugins-soup:1.0 )
+"
+RDEPEND="${DEPEND}
+ !<dev-qt/qtwebkit-4.10.4:4[gstreamer]
+ !<media-libs/phonon-gstreamer-4.10:0
+"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${P}-no-paused-on-zero-vol.patch" )
+
+src_prepare() {
+ cmake_src_prepare
+ use minimal && cmake_run_in gstreamer cmake_comment_add_subdirectory icons
+}
+
+src_configure() {
+ local mycmakeargs=( -DPHONON_BUILD_PHONON4QT5=OFF )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ use minimal || xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ use minimal || xdg_icon_cache_update
+}