summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-08-15 00:32:23 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-08-16 17:51:47 +0200
commit21e8d862edc7aa56fac82fae29e846eab8784178 (patch)
tree253bfd5793e199da3d7220c7b143beead8594161 /media-libs
parent*/*: Follow-up virtual/pam removal, switch to sys-libs/pam (diff)
downloadkde-sunset-21e8d862edc7aa56fac82fae29e846eab8784178.tar.gz
kde-sunset-21e8d862edc7aa56fac82fae29e846eab8784178.tar.bz2
kde-sunset-21e8d862edc7aa56fac82fae29e846eab8784178.zip
media-libs/qimageblitz: Import from Gentoo ebuild repo before last-rites
Required by kde-apps/okular. Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/qimageblitz/Manifest1
-rw-r--r--media-libs/qimageblitz/files/qimageblitz-0.0.6_p20131029-gcc.patch16
-rw-r--r--media-libs/qimageblitz/metadata.xml5
-rw-r--r--media-libs/qimageblitz/qimageblitz-0.0.6_p20131029.ebuild43
4 files changed, 65 insertions, 0 deletions
diff --git a/media-libs/qimageblitz/Manifest b/media-libs/qimageblitz/Manifest
new file mode 100644
index 00000000..a5e69100
--- /dev/null
+++ b/media-libs/qimageblitz/Manifest
@@ -0,0 +1 @@
+DIST qimageblitz-0.0.6_p20131029.tar.xz 43428 BLAKE2B 6a10f12236d759cb2999f807ae05345ad91ca2a3f965fa8ae6d38431a4a91439242ceac2facce67b46a5260cef11a4a5fdceccff73260235658830262fc909cc SHA512 2a32105aed52ea33fbd46702a2b7cdd9671efef9bb52209ede534abc95ac40dd9ae2bd22cf09b30a309337653c4a754c50ef3fe4ad0aad7d4ffd0b5994a85981
diff --git a/media-libs/qimageblitz/files/qimageblitz-0.0.6_p20131029-gcc.patch b/media-libs/qimageblitz/files/qimageblitz-0.0.6_p20131029-gcc.patch
new file mode 100644
index 00000000..922a2629
--- /dev/null
+++ b/media-libs/qimageblitz/files/qimageblitz-0.0.6_p20131029-gcc.patch
@@ -0,0 +1,16 @@
+--- a/blitz/CMakeLists.txt
++++ b/blitz/CMakeLists.txt
+@@ -31,12 +31,8 @@
+
+ if(HAVE_MMX)
+ if(NOT APPLE AND NOT WIN32)
++ enable_language(ASM)
+ set( blitz_LIB_SRCS ${blitz_LIB_SRCS} asm_scale.S )
+- add_custom_command(OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/asm_scale.o
+- COMMAND ${CMAKE_C_COMPILER} -c ${CMAKE_CURRENT_SOURCE_DIR}/asm_scale.S
+- DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/asm_scale.S )
+- set( blitz_LIB_EXTRA_SRCS ${CMAKE_CURRENT_BINARY_DIR}/asm_scale.o )
+- set(HAVE_EXTERNAL_ASM TRUE)
+ endif(NOT APPLE AND NOT WIN32)
+ endif(HAVE_MMX)
+ configure_file (config-processor.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-processor.h )
diff --git a/media-libs/qimageblitz/metadata.xml b/media-libs/qimageblitz/metadata.xml
new file mode 100644
index 00000000..7a38bb90
--- /dev/null
+++ b/media-libs/qimageblitz/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+</pkgmetadata>
diff --git a/media-libs/qimageblitz/qimageblitz-0.0.6_p20131029.ebuild b/media-libs/qimageblitz/qimageblitz-0.0.6_p20131029.ebuild
new file mode 100644
index 00000000..96e5ffaa
--- /dev/null
+++ b/media-libs/qimageblitz/qimageblitz-0.0.6_p20131029.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Graphical effect and filter library by KDE"
+HOMEPAGE="https://websvn.kde.org/trunk/kdesupport/qimageblitz/"
+SRC_URI="http://dev.gentoo.org/~asturm/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
+SLOT="0"
+IUSE="altivec cpu_flags_x86_3dnow cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 debug qt5"
+
+DEPEND="
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ )
+ !qt5? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-gcc.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DQT4_BUILD=$(usex !qt5)
+ -DHAVE_3DNOW=$(usex cpu_flags_x86_3dnow)
+ -DHAVE_MMX=$(usex cpu_flags_x86_mmx)
+ -DHAVE_SSE=$(usex cpu_flags_x86_sse)
+ -DHAVE_SSE2=$(usex cpu_flags_x86_sse2)
+ )
+ use ppc && mycmakeargs+=( -DHAVE_ALTIVEC=$(usex altivec) )
+
+ cmake-utils_src_configure
+}