summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-12-06 22:26:04 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-12-07 00:48:47 +0100
commitabf39af492f6e5498908c04fda8fd2fdff0c9b3b (patch)
treee6ed370deca756fc81e57c6491af9b9baa7cc054 /kde-apps
parentkde-apps/konq-plugins: Drop 4.14.3 (r0) (diff)
downloadkde-sunset-abf39af492f6e5498908c04fda8fd2fdff0c9b3b.tar.gz
kde-sunset-abf39af492f6e5498908c04fda8fd2fdff0c9b3b.tar.bz2
kde-sunset-abf39af492f6e5498908c04fda8fd2fdff0c9b3b.zip
kde-apps/klinkstatus: Switch USE tidy to app-text/tidy-html5, EAPI-6
Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps')
-rw-r--r--kde-apps/klinkstatus/files/klinkstatus-4.14.3-tidyhtml5.patch11
-rw-r--r--kde-apps/klinkstatus/klinkstatus-4.14.3-r1.ebuild38
2 files changed, 49 insertions, 0 deletions
diff --git a/kde-apps/klinkstatus/files/klinkstatus-4.14.3-tidyhtml5.patch b/kde-apps/klinkstatus/files/klinkstatus-4.14.3-tidyhtml5.patch
new file mode 100644
index 00000000..85efd746
--- /dev/null
+++ b/kde-apps/klinkstatus/files/klinkstatus-4.14.3-tidyhtml5.patch
@@ -0,0 +1,11 @@
+--- a/klinkstatus/src/tidy/tidyx.h 2008-07-28 18:04:32.000000000 +0200
++++ b/klinkstatus/src/tidy/tidyx.h 2020-12-06 22:19:30.793217209 +0100
+@@ -49,7 +49,7 @@
+ */
+
+ #include <tidy.h>
+-#include <buffio.h>
++#include <tidybuffio.h>
+
+ #include <config-tidy.h>
+
diff --git a/kde-apps/klinkstatus/klinkstatus-4.14.3-r1.ebuild b/kde-apps/klinkstatus/klinkstatus-4.14.3-r1.ebuild
new file mode 100644
index 00000000..9732f2cd
--- /dev/null
+++ b/kde-apps/klinkstatus/klinkstatus-4.14.3-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="optional"
+KMNAME="kdewebdev"
+inherit kde4-meta
+
+DESCRIPTION="KDE web development - link validity checker"
+HOMEPAGE="https://apps.kde.org/en/klinkstatus"
+
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="debug tidy"
+
+DEPEND="
+ $(add_kdeapps_dep kdepimlibs)
+ tidy? ( app-text/tidy-html5 )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-tidyhtml5.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_KdepimLibs=ON
+ -DWITH_LibTidy=$(usex tidy)
+ )
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ has_version dev-lang/ruby ||
+ elog "To use scripting in ${PN}, install dev-lang/ruby."
+}