summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin von Gagern <Martin.vGagern@gmx.net>2010-01-28 13:38:12 +0100
committerMartin von Gagern <Martin.vGagern@gmx.net>2010-01-28 13:38:12 +0100
commitbc9363813f3c7095bd864f5a80e27bf3c8f15f30 (patch)
treeee1374f267e167af788c84cccadbd40fe8f97caf /Documentation
parent[poppler] Transition from dev-libs/poppler-qt3 to app-text/poppler[qt3] (diff)
downloadkde-sunset-bc9363813f3c7095bd864f5a80e27bf3c8f15f30.tar.gz
kde-sunset-bc9363813f3c7095bd864f5a80e27bf3c8f15f30.tar.bz2
kde-sunset-bc9363813f3c7095bd864f5a80e27bf3c8f15f30.zip
[poppler] import_poppler helper script, and newly imported ebuilds.
Wrote a simple script to help maintaining our poppler overlay in sync with the main portage tree, but wtill have qt3 support added on top of that. The script discards any previous changes, simply imports the poppler ebuilds from main portage tree and then adjusts them for qt3 support using a bunch of sed commands. Ebuilds where no sed command applied will get dropped again. I didn't bother updating the ChangeLog, nor dropping patches not required by the set of ebuilds with modifications. I also didn't implement serious error checking, so the sed commands might e.g. use an IUSE without declaring it if the structure of the main portage ebuilds goes that way. To avoid such issues, the final diff is displayed to the maintainer and should be checked for sanity.
Diffstat (limited to 'Documentation')
-rwxr-xr-xDocumentation/maintainers/import_poppler25
-rw-r--r--Documentation/package.unmask/kde-3.51
2 files changed, 26 insertions, 0 deletions
diff --git a/Documentation/maintainers/import_poppler b/Documentation/maintainers/import_poppler
new file mode 100755
index 00000000..11febbb4
--- /dev/null
+++ b/Documentation/maintainers/import_poppler
@@ -0,0 +1,25 @@
+#!/bin/bash
+
+set -e
+cd "$(dirname "$0")"/../..
+
+# Clone poppler dir from main portage tree
+rm -r app-text/poppler
+cp -r "${PORTDIR:-/usr/portage}/app-text/poppler" app-text/
+
+# Make adjustments to ebuilds
+sed -i \
+ -e 's/^\(IUSE=.*\) qt4/\1 qt3 qt4/' \
+ -e 's/-DWITH_Qt3=OFF/$(cmake-utils_use_with qt3)/' \
+ -e 's/^\([ \t]*\)\(qt4? ( x11-libs\/qt-core:4\)/\1qt3? ( >=x11-libs\/qt-3.3:3 )\n\1\2/' \
+ app-text/poppler/*.ebuild
+
+# Drop all unmodified ebuilds, e.g. for older versions without qt4 USE flag
+for i in app-text/poppler/*.ebuild; do
+ cmp -s "$i" "${PORTDIR:-/usr/portage}/$i" && rm $i
+done
+
+# Redigest and show difference
+ebuild $(ls -1 app-text/poppler/*.ebuild | tail -n1) digest
+diff -ur "${PORTDIR:-/usr/portage}/app-text/poppler" app-text/poppler
+Documentation/maintainers/generate_unmask
diff --git a/Documentation/package.unmask/kde-3.5 b/Documentation/package.unmask/kde-3.5
index 2cbc3542..e4a0fd7e 100644
--- a/Documentation/package.unmask/kde-3.5
+++ b/Documentation/package.unmask/kde-3.5
@@ -58,6 +58,7 @@
=app-text/kchmviewer-3.1_p2-r1
=app-text/kding-0.4.3
=app-text/poppler-0.12.3-r2
+=app-text/poppler-0.12.3-r3
=dev-db/hk_classes-0.8.3
=dev-db/hk_classes-0.8.3-r1
=dev-db/knoda-0.8.3